Skip to content
Permalink
Browse files

debian packaging fixes

* enable globe on jessie
* add dependency on libqt4-sql-sqlite to qgis-provider (fixes #8662)
  • Loading branch information
jef-n committed Feb 22, 2014
1 parent f02591a commit 3f6543d93bae0955ef7b1c704fd4fc392e67549c
@@ -1,8 +1,10 @@
qgis (2.3.0) UNRELEASED; urgency=medium

* New development version 2.3 after branch of 2.2
* enable globe on jessie
* add dependency on libqt4-sql-sqlite to qgis-provider

-- Jürgen E. Fischer <jef@norbit.de> Sat, 22 Feb 2014 09:49:29 +0100
-- Jürgen E. Fischer <jef@norbit.de> Sun, 23 Feb 2014 11:36:30 +0100

qgis (2.2.0) unstable; urgency=medium

@@ -172,6 +172,7 @@ Package: qgis-providers
Architecture: any
Depends:
qgis-providers-common (= ${source:Version}),
libqt4-sql-sqlite,
${shlibs:Depends},
${misc:Depends}
Replaces: qgis (<= 1.6)
@@ -157,7 +157,11 @@ Description: Python bindings to QGIS - architecture-independent files

Package: qgis-providers
Architecture: any
Depends: qgis-providers-common (= ${source:Version}), ${shlibs:Depends}, ${misc:Depends}
Depends:
qgis-providers-common (= ${source:Version}),
libqt4-sql-sqlite,
${shlibs:Depends},
${misc:Depends}
Replaces: qgis (<= 1.6)
Breaks: qgis (<= 1.6)
Description: collection of data providers to QGIS
@@ -174,6 +174,7 @@ Package: qgis-providers
Architecture: any
Depends:
qgis-providers-common (= ${source:Version}),
libqt4-sql-sqlite,
${shlibs:Depends},
${misc:Depends}
Replaces: qgis (<= 1.6)
@@ -174,6 +174,7 @@ Package: qgis-providers
Architecture: any
Depends:
qgis-providers-common (= ${source:Version}),
libqt4-sql-sqlite,
${shlibs:Depends},
${misc:Depends}
Replaces: qgis (<= 1.6)
@@ -172,6 +172,7 @@ Package: qgis-providers
Architecture: any
Depends:
qgis-providers-common (= ${source:Version}),
libqt4-sql-sqlite,
${shlibs:Depends},
${misc:Depends}
Replaces: qgis (<= 1.6)
@@ -172,6 +172,7 @@ Package: qgis-providers
Architecture: any
Depends:
qgis-providers-common (= ${source:Version}),
libqt4-sql-sqlite,
${shlibs:Depends},
${misc:Depends}
Replaces: qgis (<= 1.6)
@@ -173,6 +173,7 @@ Package: qgis-providers
Architecture: any
Depends:
qgis-providers-common (= ${source:Version}),
libqt4-sql-sqlite,
${shlibs:Depends},
${misc:Depends}
Replaces: qgis (<= 1.6)
@@ -170,6 +170,7 @@ Package: qgis-providers
Architecture: any
Depends:
qgis-providers-common (= ${source:Version}),
libqt4-sql-sqlite,
${shlibs:Depends},
${misc:Depends}
Replaces: qgis (<= 1.6)
@@ -156,7 +156,11 @@ Description: Python bindings to QGIS - architecture-independent files

Package: qgis-providers
Architecture: any
Depends: qgis-providers-common (= ${source:Version}), ${shlibs:Depends}, ${misc:Depends}
Depends:
qgis-providers-common (= ${source:Version}),
libqt4-sql-sqlite,
${shlibs:Depends},
${misc:Depends}
Replaces: qgis (<= 1.6)
Breaks: qgis (<= 1.6)
Description: collection of data providers to QGIS
@@ -47,7 +47,8 @@ CMAKE_OPTS := \
-D WITH_MAPSERVER=TRUE \
-D MAPSERVER_SKIP_ECW=TRUE \
-D QGIS_CGIBIN_SUBDIR=/usr/lib/cgi-bin \
-D WITH_APIDOC=TRUE
-D WITH_APIDOC=TRUE \
-D WITH_GLOBE=TRUE

MAKEFLAGS += VERBOSE=YES

@@ -61,11 +62,6 @@ ifneq (,$(findstring $(DISTRIBUTION),"wheezy jessie sid precise raring saucy tru
CMAKE_OPTS += -D WITH_PYSPATIALITE=TRUE
endif

ifneq (,$(findstring $(DISTRIBUTION),"jessie"))
CMAKE_OPTS += -D WITH_GLOBE=FALSE
else
CMAKE_OPTS += -D WITH_GLOBE=TRUE
endif

ifneq (,$(findstring $(DISTRIBUTION),"jessie raring saucy trusty sid sid-oracle"))
CMAKE_OPTS += -D PYTHON_LIBRARY=/usr/lib/$(DEB_BUILD_MULTIARCH)/libpython2.7.so

0 comments on commit 3f6543d

Please sign in to comment.
You can’t perform that action at this time.