Skip to content
Permalink
Browse files

debian packaging update

(cherry picked from commit 750e60f)
  • Loading branch information
jef-n committed Aug 3, 2016
1 parent 7401dd3 commit 3fed3cf802aeff089fd3d1000150e431954bf28a
@@ -1,8 +1,11 @@
qgis (2.16.1) UNRELEASED; urgency=medium

* Release of 2.16.1
* drop support for debian wheezy and ubuntu wily
* add python-requests dependency for metasearch plugin
* lintian fixes

-- Jürgen E. Fischer <jef@norbit.de> Fri, 29 Jul 2016 14:04:56 +0200
-- Jürgen E. Fischer <jef@norbit.de> Wed, 03 Aug 2016 20:25:26 +0200

qgis (2.16.0) unstable; urgency=medium

@@ -1,3 +1,3 @@
#stretch sid jessie trusty wily xenial#9
#wheezy jessie#8
#stretch sid jessie trusty xenial#9
#jessie#8
#precise#7
@@ -6,32 +6,30 @@ Priority: optional
Build-Depends:
bison,
cmake (>= 2.8),
#wily# cmake (<< 3.3.2),
#sid stretch jessie wheezy trusty wily xenial# debhelper (>= 9),
#sid stretch jessie trusty wily xenial# dh-python,
#sid stretch jessie trusty xenial# debhelper (>= 9),
#sid stretch jessie trusty xenial# dh-python,
#precise# debhelper (>= 7),
flex,
grass-dev,
libexpat1-dev,
libfcgi-dev,
#sid stretch jessie trusty wily xenial# libgdal-dev (>= 1.10.1-0~),
#sid stretch jessie trusty xenial# libgdal-dev (>= 1.10.1-0~),
#precise# libgdal-dev (>= 1.9.0) | libgdal1-dev (<< 1.9.0),
#wheezy# libgdal1-dev,
gdal-bin,
python-gdal,
libgeos-dev (>= 3.0.0),
#jessie wheezy precise trusty wily# libgsl0-dev,
#jessie precise trusty# libgsl0-dev,
#sid stretch xenial# libgsl-dev,
libpq-dev,
libproj-dev,
libqt4-dev (>= 4.7.0),
libqt4-opengl-dev,
libqca2-dev,
libqca2-plugin-ossl,
#wheezy jessie precise trusty utopic vivid wily# libqtwebkit-dev,
#stretch jessie wheezy# libqwt-dev,
#precise trusty wily xenial sid# libqwt5-qt4-dev,
#sid stretch jessie wheezy trusty wily xenial# libqjson-dev,
#jessie precise trusty xenial# libqtwebkit-dev,
#stretch jessie# libqwt-dev,
#precise trusty xenial sid# libqwt5-qt4-dev,
#sid stretch jessie trusty xenial# libqjson-dev,
libspatialite-dev,
libsqlite3-dev,
libspatialindex-dev,
@@ -42,14 +40,13 @@ Build-Depends:
python-qt4-dev,
python-qt4-sql,
python-yaml, python-mock,
#stretch sid wily xenial# python-future,
#precise wheezy# python,
#stretch sid xenial# python-future,
#precise# python,
#precise# python-central (>= 0.5),
#wheezy# python-dev,
#sid stretch jessie trusty wily xenial# python-all (>= 2.6.6-3~), python-all-dev (>= 2.6.6-3~),
#sid stretch jessie wily xenial# pyqt4.qsci-dev,
#sid stretch jessie trusty wily xenial# python-pyspatialite,
#sid wheezy jessie stretch trusty wily xenial# python-nose2,
#sid stretch jessie trusty xenial# python-all (>= 2.6.6-3~), python-all-dev (>= 2.6.6-3~),
#sid stretch jessie xenial# pyqt4.qsci-dev,
#sid stretch jessie trusty xenial# python-pyspatialite,
#sid jessie stretch trusty xenial# python-nose2,
python-sip (>= 4.5.0),
python-sip-dev (>= 4.5.0),
libosgearth-dev,
@@ -67,11 +64,10 @@ Build-Depends:
libqt4-sql-sqlite, python-psycopg2
Build-Conflicts: libqgis-dev, qgis-dev
#sid stretch xenial#Standards-Version: 3.9.7
#jessie wily#Standards-Version: 3.9.6
#wheezy#Standards-Version: 3.9.3
#jessie#Standards-Version: 3.9.6
#precise trusty#Standards-Version: 3.8.4
#sid stretch jessie#X-Python-Version: >= 2.7, << 2.8
#wheezy precise trusty wily xenial#XS-Python-Version: current
#precise trusty xenial#XS-Python-Version: current
Vcs-Browser: https://github.com/qgis/QGIS/
Vcs-Git: https://github.com/qgis/QGIS.git
Homepage: http://qgis.org/
@@ -244,11 +240,10 @@ Section: libdevel
Depends:
grass-dev,
libexpat1-dev,
#sid stretch jessie trusty wily xenial# libgdal-dev (>= 1.10.1-0~),
#sid stretch jessie trusty xenial# libgdal-dev (>= 1.10.1-0~),
#precise# libgdal-dev (>= 1.9.0) | libgdal1-dev (<< 1.9.0),
#wheezy# libgdal1-dev,
libgeos-dev (>= 3.0.0),
#jessie wheezy precise trusty wily# libgsl0-dev,
#jessie precise trusty# libgsl0-dev,
#sid stretch xenial# libgsl-dev,
libpq-dev,
libproj-dev,
@@ -383,19 +378,20 @@ Depends:
python-markupsafe,
python-pygments,
python-dateutil,
python-requests,
python-tz,
python-six,
python-yaml,
#stretch sid wily xenial# python-future,
#sid stretch jessie trusty wily xenial# python-pyspatialite,
#stretch sid xenial# python-future,
#sid stretch jessie trusty xenial# python-pyspatialite,
libqgispython{QGIS_ABI},
${shlibs:Depends},
${python:Depends},
${misc:Depends},
${sip:Depends}
Provides: ${python:Provides}
Recommends: liblwgeom-dev
#wheezy precise#XB-Python-Version: ${python:Versions}
#precise#XB-Python-Version: ${python:Versions}
Description: Python bindings to QGIS
QGIS is a Geographic Information System (GIS) which manages, analyzes and
display databases of geographic information.
@@ -1,2 +1,3 @@
libqgis-analysis{QGIS_ABI}: no-symbols-control-file
libqgis-analysis{QGIS_ABI}: shlib-calls-exit
libqgis-analysis{QGIS_ABI}: spelling-error-in-binary usr/lib/libqgis_analysis.so.{QGIS_ABI} normalY normally
@@ -1,2 +1,4 @@
libqgis-core{QGIS_ABI}: shlib-calls-exit usr/lib/libqgis_core.so.{QGIS_ABI}
libqgis-core{QGIS_ABI}: no-symbols-control-file usr/lib/libqgis_core.so.{QGIS_ABI}
libqgis-core{QGIS_ABI}: spelling-error-in-binary usr/lib/libqgis_core.so.{QGIS_ABI} naM name
libqgis-core{QGIS_ABI}: spelling-error-in-binary usr/lib/libqgis_core.so.{QGIS_ABI} orderD ordered

This file was deleted.

@@ -0,0 +1,2 @@
libqgis-customwidgets: no-symbols-control-file
libqgis-customwidgets: spelling-error-in-binary {QT_PLUGIN_DIR}/designer/libqgis_customwidgets.so.{QGIS_ABI} YUr Your
@@ -7,5 +7,5 @@ usr/lib/python*/*-packages/qgis/networkanalysis/*
usr/lib/python*/*-packages/qgis/PyQt/*
usr/lib/python*/*-packages/qgis/server/*
usr/lib/python*/*-packages/qgis/testing/*
#wheezy precise#usr/lib/python*/*-packages/pyspatialite/*.py
#wheezy precise#usr/lib/python*/*-packages/pyspatialite/*.so
#precise#usr/lib/python*/*-packages/pyspatialite/*.py
#precise#usr/lib/python*/*-packages/pyspatialite/*.so
@@ -1 +1,2 @@
python-qgis: hardening-no-fortify-functions
python-qgis: spelling-error-in-binary usr/lib/python*/*-packages/qgis/*.so onself oneself
@@ -12,8 +12,13 @@ usr/share/qgis/doc/images
usr/share/qgis/doc/index.html
usr/share/qgis/doc/news
usr/share/qgis/doc/news.html
usr/share/qgis/doc/release-sponsors.html
usr/share/qgis/doc/style.css
usr/share/qgis/i18n/*
usr/share/qgis/images/*
usr/share/qgis/resources/spatialite.db
usr/share/qgis/resources/themes/*
usr/share/pixmaps/
usr/share/mime/packages/
usr/share/mimelnk/
usr/share/icons/hicolor/
@@ -1 +1,2 @@
usr/share/qgis/globe
usr/include/osgEarthDrivers/feature_qgis
@@ -1 +1,2 @@
usr/lib/qgis/plugins/libglobeplugin.so
usr/lib/libosgdb_osgearth_feature_qgis.so

This file was deleted.

@@ -0,0 +1 @@
qgis: spelling-error-in-binary usr/lib/qgis/qgis_help YUr Your
@@ -17,6 +17,6 @@ usr/lib/qgis/plugins/libvirtuallayerprovider.so
usr/lib/qgis/plugins/libwcsprovider.so
usr/lib/qgis/plugins/libwfsprovider.so
usr/lib/qgis/plugins/libwmsprovider.so
#sid stretch jessie wheezy trusty wily xenial#usr/lib/qgis/plugins/libarcgismapserverprovider.so
#sid stretch jessie wheezy trusty wily xenial#usr/lib/qgis/plugins/libarcgisfeatureserverprovider.so
#sid stretch jessie trusty xenial#usr/lib/qgis/plugins/libarcgismapserverprovider.so
#sid stretch jessie trusty xenial#usr/lib/qgis/plugins/libarcgisfeatureserverprovider.so
{QT_PLUGIN_DIR}/sqldrivers/libqsqlspatialite.so
@@ -0,0 +1,2 @@
qgis-providers: spelling-error-in-binary usr/lib/qgis/plugins/libdelimitedtextprovider.so AddD Add
qgis-providers: spelling-error-in-binary usr/lib/qgis/plugins/libpostgresprovider.so theRes there's
@@ -15,8 +15,4 @@ usr/lib/qgis/plugins/libtopolplugin.so
usr/lib/qgis/plugins/libgeometrycheckerplugin.so
usr/lib/qgis/plugins/libgeometrysnapperplugin.so
usr/lib/qgis/qgis_help
usr/share/pixmaps/
usr/share/applications/
usr/share/mime/packages/
usr/share/mimelnk/
usr/share/icons/hicolor/
usr/share/applications
@@ -1,4 +1,2 @@
# Build uses -D_FORTIFY_SOURCE=2, but hardening-check reports:
# Fortify Source functions: no, only unprotected functions found!
# unprotected: fgets
qgis: hardening-no-fortify-functions usr/lib/qgis/qgis_help
qgis: spelling-error-in-binary usr/bin/qgis.bin YUr Your
qgis: spelling-error-in-binary usr/lib/qgis/qgis_help YUr Your
@@ -34,7 +34,7 @@ ifneq (,$(findstring -oracle,$(DISTRIBUTION)))
WITH_ORACLE=1
endif

ifneq ($(DISTRIBUTION),$(findstring $(DISTRIBUTION),"wheezy jessie stretch precise trusty wily xenial"))
ifneq ($(DISTRIBUTION),$(findstring $(DISTRIBUTION),"jessie stretch precise trusty xenial"))
DISTRIBUTION := sid
endif

@@ -68,6 +68,7 @@ CMAKE_OPTS := \
-DQGIS_CGIBIN_SUBDIR=/usr/lib/cgi-bin \
-DWITH_APIDOC=TRUE \
-DGENERATE_QHP=TRUE \
-DSUPPRESS_SIP_WARNINGS=TRUE \
-DWITH_CUSTOM_WIDGETS=TRUE \
-DWITH_INTERNAL_HTTPLIB2=FALSE \
-DWITH_INTERNAL_JINJA2=FALSE \
@@ -106,7 +107,7 @@ else
CMAKE_OPTS += -DWITH_INTERNAL_NOSE2=FALSE -DWITH_INTERNAL_SIX=FALSE
endif

ifeq (,$(findstring $(DISTRIBUTION),"stretch sid wily xenial"))
ifeq (,$(findstring $(DISTRIBUTION),"stretch sid xenial"))
CMAKE_OPTS += -DWITH_INTERNAL_FUTURE=TRUE
else
CMAKE_OPTS += -DWITH_INTERNAL_FUTURE=FALSE
@@ -116,7 +117,7 @@ ifneq (,$(WITH_GLOBE))
CMAKE_OPTS += -DWITH_GLOBE=TRUE
endif

ifneq (,$(findstring $(DISTRIBUTION),"wheezy precise"))
ifneq (,$(findstring $(DISTRIBUTION),"precise"))
CMAKE_OPTS += -DWITH_PYSPATIALITE=TRUE
endif

@@ -132,7 +133,7 @@ ifneq (,$(findstring $(DISTRIBUTION),"sid"))
CMAKE_OPTS += -DGEOS_LIBRARY=/usr/lib/$(DEB_BUILD_MULTIARCH)/libgeos_c.so
endif

ifneq (,$(findstring $(DISTRIBUTION),"jessie stretch trusty wily xenial sid"))
ifneq (,$(findstring $(DISTRIBUTION),"jessie stretch trusty xenial sid"))
CMAKE_OPTS += -DPYTHON_LIBRARY=/usr/lib/$(DEB_BUILD_MULTIARCH)/libpython2.7.so
endif

@@ -170,7 +171,7 @@ else
CMAKE_OPTS += -DENABLE_TESTS=TRUE
endif

ifneq (,$(findstring $(DISTRIBUTION),"wheezy jessie stretch trusty sid"))
ifneq (,$(findstring $(DISTRIBUTION),"jessie stretch trusty sid"))
CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS)
CFLAGS := $(shell dpkg-buildflags --get CFLAGS) $(CPPFLAGS)
CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS) $(CPPFLAGS)
@@ -36,7 +36,7 @@ void QgsReaderThread::run()
QString help;

char buffer[1024];
while ( fgets( buffer, sizeof buffer, stdin ) )
while ( fgets( buffer, sizeof buffer - 1, stdin ) )
{
if ( strcmp( buffer, "EOH\n" ) == 0 )
{
@@ -236,7 +236,7 @@ bool DL_Dxf::getStrippedLine(std::string& s, unsigned int size, FILE *fp) {
// Only the useful part of the line
char* line;

line = fgets(wholeLine, size, fp);
line = fgets(wholeLine, size-1, fp);

if (line!=nullptr && line[0] != '\0') { // Evaluates to fgets() retval
// line == wholeLine at this point.
@@ -217,7 +217,7 @@ int main( int argc, char **argv )
G_suppress_masking(); // must be after G_set_window()
fd = G_open_cell_old( rast_opt->answer, "" );
// wait for coords from stdin
while ( fgets( buff, 100, stdin ) != 0 )
while ( fgets( buff, sizeof buff - 1, stdin ) != 0 )
{
if ( sscanf( buff, "%lf%lf", &x, &y ) != 2 )
{

0 comments on commit 3fed3cf

Please sign in to comment.
You can’t perform that action at this time.