Skip to content
Permalink
Browse files

QT_PLUGINS_DIR is still required

  • Loading branch information
nyalldawson committed Feb 8, 2020
1 parent 8eb3e58 commit 44b2518d9b892e9628e258aa5fd91d3da458ae05
Showing with 5 additions and 0 deletions.
  1. +5 −0 CMakeLists.txt
@@ -401,6 +401,11 @@ IF(WITH_CORE)
IF (APPLE)
FIND_PACKAGE(Qt5MacExtras REQUIRED)
ENDIF (APPLE)

# get the Qt plugins directory
GET_TARGET_PROPERTY(QMAKE_EXECUTABLE Qt5::qmake LOCATION)
EXEC_PROGRAM(${QMAKE_EXECUTABLE} ARGS "-query QT_INSTALL_PLUGINS" RETURN_VALUE return_code OUTPUT_VARIABLE QT_PLUGINS_DIR )

MESSAGE(STATUS "Found Qt version: ${Qt5Core_VERSION_STRING}")
IF (WITH_QUICK)
FIND_PACKAGE(Qt5Qml REQUIRED)

0 comments on commit 44b2518

Please sign in to comment.
You can’t perform that action at this time.