Skip to content

Commit

Permalink
'fix' weird automoc test problem on wily
Browse files Browse the repository at this point in the history
  • Loading branch information
jef-n committed Nov 22, 2015
1 parent 7840dbe commit 57c22e5
Showing 1 changed file with 3 additions and 8 deletions.
11 changes: 3 additions & 8 deletions tests/src/core/CMakeLists.txt
Original file line number Diff line number Diff line change
Expand Up @@ -57,9 +57,7 @@ ENDIF (APPLE)
#See: http://www.cmake.org/Wiki/CMake_RPATH_handling#No_relinking_and_full_RPATH_for_the_install_tree

MACRO (ADD_QGIS_TEST testname testsrc)
SET(qgis_${testname}_SRCS ${testsrc} ${util_SRCS})
SET(qgis_${testname}_MOC_CPPS ${testsrc})
ADD_EXECUTABLE(qgis_${testname} ${qgis_${testname}_SRCS})
ADD_EXECUTABLE(qgis_${testname} ${testsrc} ${util_SRCS})
SET_TARGET_PROPERTIES(qgis_${testname} PROPERTIES AUTOMOC TRUE)
TARGET_LINK_LIBRARIES(qgis_${testname}
${QT_QTXML_LIBRARY}
Expand All @@ -71,9 +69,6 @@ MACRO (ADD_QGIS_TEST testname testsrc)
${GDAL_LIBRARY}
qgis_core)
ADD_TEST(qgis_${testname} ${CMAKE_CURRENT_BINARY_DIR}/../../../output/bin/qgis_${testname} -maxwarnings 10000)
#SET_TARGET_PROPERTIES(qgis_${testname} PROPERTIES
# INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/${QGIS_LIB_DIR}
# INSTALL_RPATH_USE_LINK_PATH true )
ENDMACRO (ADD_QGIS_TEST)

#############################################################
Expand All @@ -86,7 +81,7 @@ ADD_QGIS_TEST(authconfigtest testqgsauthconfig.cpp)
ADD_QGIS_TEST(authmanagertest testqgsauthmanager.cpp)
ADD_QGIS_TEST(blendmodestest testqgsblendmodes.cpp)
ADD_QGIS_TEST(clippertest testqgsclipper.cpp)
ADD_QGIS_TEST(colorscheme testqgscolorscheme.cpp)
ADD_QGIS_TEST(colorschemetest testqgscolorscheme.cpp)
ADD_QGIS_TEST(colorschemeregistry testqgscolorschemeregistry.cpp)
ADD_QGIS_TEST(composerddtest testqgscomposerdd.cpp)
ADD_QGIS_TEST(composereffectstest testqgscomposereffects.cpp)
Expand Down Expand Up @@ -123,7 +118,7 @@ ADD_QGIS_TEST(featuretest testqgsfeature.cpp)
ADD_QGIS_TEST(fieldstest testqgsfields.cpp)
ADD_QGIS_TEST(fieldtest testqgsfield.cpp)
ADD_QGIS_TEST(filewritertest testqgsvectorfilewriter.cpp)
ADD_QGIS_TEST(fontmarkertest testqgsfontmarker.cpp)
ADD_QGIS_TEST(fontmarkertest2 testqgsfontmarker.cpp)
ADD_QGIS_TEST(fontutils testqgsfontutils.cpp)
ADD_QGIS_TEST(geometryimporttest testqgsgeometryimport.cpp)
ADD_QGIS_TEST(geometrytest testqgsgeometry.cpp)
Expand Down

4 comments on commit 57c22e5

@nyalldawson
Copy link
Collaborator

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

@jef-n thank you! Glad I wasn't the only one hitting this..

@jef-n
Copy link
Member Author

@jef-n jef-n commented on 57c22e5 Nov 23, 2015

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

@nyalldawson unfortunately it only partly helps - wily amd64 is still broken. really odd. seems to only affect wily - although unstable also has cmake 3.2.2-2 (build log):

/tmp/buildd/qgis-2.13.0+git20151123+57c22e5+23wily/tests/src/core/testqgsfontutils.cpp:151:32: fatal error: testqgsfontutils.moc: No such file or directory
compilation terminated.

@luipir
Copy link
Contributor

@luipir luipir commented on 57c22e5 Nov 23, 2015

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

@luipir
Copy link
Contributor

@luipir luipir commented on 57c22e5 Nov 23, 2015

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

I had a strange problem disappeared after re-run make
https://gist.github.com/luipir/7b873111a5802c21c138
I don't know if related because not part of the test copilation

Please sign in to comment.