Skip to content
Permalink
Browse files
Fix for ticket #217 - autogen.sh didn't correctly detect older
versions of automake and hence didn't warn the user


git-svn-id: http://svn.osgeo.org/qgis/trunk@5657 c8812cc2-4d05-0410-92ff-de0c093fc19c
  • Loading branch information
g_j_m committed Aug 2, 2006
1 parent 3064123 commit 58e784484c3809c5d79083a8e2bc779842019d8d
Showing with 3 additions and 3 deletions.
  1. +3 −3 autogen.sh
@@ -22,10 +22,10 @@ if [ "`uname`" = "Darwin" ]; then
fi

# Check automake version
AM_VERSION=`automake --version | sed -n -e 's#[^0-9]* \([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*$#\1 \2 \3#p'`
AM_VERSION=`automake --version | sed -n -e 's#[^0-9]* \([0-9]*\)\.\([0-9]*\)*\.*\(\([0-9]*\)\).*$#\1 \2 \3#p'`
AM_V1=`echo $AM_VERSION | awk '{print $1}'`
AM_V2=`echo $AM_VERSION | awk '{print $2}'`
AM_V3=`echo $AM_VERSION | awk '{print $3}'`
AM_V3=`echo $AM_VERSION | awk '{if ($NF > 2) print $3; else print "0";}'`

if [ $AM_1 -gt $AM_V1 ]; then
AM_ERROR=1
@@ -45,7 +45,7 @@ fi

if [ "$AM_ERROR" = "1" ]; then
echo -e '\E[31;m'
echo -n "Your automake version `automake --version | sed -n -e 's#[^0-9]* \([0-9]*\.[0-9]*\.[0-9]*\).*#\1#p'`"
echo -n "Your automake version `automake --version | sed -n -e 's#[^0-9]* \([0-9]*\.[0-9]*\.*[0-9]*\).*#\1#p'`"
echo " is older than the suggested one, $AM_1.$AM_2.$AM_3"
echo "Go on at your own risk. :-)"
echo

0 comments on commit 58e7844

Please sign in to comment.