Skip to content
Permalink
Browse files
raise Qt dependency to 4.5
  • Loading branch information
jef-n committed Jul 27, 2013
1 parent a261812 commit 5c80e50f4211146240f5df4a5b59d1a1f27ea013
Showing with 39 additions and 38 deletions.
  1. +1 −1 CMakeLists.txt
  2. +4 −4 INSTALL
  3. +2 −1 debian/changelog
  4. +3 −3 debian/control.lucid
  5. +3 −3 debian/control.oneiric
  6. +3 −3 debian/control.precise
  7. +3 −3 debian/control.quantal
  8. +3 −3 debian/control.raring
  9. +2 −2 debian/control.sid
  10. +3 −3 debian/control.sid-oracle
  11. +3 −3 debian/control.squeeze
  12. +3 −3 debian/control.wheezy
  13. +5 −5 doc/INSTALL.html
  14. +1 −1 doc/overview.t2t
@@ -220,7 +220,7 @@ SET (HAVE_MSSQL TRUE)

#############################################################
# search for Qt4
SET(QT_MIN_VERSION 4.4.0)
SET(QT_MIN_VERSION 4.5.0)
FIND_PACKAGE(Qt4 ${QT_MIN_VERSION} REQUIRED)
SET(QT_USE_QTXML 1)
SET(QT_USE_QTNETWORK 1)
@@ -1,10 +1,10 @@
QGIS
Building QGIS from source - step by step
Sunday July 21, 2013
Saturday July 27, 2013


Last Updated: Sunday July 21, 2013
Last Change : Wednesday May 22, 2013
Last Updated: Saturday July 27, 2013
Last Change : Saturday July 27, 2013


1. Introduction
@@ -98,7 +98,7 @@ Required build tools:

Required build deps:

- Qt >= 4.4.0
- Qt >= 4.5.0
- Proj >= 4.4.x
- GEOS >= 3.0
- Sqlite3 >= 3.0.0
@@ -18,8 +18,9 @@ qgis (1.9.0) UNRELEASED; urgency=low
* drop context_help, function_help and qgis_help.db files
* use dh_sip
* add build dependency to xfonts (100dpi, 75dpi, scalable) for tests
* raise Qt dependency to 4.6

-- Jürgen E. Fischer <jef@norbit.de> Sat, 20 Jul 2013 13:18:52 +0200
-- Jürgen E. Fischer <jef@norbit.de> Sat, 27 Jul 2013 16:45:43 +0200

qgis (1.8.0) UNRELEASED; urgency=low

@@ -15,7 +15,7 @@ Build-Depends:
libgsl0-dev,
libpq-dev,
libproj-dev,
libqt4-dev (>=4.4.0),
libqt4-dev (>=4.6.0),
libqwt5-qt4-dev,
libspatialite-dev,
libsqlite3-dev,
@@ -88,11 +88,11 @@ Depends:
libpq-dev,
libproj-dev,
libqgis{QGIS_ABI} (= ${binary:Version}),
libqt4-dev (>=4.4.0),
libqt4-dev (>=4.6.0),
libsqlite3-dev,
python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0),
qt4-designer (>=4.4.0),
qt4-designer (>=4.6.0),
${misc:Depends}
Provides: qgis-dev
Replaces: qgis-dev, libqgis1-dev, libqgis1.4.0-dev
@@ -15,7 +15,7 @@ Build-Depends:
libgsl0-dev,
libpq-dev,
libproj-dev,
libqt4-dev (>=4.4.0),
libqt4-dev (>=4.6.0),
libqtwebkit-dev,
libqwt5-qt4-dev,
libspatialite-dev,
@@ -89,11 +89,11 @@ Depends:
libpq-dev,
libproj-dev,
libqgis{QGIS_ABI} (= ${binary:Version}),
libqt4-dev (>=4.4.0),
libqt4-dev (>=4.6.0),
libsqlite3-dev,
python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0),
qt4-designer (>=4.4.0),
qt4-designer (>=4.6.0),
${misc:Depends}
Provides: qgis-dev
Replaces: qgis-dev, libqgis1-dev, libqgis1.4.0-dev
@@ -15,7 +15,7 @@ Build-Depends:
libgsl0-dev,
libpq-dev,
libproj-dev,
libqt4-dev (>=4.4.0),
libqt4-dev (>=4.6.0),
libqt4-opengl-dev,
libqtwebkit-dev,
libqwt5-qt4-dev,
@@ -92,11 +92,11 @@ Depends:
libpq-dev,
libproj-dev,
libqgis{QGIS_ABI} (= ${binary:Version}),
libqt4-dev (>=4.4.0),
libqt4-dev (>=4.6.0),
libsqlite3-dev,
python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0),
qt4-designer (>=4.4.0),
qt4-designer (>=4.6.0),
${misc:Depends}
Provides: qgis-dev
Replaces: qgis-dev, libqgis1-dev, libqgis1.4.0-dev
@@ -15,7 +15,7 @@ Build-Depends:
libgsl0-dev,
libpq-dev,
libproj-dev,
libqt4-dev (>=4.4.0),
libqt4-dev (>=4.6.0),
libqt4-opengl-dev,
libqtwebkit-dev,
libqwt-dev,
@@ -91,11 +91,11 @@ Depends:
libpq-dev,
libproj-dev,
libqgis{QGIS_ABI} (= ${binary:Version}),
libqt4-dev (>=4.4.0),
libqt4-dev (>=4.6.0),
libsqlite3-dev,
python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0),
qt4-designer (>=4.4.0),
qt4-designer (>=4.6.0),
${misc:Depends}
Provides: qgis-dev
Replaces: qgis-dev, libqgis1-dev, libqgis1.4.0-dev
@@ -15,7 +15,7 @@ Build-Depends:
libgsl0-dev,
libpq-dev,
libproj-dev,
libqt4-dev (>=4.4.0),
libqt4-dev (>=4.6.0),
libqt4-opengl-dev,
libqtwebkit-dev,
libqwt5-qt4-dev,
@@ -93,11 +93,11 @@ Depends:
libpq-dev,
libproj-dev,
libqgis{QGIS_ABI} (= ${binary:Version}),
libqt4-dev (>=4.4.0),
libqt4-dev (>=4.6.0),
libsqlite3-dev,
python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0),
qt4-designer (>=4.4.0),
qt4-designer (>=4.6.0),
${misc:Depends}
Provides: qgis-dev
Replaces: qgis-dev, libqgis1-dev, libqgis1.4.0-dev
@@ -15,7 +15,7 @@ Build-Depends:
libgsl0-dev,
libpq-dev,
libproj-dev,
libqt4-dev (>=4.4.0),
libqt4-dev (>=4.6.0),
libqt4-opengl-dev,
libqtwebkit-dev,
libqwt-dev,
@@ -91,7 +91,7 @@ Depends:
libpq-dev,
libproj-dev,
libqgis{QGIS_ABI} (= ${binary:Version}),
libqt4-dev (>=4.4.0),
libqt4-dev (>=4.6.0),
libsqlite3-dev,
python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0),
@@ -15,7 +15,7 @@ Build-Depends:
libgsl0-dev,
libpq-dev,
libproj-dev,
libqt4-dev (>=4.4.0),
libqt4-dev (>=4.6.0),
libqt4-opengl-dev,
libqtwebkit-dev,
libqwt-dev,
@@ -92,11 +92,11 @@ Depends:
libpq-dev,
libproj-dev,
libqgis{QGIS_ABI} (= ${binary:Version}),
libqt4-dev (>=4.4.0),
libqt4-dev (>=4.6.0),
libsqlite3-dev,
python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0),
qt4-designer (>=4.4.0),
qt4-designer (>=4.6.0),
${misc:Depends}
Provides: qgis-dev
Replaces: qgis-dev, libqgis1-dev, libqgis1.4.0-dev
@@ -15,7 +15,7 @@ Build-Depends:
libgsl0-dev,
libpq-dev,
libproj-dev,
libqt4-dev (>=4.4.0),
libqt4-dev (>=4.6.0),
libqwt5-qt4-dev,
libspatialite-dev,
libsqlite3-dev,
@@ -89,11 +89,11 @@ Depends:
libpq-dev,
libproj-dev,
libqgis{QGIS_ABI} (= ${binary:Version}),
libqt4-dev (>=4.4.0),
libqt4-dev (>=4.6.0),
libsqlite3-dev,
python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0),
qt4-designer (>=4.4.0),
qt4-designer (>=4.6.0),
${misc:Depends}
Provides: qgis-dev
Replaces: qgis-dev, libqgis1-dev, libqgis1.4.0-dev
@@ -15,7 +15,7 @@ Build-Depends:
libgsl0-dev,
libpq-dev,
libproj-dev,
libqt4-dev (>=4.4.0),
libqt4-dev (>=4.6.0),
libqt4-opengl-dev,
libqtwebkit-dev,
libqwt-dev,
@@ -91,11 +91,11 @@ Depends:
libpq-dev,
libproj-dev,
libqgis{QGIS_ABI} (= ${binary:Version}),
libqt4-dev (>=4.4.0),
libqt4-dev (>=4.6.0),
libsqlite3-dev,
python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0),
qt4-designer (>=4.4.0),
qt4-designer (>=4.6.0),
${misc:Depends}
Provides: qgis-dev
Replaces: qgis-dev, libqgis1-dev, libqgis1.4.0-dev
@@ -77,13 +77,13 @@
<DIV CLASS="header" ID="header">
<H1>QGIS</H1>
<H2>Building QGIS from source - step by step</H2>
<H3>Sunday July 21, 2013</H3>
<H3>Saturday July 27, 2013</H3>
</DIV>

<DIV CLASS="body" ID="body">
<P>
Last Updated: Sunday July 21, 2013
Last Change : Wednesday May 22, 2013
Last Updated: Saturday July 27, 2013
Last Change : Saturday July 27, 2013
</P>
<DIV CLASS="toc">

@@ -195,7 +195,7 @@ <H1>2. Overview</H1>
</P>

<UL>
<LI>CMake &gt;= 2.6.2
<LI>CMake &gt;= 2.8.0
<LI>Flex
<LI>Bison &gt;= 2.4
</UL>
@@ -205,7 +205,7 @@ <H1>2. Overview</H1>
</P>

<UL>
<LI>Qt &gt;= 4.4.0
<LI>Qt &gt;= 4.5.0
<LI>Proj &gt;= 4.4.x
<LI>GEOS &gt;= 3.0
<LI>Sqlite3 &gt;= 3.0.0
@@ -15,7 +15,7 @@ Required build tools:

Required build deps:

- Qt >= 4.4.0
- Qt >= 4.5.0
- Proj >= 4.4.x
- GEOS >= 3.0
- Sqlite3 >= 3.0.0

0 comments on commit 5c80e50

Please sign in to comment.