Skip to content
Permalink
Browse files
Fix warning
  • Loading branch information
nyalldawson committed Jul 12, 2021
1 parent d44412d commit 5cb167b0133b2ade94bef74e1d9a5379a7b4151c
Showing with 2 additions and 20 deletions.
  1. +1 −19 python/gui/auto_generated/qgssublayersdialog.sip.in
  2. +1 −1 src/gui/qgssublayersdialog.h
@@ -21,34 +21,16 @@ class QgsSublayersDialog : QDialog
%End
public:

enum PromptMode
%Docstring
Prompt behavior of the QgsSublayersDialog

.. deprecated::
Use Qgis.SublayerPromptMode instead
%End
enum PromptMode
{

PromptAlways,
%Docstring
always ask if there are existing sublayers
%End

PromptIfNeeded,
%Docstring
always ask if there are existing sublayers, but skip if there are bands for rasters
%End

PromptNever,
%Docstring
never prompt, will not load anything
%End

PromptLoadAll
%Docstring
never prompt, but load all sublayers
%End
};

enum ProviderType
@@ -36,7 +36,7 @@ class GUI_EXPORT QgsSublayersDialog : public QDialog, private Ui::QgsSublayersDi
* Prompt behavior of the QgsSublayersDialog
* \deprecated Use Qgis::SublayerPromptMode instead
*/
Q_DECL_DEPRECATED enum PromptMode
enum Q_DECL_DEPRECATED PromptMode
{

/**

0 comments on commit 5cb167b

Please sign in to comment.