Skip to content
Permalink
Browse files

Update build dependencies

  • Loading branch information
m-kuhn committed Dec 21, 2016
1 parent 0a686c4 commit 6c5ec70f8782808fc5b35fc87ab1dac3825aa0e9
Showing with 2 additions and 3 deletions.
  1. +2 −3 doc/overview.t2t
@@ -15,15 +15,14 @@ Required build tools:

Required build dependencies:

- Qt >= 4.8.0
- Qt >= 5.3.0
- Proj >= 4.4.x
- GEOS >= 3.4
- Sqlite3 >= 3.0.0
- GDAL/OGR >= 1.4.x
- GDAL/OGR >= 2.0

This comment has been minimized.

Copy link
@rouault

rouault Dec 21, 2016

Contributor

I think it still compiles against 1.11, doesn't it ? Ubuntu 16.04 still ships with 1.11, will the ubuntu packages require ubuntugis that has 2.1 ?

This comment has been minimized.

Copy link
@m-kuhn

m-kuhn Dec 21, 2016

Author Member

True, but I think we also had a discussion about making GDAL 2.0 mandatory for QGIS 3.
I don't remember the exact reasoning. What do you think, is there any advantage of marking it required?

This comment has been minimized.

Copy link
@rouault

rouault Dec 21, 2016

Contributor

Dropping 1.X support would simplify the code, but we should check that this doesn't cause packaging headaches. The Ubuntu packages don't require UbuntuGIS, do they ? Being able to provide support for 16.04 is IMHO a plus.

This comment has been minimized.

Copy link
@m-kuhn

m-kuhn Dec 21, 2016

Author Member

Is there no "must-have" functionality in GDAL 2 (e.g. geopackage related)?

I think the timeline for 3.0 is post 17.04 (which I hope ships GDAL 2) and personally I don't mind taking the opportunity to do some cleanups if it means making ubuntugis a required dependency for older distros. But certainly only if there's a good reason for it.

This comment has been minimized.

Copy link
@rouault

rouault Dec 21, 2016

Contributor

Is there no "must-have" functionality in GDAL 2 (e.g. geopackage related)?

Yes support for GeoPackage in 2.0 is far more complete than in 1.11 (raster + spatial index for vector). And for full support with QGIS DbManager (table renaming and addition, renaming fields, etc..) you need 2.1.2 actually.

I think the timeline for 3.0 is post 17.04 (which I hope ships GDAL 2)

2.1.2 according to https://launchpad.net/ubuntu/+source/gdal

Who is our Debian/Ubuntu package master : @jef ? Any opinion ?

This comment has been minimized.

Copy link
@jef-n

jef-n via email Jan 1, 2017

Member

This comment has been minimized.

Copy link
@nyalldawson

nyalldawson Jan 3, 2017

Collaborator

@jef-n PR is available at #3940

- Qwt >= 5.0 & (< 6.1 with internal QwtPolar)
- expat >= 1.95
- QScintilla2
-

Optional dependencies:

0 comments on commit 6c5ec70

Please sign in to comment.
You can’t perform that action at this time.