Skip to content
Permalink
Browse files

more OS X install updates

  • Loading branch information
kyngchaos committed Apr 2, 2013
1 parent c367925 commit 6cfa2959bb1f89dbe21ad4600cd42788bd492de8
Showing with 25 additions and 29 deletions.
  1. +9 −10 INSTALL
  2. +9 −11 doc/INSTALL.html
  3. +7 −8 doc/osx.t2t
19 INSTALL
@@ -1,9 +1,9 @@
Quantum GIS (QGIS)
Building QGIS from source - step by step
Monday April 01, 2013
Tuesday April 02, 2013


Last Updated: Monday April 01, 2013
Last Updated: Tuesday April 02, 2013
Last Change : Saturday December 08, 2012


@@ -1504,9 +1504,6 @@ Retrieve the Qt version of the Scintilla-based text editor widget from

http://www.riverbankcomputing.co.uk/software/qscintilla/download

Note:The editor uses API files for code completion in the PyQGIS console. To
have PyQt4's API automatically created, install QScintilla2 library first.

Double-click the tarball to unpack it. Then, cd to the QScintilla2.x.x source
folder in a Terminal.

@@ -1564,15 +1561,15 @@ cd to the source folder. Then for your chosen Python:

python.org Python

python configure.py
python configure.py -n /usr/local/Qt-4.8/qsci
yes

Leopard system Python

PyQt wants to install in the system path -- this is not a good idea.
More configuration is needed to install outside the system path:

python configure.py -d /Library/Python/2.5/site-packages -b /usr/local/bin
python configure.py -d /Library/Python/2.5/site-packages -b /usr/local/bin -n /usr/local/Qt-4.8/qsci

Snow Leopard system Python

@@ -1584,18 +1581,20 @@ Substitute '2.7' for python version and 10.7 for SDK version below for Lion.

If you are using 32-bit Qt (Qt Carbon):

python2.6 configure.py -d /Library/Python/2.6/site-packages -b /usr/local/bin --use-arch i386
python2.6 configure.py -d /Library/Python/2.6/site-packages -b /usr/local/bin \
-n /usr/local/Qt-4.8/qsci --use-arch i386

For 64-bit Qt (Qt Cocoa), use this configure line:

python2.6 configure.py -d /Library/Python/2.6/site-packages -b /usr/local/bin --use-arch x86_64
python2.6 configure.py -d /Library/Python/2.6/site-packages -b /usr/local/bin \
-n /usr/local/Qt-4.8/qsci --use-arch x86_64

Lion and Mt. Lion system Python

Similar to Snow Leopard, you should install outside the system Python path.
But you don't need the arch option:

python2.7 configure.py -d /Library/Python/2.7/site-packages -b /usr/local/bin
python2.7 configure.py -d /Library/Python/2.7/site-packages -b /usr/local/bin -n /usr/local/Qt-4.8/qsci

continue...

@@ -77,12 +77,12 @@
<DIV CLASS="header" ID="header">
<H1>Quantum GIS (QGIS)</H1>
<H2>Building QGIS from source - step by step</H2>
<H3>Monday April 01, 2013</H3>
<H3>Tuesday April 02, 2013</H3>
</DIV>

<DIV CLASS="body" ID="body">
<P>
Last Updated: Monday April 01, 2013
Last Updated: Tuesday April 02, 2013
Last Change : Saturday December 08, 2012
</P>
<DIV CLASS="toc">
@@ -2118,10 +2118,6 @@ <H3>5.4.6. Additional dependencies: QScintilla2</H3>
<A HREF="http://www.riverbankcomputing.co.uk/software/qscintilla/download">http://www.riverbankcomputing.co.uk/software/qscintilla/download</A>
</P>
<P>
<U>Note:</U>The editor uses API files for code completion in the PyQGIS console. To
have PyQt4's API automatically created, install QScintilla2 library first.
</P>
<P>
Double-click the tarball to unpack it. Then, cd to the QScintilla2.x.x source
folder in a Terminal.
</P>
@@ -2201,7 +2197,7 @@ <H3>5.4.7. Additional dependencies: PyQt</H3>
</P>

<div class="code"><PRE>
python configure.py
python configure.py -n /usr/local/Qt-4.8/qsci
yes
</PRE></div>

@@ -2214,7 +2210,7 @@ <H3>5.4.7. Additional dependencies: PyQt</H3>
</P>

<div class="code"><PRE>
python configure.py -d /Library/Python/2.5/site-packages -b /usr/local/bin
python configure.py -d /Library/Python/2.5/site-packages -b /usr/local/bin -n /usr/local/Qt-4.8/qsci
</PRE></div>

<P>
@@ -2232,15 +2228,17 @@ <H3>5.4.7. Additional dependencies: PyQt</H3>
</P>

<div class="code"><PRE>
python2.6 configure.py -d /Library/Python/2.6/site-packages -b /usr/local/bin --use-arch i386
python2.6 configure.py -d /Library/Python/2.6/site-packages -b /usr/local/bin \
-n /usr/local/Qt-4.8/qsci --use-arch i386
</PRE></div>

<P>
For 64-bit Qt (Qt Cocoa), use this configure line:
</P>

<div class="code"><PRE>
python2.6 configure.py -d /Library/Python/2.6/site-packages -b /usr/local/bin --use-arch x86_64
python2.6 configure.py -d /Library/Python/2.6/site-packages -b /usr/local/bin \
-n /usr/local/Qt-4.8/qsci --use-arch x86_64
</PRE></div>

<P>
@@ -2252,7 +2250,7 @@ <H3>5.4.7. Additional dependencies: PyQt</H3>
</P>

<div class="code"><PRE>
python2.7 configure.py -d /Library/Python/2.7/site-packages -b /usr/local/bin
python2.7 configure.py -d /Library/Python/2.7/site-packages -b /usr/local/bin -n /usr/local/Qt-4.8/qsci
</PRE></div>

<P>
@@ -362,9 +362,6 @@ Retrieve the Qt version of the Scintilla-based text editor widget from

http://www.riverbankcomputing.co.uk/software/qscintilla/download

__Note:__The editor uses API files for code completion in the PyQGIS console. To
have PyQt4's API automatically created, install QScintilla2 library first.

Double-click the tarball to unpack it. Then, cd to the QScintilla2.x.x source
folder in a Terminal.

@@ -425,7 +422,7 @@ cd to the source folder. Then for your chosen Python:
__python.org Python__

```
python configure.py
python configure.py -n /usr/local/Qt-4.8/qsci
yes
```

@@ -435,7 +432,7 @@ PyQt wants to install in the system path -- this is not a good idea.
More configuration is needed to install outside the system path:

```
python configure.py -d /Library/Python/2.5/site-packages -b /usr/local/bin
python configure.py -d /Library/Python/2.5/site-packages -b /usr/local/bin -n /usr/local/Qt-4.8/qsci
```

__Snow Leopard system Python__
@@ -449,13 +446,15 @@ Substitute '2.7' for python version and 10.7 for SDK version below for Lion.
If you are using 32-bit Qt (Qt Carbon):

```
python2.6 configure.py -d /Library/Python/2.6/site-packages -b /usr/local/bin --use-arch i386
python2.6 configure.py -d /Library/Python/2.6/site-packages -b /usr/local/bin \
-n /usr/local/Qt-4.8/qsci --use-arch i386
```

For 64-bit Qt (Qt Cocoa), use this configure line:

```
python2.6 configure.py -d /Library/Python/2.6/site-packages -b /usr/local/bin --use-arch x86_64
python2.6 configure.py -d /Library/Python/2.6/site-packages -b /usr/local/bin \
-n /usr/local/Qt-4.8/qsci --use-arch x86_64
```

__Lion and Mt. Lion system Python__
@@ -464,7 +463,7 @@ Similar to Snow Leopard, you should install outside the system Python path.
But you don't need the arch option:

```
python2.7 configure.py -d /Library/Python/2.7/site-packages -b /usr/local/bin
python2.7 configure.py -d /Library/Python/2.7/site-packages -b /usr/local/bin -n /usr/local/Qt-4.8/qsci
```

__continue...__

0 comments on commit 6cfa295

Please sign in to comment.
You can’t perform that action at this time.