Skip to content
Permalink
Browse files
revert r8437 and fix it different
- use FIND_PACKAGE(Qt4 REQUIRED) before SET(QT_... 1)
  as cmake's Modules/FindQt4.cmake suggests
- should also fix #913


git-svn-id: http://svn.osgeo.org/qgis/trunk@8438 c8812cc2-4d05-0410-92ff-de0c093fc19c
  • Loading branch information
jef committed May 14, 2008
1 parent 7c0d8ac commit 6f03494d8f0cbbb654883a7ee62ccb3fe59478d7
Showing with 3 additions and 3 deletions.
  1. +2 −2 CMakeLists.txt
  2. +1 −1 src/app/qgsabout.cpp
@@ -133,6 +133,7 @@ ENDIF (POSTGRES_FOUND)

#############################################################
# search for Qt4
FIND_PACKAGE(Qt4 REQUIRED)

SET( QT_USE_QT3SUPPORT TRUE )
SET( QT_USE_QTXML TRUE )
@@ -144,7 +145,6 @@ IF (ENABLE_TESTS)
ENABLE_TESTING()
ENDIF (ENABLE_TESTS)

FIND_PACKAGE(Qt4 REQUIRED)

INCLUDE( ${QT_USE_FILE} )

@@ -230,7 +230,7 @@ ELSE (WIN32)
SET (DEFAULT_INCLUDE_SUBDIR include/qgis)

IF (UNIX AND NOT APPLE)
ADD_DEFINITIONS(-DPREFIX=\\"${CMAKE_INSTALL_PREFIX}\\")
ADD_DEFINITIONS(-DPREFIX=${CMAKE_INSTALL_PREFIX})
ENDIF (UNIX AND NOT APPLE)

ENDIF (WIN32)
@@ -24,7 +24,7 @@
#include <QFile>
#include <QTextStream>
#include <QImageReader>
#include <QtSql/QSqlDatabase>
#include <QSqlDatabase>
#include <iostream>

/* Uncomment this block to use preloaded images

0 comments on commit 6f03494

Please sign in to comment.