Skip to content
Permalink
Browse files
fix debian packaging
git-svn-id: http://svn.osgeo.org/qgis/branches/Release-0_11_0@8795 c8812cc2-4d05-0410-92ff-de0c093fc19c
  • Loading branch information
jef committed Jul 16, 2008
1 parent b1b171f commit 72316faf541d200fa4b4c102570837408a415191
Showing with 18 additions and 14 deletions.
  1. +13 −0 debian/changelog
  2. +4 −12 debian/control
  3. +0 −1 debian/libqgis1-dev.install
  4. +0 −1 debian/libqgispython0.11.install
  5. +1 −0 debian/python-qgis.install
@@ -1,3 +1,16 @@
qgis (0.11.0-1) stable; urgency=low

* libqgispython0.11 integrated into python-qgis
* introduced a build conflict with libqgis1-dev

-- Jürgen E. Fischer <jef@norbit.de> Wed, 16 Jul 2008 22:42:11 +0200

qgis (0.11.0) stable; urgency=low

* New upstream release: Quantum GIS 0.11.0 'Metis'

-- Jürgen E. Fischer <jef@norbit.de> Tue, 15 Jul 2008 20:41:12 +0200

qgis (0.11.0test3) experimental; urgency=low

* add memory provider
@@ -9,6 +9,7 @@ Build-Depends: debhelper (>= 5.0.0), libgdal1-dev, libpq-dev,
libqt4-qt3support (>=4.2.0), libqt4-sql (>=4.2.0), python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0),
python-sip4-dev (>= 4.5.0), libfontconfig1-dev, libxi-dev, libxrandr-dev, libxrender-dev, libice-dev,
libsm-dev
Build-Conflicts: libqgis1-dev
Standards-Version: 3.7.3
XS-Python-Version: current
Homepage: http://qgis.org/
@@ -58,8 +59,7 @@ Depends: qgis (= ${binary:Version}), libgdal1-dev | libgdal1-1.3.2-dev,
libsqlite3-dev, libgsl0-dev, proj, libexpat1-dev, libqt4-core (>=4.2.0),
libqt4-dev (>=4.2.0), libqt4-gui (>=4.2.0), libqt4-qt3support (>=4.2.0),
libqt4-sql (>=4.2.0), python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0),
qt4-designer (>=4.2.0), libqgispython0.11, libqgisgrass0.11, libqgis-gui0.11,
libqgis-core0.11
qt4-designer (>=4.2.0), libqgisgrass0.11, libqgis-gui0.11, libqgis-core0.11
Provides: libqgis-dev
Conflicts: libqgis-dev, qgis-dev
Replaces: qgis-dev
@@ -89,21 +89,13 @@ Description: Quantum GIS - shared grass library
Package: python-qgis
Section: python
Architecture: any
Depends: libqgispython0.11, ${shlibs:Depends}, ${misc:Depends}
Depends: ${shlibs:Depends}, ${misc:Depends}
Provides: ${python:Provides}
Replaces: libqgispython0.11
XB-Python-Version: ${python:Versions}
Description: Python bindings to Quantum GIS
Quantum GIS is a Geographic Information System (GIS) which manages, analyzes
and display databases of geographic information.
.
This package contains the files for the Python support.

Package: libqgispython0.11
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
XB-Python-Version: ${python:Versions}
Description: Quantum GIS - shared Python library
Quantum GIS is a Geographic Information System (GIS) which manages, analyzes
and display databases of geographic information.
.
This package contains the shared library for the Python support.
@@ -1,5 +1,4 @@
usr/include/qgis/*
usr/lib/libqgispython.so
usr/lib/libqgisgrass.so
usr/lib/libqgis_gui.so
usr/lib/libqgis_core.so

This file was deleted.

@@ -2,3 +2,4 @@ usr/share/qgis/python/*
usr/lib/python*/site-packages/qgis/__init__.py
usr/lib/python*/site-packages/qgis/qgisconfig.py
usr/lib/python*/site-packages/qgis/*.so
usr/lib/libqgispython.so*

0 comments on commit 72316fa

Please sign in to comment.