Skip to content
Permalink
Browse files

[Plugin manager] Add a label for built-in plugins explaining they are…

…n't uninstallable.
  • Loading branch information
borysiasty committed Oct 23, 2017
1 parent ea0e09b commit 87d087bbfdb048e49b12003cd97d80aeb8068505
Showing with 7 additions and 0 deletions.
  1. +7 −0 src/app/pluginmanager/qgspluginmanager.cpp
@@ -810,6 +810,13 @@ void QgsPluginManager::showPluginDetails( QStandardItem *item )
"</table>" ).arg( tr( "This plugin is trusted" ) );
}

if ( metadata->value( QStringLiteral( "readonly" ) ) == QLatin1String( "true" ) )
{
html += QString( "<table bgcolor=\"#90EEE9\" cellspacing=\"2\" cellpadding=\"2\" width=\"100%\">"
" <tr><td width=\"100%\" style=\"color:#660000\"><b>%1</b></td></tr>"
"</table>" ).arg( tr( "This is a system plugin, so you can't uninstall it" ) );
}

// Now the metadata

html += QLatin1String( "<table cellspacing=\"4\" width=\"100%\"><tr><td>" );

1 comment on commit 87d087b

@borysiasty

This comment has been minimized.

Copy link
Member Author

@borysiasty borysiasty commented on 87d087b Oct 24, 2017

@rduivenvoorde I'm sorry, doesn't this new label bar require [needs-doc]? It fixes https://issues.qgis.org/issues/9405

Please sign in to comment.
You can’t perform that action at this time.