Skip to content
Permalink
Browse files

Fix rubber band in node tool not getting updated correctly

  • Loading branch information
wonder-sk committed Nov 15, 2016
1 parent d237e27 commit 8908eea43bb0cce524f21732f14a8a5e924d2227
Showing with 1 addition and 1 deletion.
  1. +1 −1 src/app/nodetool/qgsmaptoolnodetool.cpp
@@ -252,7 +252,7 @@ void QgsMapToolNodeTool::canvasPressEvent( QgsMapMouseEvent* e )
}
connect( QgisApp::instance()->layerTreeView(), SIGNAL( currentLayerChanged( QgsMapLayer* ) ), this, SLOT( currentLayerChanged( QgsMapLayer* ) ) );
connect( mSelectedFeature, SIGNAL( destroyed() ), this, SLOT( selectedFeatureDestroyed() ) );
connect( vlayer, SIGNAL( geometryChanged( QgsFeatureId, const QgsGeometry & ) ), this, SLOT( geometryChanged( QgsFeatureId, QgsGeometry & ) ) );
connect( vlayer, SIGNAL( geometryChanged( QgsFeatureId, const QgsGeometry & ) ), this, SLOT( geometryChanged( QgsFeatureId, const QgsGeometry & ) ) );

This comment has been minimized.

Copy link
@m-kuhn

m-kuhn Nov 15, 2016

Member

Why not change this to new-style signal/slots? It would help to avoid such problems once and forever.

This comment has been minimized.

Copy link
@wonder-sk

wonder-sk Nov 15, 2016

Author Member

Laziness ;-)

I was just checking if my recent geometry changes did not cause that issue - apparently it was there for some time already

connect( vlayer, SIGNAL( editingStopped() ), this, SLOT( editingToggled() ) );
mIsPoint = vlayer->geometryType() == QgsWkbTypes::PointGeometry;
mNodeEditor = new QgsNodeEditor( vlayer, mSelectedFeature, mCanvas );

0 comments on commit 8908eea

Please sign in to comment.
You can’t perform that action at this time.