Skip to content
Permalink
Browse files

UMinor updates to install process and generated INSTALL doc using txt…

…2tags

git-svn-id: http://svn.osgeo.org/qgis/trunk/qgis@7163 c8812cc2-4d05-0410-92ff-de0c093fc19c
  • Loading branch information
timlinux
timlinux committed Aug 28, 2007
1 parent 0fa7062 commit 94128bc33d1081cd97683f7233a86a8e2bc34122
Showing with 8 additions and 12 deletions.
  1. +4 −4 INSTALL
  2. +4 −8 INSTALL.t2t
@@ -1,4 +1,3 @@
%!encoding: iso-8859-1


------------------------------------------------------------------------
@@ -773,16 +772,17 @@ above commands to select the Qt4 version of the relevant applications.


sudo apt-get install gdal-bin libgdal1-dev libgeos-dev proj libtool \
libgdal-doc libhdf4g-dev libhdf4g-run python-dev python-qt4-dev sip4 \
libgdal-doc libhdf4g-dev libhdf4g-run python-dev \
swig libgsl0-dev g++ libjasper-1.701-dev libtiff4-dev subversion gsl-bin \
libsqlite3-dev sqlite3 ccache make libpq-dev flex bison cmake
libsqlite3-dev sqlite3 ccache make libpq-dev flex bison cmake txt2tags \
python-qt4 python-qt4-dev python-sip4 sip4


/!\ Debian users should use libgdal-dev above rather

/!\ *Note:* For python language bindings SIP >= 4.5 and PyQt4 >= 4.1 is required! Some stable GNU/Linux
distributions (e.g. Debian or SuSE) only provide SIP < 4.5 and PyQt4 < 4.1. To include support for python
language bindings you need to build and install those packages from source.
language bindings you may need to build and install those packages from source.


5.5. GRASS Specific Steps
@@ -659,21 +659,17 @@ above commands to select the Qt4 version of the relevant applications.

```
sudo apt-get install gdal-bin libgdal1-dev libgeos-dev proj libtool \
libgdal-doc libhdf4g-dev libhdf4g-run python-dev python-qt4-dev sip4 \
libgdal-doc libhdf4g-dev libhdf4g-run python-dev \
swig libgsl0-dev g++ libjasper-1.701-dev libtiff4-dev subversion gsl-bin \
libsqlite3-dev sqlite3 ccache make libpq-dev flex bison cmake txt2tags
libsqlite3-dev sqlite3 ccache make libpq-dev flex bison cmake txt2tags \
python-qt4 python-qt4-dev python-sip4 sip4
```

/!\ Debian users should use libgdal-dev above rather

/!\ ***Note:*** For python language bindings SIP >= 4.5 and PyQt4 >= 4.1 is required! Some stable GNU/Linux
distributions (e.g. Debian or SuSE) only provide SIP < 4.5 and PyQt4 < 4.1. To include support for python
language bindings you need to build and install those packages from source. You can try to install them
using:

```
sudo apt-get install python-qt4 python-qt4-dev python-sip4
```
language bindings you may need to build and install those packages from source.


== GRASS Specific Steps ==

0 comments on commit 94128bc

Please sign in to comment.
You can’t perform that action at this time.