Skip to content
Permalink
Browse files

* update INSTALL

* osgeo4w: search qt5 first and use pyrcc5.bat
  • Loading branch information
jef-n committed Feb 6, 2017
1 parent 64748aa commit 9475850f39a1687da02423f5d652ff8e0e72be2c
Showing with 21 additions and 16 deletions.
  1. +1 −1 cmake/PyQtMacros.cmake
  2. +18 −13 doc/msvc.t2t
  3. +2 −2 ms-windows/osgeo4w/package-nightly.cmd
@@ -55,7 +55,7 @@ ENDMACRO(PYQT_WRAP_UI)
IF(NOT PYRCC_PROGRAM)
IF (MSVC)
FIND_PROGRAM(PYRCC_PROGRAM
NAMES ${PYRCC_PROG_NAME}.exe
NAMES ${PYRCC_PROG_NAME}.bat
PATHS $ENV{LIB_DIR}/bin
)
ELSE(MSVC)
@@ -12,19 +12,14 @@ build QGIS.

The free (as in free beer) Express Edition installer is available under:

http://download.microsoft.com/download/c/d/7/cd7d4dfb-5290-4cc7-9f85-ab9e3c9af796/vc_web.exe

You also need the Windows SDK for Windows 7 and .NET Framework 4:

http://download.microsoft.com/download/A/6/A/A6AC035D-DA3F-4F0C-ADA4-37C8E5D34E3D/winsdk_web.exe

https://download.my.visualstudio.com/db/en_visual_studio_express_2015_for_windows_10_x86_x64_web_installer_6878617.exe?t=9437eae7-7ff2-462a-a349-312fd069ef2d&e=1486459960&h=1fa3414e467f267c795c01bc38b9472d&su=1

===Other tools and dependencies===

Download and install following packages:

|| Tool | Website |
| CMake | http://www.cmake.org/files/v3.0/cmake-3.0.2-win32-x86.exe |
| CMake | https://cmake.org/files/v3.7/cmake-3.7.2-win64-x64.msi |
| GNU flex, GNU bison and GIT | http://cygwin.com/setup-x86.exe (32bit) or http://cygwin.com/setup-x86_64.exe (64bit) |
| OSGeo4W | http://download.osgeo.org/osgeo4w/osgeo4w-setup-x86.exe (32bit) or http://download.osgeo.org/osgeo4w/osgeo4w-setup-x86_64.exe (64bit) |

@@ -46,13 +41,23 @@ and from OSGeo4W (select //Advanced Installation//):
- grass
- gsl-devel
- iconv
- pyqt4
- qt4-devel
- qwt5-devel-qt4
- sip
- spatialite
- libspatialindex-devel
- python-qscintilla
- pyqt5
- python3-devel
- python3-qscintilla
- qca-qt5-devel
- qca-qt5-libs
- qscintilla-qt5
- qt5-devel
- qt5-libs-debug
- qtwebkit-qt5-devel
- qtwebkit-qt5-libs-debug
- qwt-devel-qt5
- sip-qt5
- spatialite
-



This will also select packages the above packages depend on.

@@ -152,8 +152,8 @@ touch %SRCDIR%\CMakeLists.txt
echo CMAKE: %DATE% %TIME%
if errorlevel 1 goto error

set LIB=%LIB%;%OSGEO4W_ROOT%\lib
set INCLUDE=%INCLUDE%;%OSGEO4W_ROOT%\include
set LIB=%LIB%;%OSGEO4W_ROOT%\apps\Qt5\lib;%OSGEO4W_ROOT%\lib
set INCLUDE=%INCLUDE%;%OSGEO4W_ROOT%\apps\Qt5\include;%OSGEO4W_ROOT%\include

cmake -G Ninja ^
-D CMAKE_CXX_COMPILER="%CMAKE_COMPILER_PATH:\=/%/cl.exe" ^

0 comments on commit 9475850

Please sign in to comment.
You can’t perform that action at this time.