Skip to content
Permalink
Browse files

Be more lenient on accepting SAGA versions

Even though SAGA explicitly does't follow semver conventions, there are
advances, and not all changes on their part break the API. Since the
user is already warned in big letters that versions different from 2.3
are unsupported, in beta status, we've changed the requirement for SAGA
"beta" from 7.3 to everything in version 7.
  • Loading branch information
espinafre authored and nyalldawson committed May 28, 2020
1 parent 090604c commit 97e0651555797266829c647be1aaa91e550d92f4
Showing with 1 addition and 1 deletion.
  1. +1 −1 python/plugins/processing/algs/saga/SagaAlgorithmProvider.py
@@ -41,7 +41,7 @@
os.path.split(os.path.dirname(__file__))[0], os.pardir))

REQUIRED_VERSION = '2.3.'
BETA_SUPPORT_VERSION = '7.3.'
BETA_SUPPORT_VERSION = '7.'


class SagaAlgorithmProvider(QgsProcessingProvider):

0 comments on commit 97e0651

Please sign in to comment.
You can’t perform that action at this time.