Skip to content
Permalink
Browse files

debian packaging: add pdal provider and switch to sip5

  • Loading branch information
jef-n committed Nov 7, 2020
1 parent 7c458a9 commit 9e02078d8801c9c125119f11b17da0b41a73b2d5
@@ -54,8 +54,6 @@ Build-Depends:
python3-pyqt5.qsci,
python3-pyqt5.qtsql,
python3-pyqt5.qtsvg,
python3-sip-dev,
python3-sip,
python3-termcolor,
python3-yaml,
qt3d5-dev,
@@ -56,8 +56,8 @@ Build-Depends:
python3-pyqt5.qsci,
python3-pyqt5.qtsql,
python3-pyqt5.qtsvg,
python3-sip-dev,
python3-sip,
#sid groovy# sip5-tools,
#buster bullseye bionic focal# python3-sip-dev, python3-sip,
python3-termcolor,
python3-yaml,
qt3d5-dev,
@@ -71,6 +71,7 @@ Build-Depends:
qtpositioning5-dev,
qttools5-dev-tools,
qttools5-dev,
libpdal-dev, pdal,
libprotobuf-dev,
protobuf-compiler,
saga,
@@ -20,4 +20,5 @@ usr/lib/qgis/plugins/libvirtuallayerprovider.so
usr/lib/qgis/plugins/libwcsprovider.so
usr/lib/qgis/plugins/libwfsprovider.so
usr/lib/qgis/plugins/libwmsprovider.so
#!xenial#usr/lib/*/qt?/plugins/sqldrivers/libqsqlspatialite.so
usr/lib/qgis/plugins/libpdalprovider.so
usr/lib/*/qt?/plugins/sqldrivers/libqsqlspatialite.so
@@ -40,7 +40,7 @@ endif

QT_PLUGINS_DIR = lib/$(DEB_BUILD_MULTIARCH)/qt5/plugins

ifneq ($(DISTRIBUTION),$(findstring $(DISTRIBUTION),"buster bionic focal groovy"))
ifneq ($(DISTRIBUTION),$(findstring $(DISTRIBUTION),"buster bullseye bionic focal groovy"))
DISTRIBUTION := sid
endif

@@ -98,7 +98,10 @@ CMAKE_OPTS := \
-DQT_PLUGINS_DIR=$(QT_PLUGINS_DIR) \
-DPYTHON_LIBRARY=$(PYTHON_LIBRARY) \
-DDOXYGEN_ON_DEMAND=TRUE \
-DWITH_QSPATIALITE=TRUE
-DWITH_QSPATIALITE=TRUE \
-DWITH_3D=TRUE \
-DGEOS_LIBRARY=/usr/lib/$(DEB_BUILD_MULTIARCH)/libgeos_c.so \
-DWITH_PDAL=TRUE

ifneq ($(SHA),)
CMAKE_OPTS += -DSHA=$(SHA)
@@ -115,11 +118,6 @@ ifneq (,$(findstring $(DISTRIBUTION),"sid buster"))
CMAKE_OPTS += -DPOSTGRES_LIBRARY=/usr/lib/$(DEB_BUILD_MULTIARCH)/libpq.so
endif

ifneq (,$(findstring $(DISTRIBUTION),"sid buster bionic focal groovy"))
CMAKE_OPTS += \
-DWITH_3D=TRUE \
-DGEOS_LIBRARY=/usr/lib/$(DEB_BUILD_MULTIARCH)/libgeos_c.so

$(shell test -f /usr/include/$(DEB_BUILD_MULTIARCH)/qt5/Qt3DExtras/qt3dextrasversion.h -a -f /usr/lib/$(DEB_BUILD_MULTIARCH)/cmake/Qt53DExtras/Qt53DExtrasConfig.cmake)
ifneq (0,$(.SHELLSTATUS))
# Qt3DExtras intentionally removed from debian (#895386) and in turn ubuntu
@@ -129,8 +127,6 @@ ifneq (0,$(.SHELLSTATUS))
-DQT5_3DEXTRA_LIBRARY=/usr/lib/$(DEB_BUILD_MULTIARCH)/libQt53DExtras.so
endif

endif

ifneq (,$(WITH_ORACLE))
ifeq ($(DEB_BUILD_ARCH),amd64)
ORACLE_INCLUDEDIR=/usr/include/oracle/18.5/client64/
Empty file.

0 comments on commit 9e02078

Please sign in to comment.
You can’t perform that action at this time.