Skip to content
Permalink
Browse files
Mac python build changes:
- lib extension is .dylib not .so
- all qt frameworks are needed for linking


git-svn-id: http://svn.osgeo.org/qgis/trunk@6526 c8812cc2-4d05-0410-92ff-de0c093fc19c
  • Loading branch information
telwertowski committed Feb 5, 2007
1 parent df975a8 commit a3e1549c51b912a1983ee53e63bdaca6d239cc5c
Showing with 9 additions and 4 deletions.
  1. +7 −2 python/CMakeLists.txt
  2. +2 −2 python/configure.py.in
@@ -7,8 +7,13 @@ IF (WIN32)
ELSE (WIN32)
SET(BINDINGS_CORE_LIB ${CMAKE_CURRENT_BINARY_DIR}/core/core.so)
SET(BINDINGS_GUI_LIB ${CMAKE_CURRENT_BINARY_DIR}/gui/gui.so)
SET(QGIS_CORE_LIB ${CMAKE_BINARY_DIR}/src/core/libqgis_core.so)
SET(QGIS_GUI_LIB ${CMAKE_BINARY_DIR}/src/gui/libqgis_gui.so)
IF (APPLE)
SET(QGIS_CORE_LIB ${CMAKE_BINARY_DIR}/src/core/libqgis_core.dylib)
SET(QGIS_GUI_LIB ${CMAKE_BINARY_DIR}/src/gui/libqgis_gui.dylib)
ELSE (APPLE)
SET(QGIS_CORE_LIB ${CMAKE_BINARY_DIR}/src/core/libqgis_core.so)
SET(QGIS_GUI_LIB ${CMAKE_BINARY_DIR}/src/gui/libqgis_gui.so)
ENDIF (APPLE)
ENDIF (WIN32)

SET (BINDINGS_LIBS ${BINDINGS_CORE_LIB} ${BINDINGS_GUI_LIB})
@@ -76,15 +76,15 @@ for sip in sips_gui:
# linker flags needed by the Qt library.
makefile_core = sipconfig.ModuleMakefile(
configuration=config,
qt=["QtCore","QtGui","QtXml"],
qt=["QtCore","QtGui","QtNetwork","QtSql","QtSvg","QtXml","Qt3Support"],
build_file=build_file_core,
installs=installs_core,
install_dir=mod_dir,
dir="core")

makefile_gui = sipconfig.ModuleMakefile(
configuration=config,
qt=["QtCore","QtGui","QtXml"],
qt=["QtCore","QtGui","QtNetwork","QtSql","QtSvg","QtXml","Qt3Support"],
build_file=build_file_gui,
installs=installs_gui,
install_dir=mod_dir,

0 comments on commit a3e1549

Please sign in to comment.