Skip to content
Permalink
Browse files

debian packaging: depend on grass abi

  • Loading branch information
jef-n committed Sep 27, 2017
1 parent 8c3939e commit a7d1a66e5dd0dccf75d276890fd969e6c07519c9
Showing with 4 additions and 1 deletion.
  1. +2 −1 debian/control.in
  2. +2 −0 debian/rules
@@ -273,7 +273,8 @@ Depends:
qgis-provider-grass (= ${binary:Version}),
${shlibs:Depends},
${misc:Depends},
grass-core
grass-core,
grass{GRASSABI}
Description: GRASS plugin for QGIS
QGIS is a Geographic Information System (GIS) which manages, analyzes and
display databases of geographic information.
@@ -54,6 +54,7 @@ QGIS_PATCH=$(shell sed -ne 's/SET(CPACK_PACKAGE_VERSION_PATCH "\([0-9]*\)")/\1/p
QGIS_ABI=$(QGIS_MAJOR).$(QGIS_MINOR).$(QGIS_PATCH)
GRASS=grass$(subst .,,$(shell pkg-config --modversion grass|cut -d. -f1,2))
GRASSVER=$(subst .,,$(shell pkg-config --modversion grass|cut -d. -f1))
GRASSABI=$(subst .,,$(shell pkg-config --modversion grass))

This comment has been minimized.

Copy link
@sebastic

sebastic Sep 28, 2017

Contributor

Please note that the virtual package for GRASS release candidates is: <MAJOR><MINOR><PATCH>-<RC> (e.g. 722-1 for 7.2.2-RC1).

If the qgis package is never built with GRASS RCs the lack of support for its ABI package is fine, otherwise the logic used in the libgdal-grass package can be used:

GRASS_ABI=grass$(subst .,,$(shell pkg-config --modversion grass | cut -d. -f1,2,3 | sed -e 's/RC/-/'))

This comment has been minimized.

Copy link
@jef-n

jef-n Sep 28, 2017

Author Member

Thanks. See ebec25f


CMAKE_OPTS := \
-G Ninja \
@@ -187,6 +188,7 @@ $(2): $(1)
-e "s/\{QGIS_ABI\}/$(QGIS_ABI)/g" \
-e "s/\{GRASS\}/$(GRASS)/g" \
-e "s/\{GRASSVER\}/$(GRASSVER)/g" \
-e "s/\{GRASSABI\}/$(GRASSABI)/g" \
-e "s/\{GRASSVER_QGISABI\}/$(GRASSVER)-$(QGIS_ABI)/g" \
$$^ >$$@

0 comments on commit a7d1a66

Please sign in to comment.
You can’t perform that action at this time.