Skip to content
Permalink
Browse files
Update Mac release scripts for 1.0.0 preview 2.
git-svn-id: http://svn.osgeo.org/qgis/trunk@9604 c8812cc2-4d05-0410-92ff-de0c093fc19c
  • Loading branch information
telwertowski committed Nov 8, 2008
1 parent e446651 commit a96b47fc73e18ceb66ab955e5088273a33bc7e94
Showing with 25 additions and 22 deletions.
  1. +8 −8 mac/Read Me (Mac).rtf
  2. +4 −4 mac/release-check.sh
  3. +1 −1 mac/release-extra-grass.sh
  4. +2 −2 mac/release-extra-py.sh
  5. +1 −1 mac/release-extra-qt.sh
  6. +2 −2 mac/release-extra.sh
  7. +4 −4 mac/release-strip.sh
  8. +3 −0 src/mac/Contents/Info.plist.in
@@ -42,22 +42,22 @@ This release of QGIS requires Mac OS X 10.3.9 or later. A PostgreSQL version 7 o
\f1\b0 \cf0 \
The following libraries are included with this distribution of QGIS. If you have other versions of these libraries installed, QGIS will ignore your versions and use these.\
\
GDAL 1.5.2 (libgdal.1.dylib)\
GEOS 3.0.0 (libgeos_c.1.4.1.dylib)\
GDAL 1.5.3 (libgdal.1.dylib)\
GEOS 3.0.1 (libgeos_c.1.4.2.dylib)\
PROJ 4.6.1 (libproj.0.5.5.dylib)\
SQLite 3.6.2 (libsqlite3.0.dylib)\
SQLite 3.6.4 (libsqlite3.0.dylib)\
Xerces-C++ 2.8.0 (libxerces-c.28.0.dylib)\
Qt/Mac 4.4.2 (various Qt frameworks)\
Qt/Mac 4.4.3 (various Qt frameworks)\
GIF 4.1.6 (libgif.4.1.6.dylib)\
JPEG 6b (libjpeg.62.0.0.dylib)\
PNG 1.2.29 (libpng12.0.dylib)\
TIFF 3.8.2 (libtiff.3.dylib)\
GeoTIFF 1.2.4 (libgeotiff.1.2.4.dylib)\
JasPer 1.900.1.uuid (libjasper.1.0.0.dylib)\
Expat 2.0.1 (libexpat.1.5.2.dylib)\
FFTW 3.1.2 (libfftw3.3.1.2.dylib)\
FFTW 3.1.3 (libfftw3.3.1.3.dylib)\
GSL 1.11 (libgsl.0.dylib, libgslcblas.0.dylib)\
PostgreSQL 8.3.3 (libpq.5.1.dylib) This client can also access a version 7 server.\
PostgreSQL 8.3.4 (libpq.5.1.dylib) This client can also access a version 7 server.\
GRASS 6.3.0 (libgrass_*.6.3.0.dylib)\
SIP 4.7.7 (sip.so)\
PyQt4 4.4.3 (Qt*.so)\
@@ -89,15 +89,15 @@ PyQt4 4.4.3 (Qt*.so)\
\
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural

\f2 \cf0 ln -s /Applications/GPSBabel+-1.3.5/gpsbabel /usr/local/bin/gpsbabel\
\f2 \cf0 ln -s /Applications/GPSBabel+-1.3.6/gpsbabel /usr/local/bin/gpsbabel\
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural

\f1 \cf0 \
or add the folder containing GPSBabel to your search path:\
\
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural

\f2 \cf0 export PATH=$PATH:/Applications/GPSBabel+-1.3.5\
\f2 \cf0 export PATH=$PATH:/Applications/GPSBabel+-1.3.6\
\pard\tx720\tx1440\tx2160\tx2880\tx3600\tx4320\tx5040\tx5760\tx6480\tx7200\tx7920\tx8640\ql\qnatural

\f1 \cf0 \
@@ -40,8 +40,8 @@ otool -L $PREFIX/lib/QtXml.framework/Versions/4/QtXml
otool -L $PREFIX/../plugins/imageformats/libqjpeg.dylib

otool -L $PREFIX/lib/libgdal.1.dylib
otool -L $PREFIX/lib/libgeos.3.0.0.dylib
otool -L $PREFIX/lib/libgeos_c.1.4.1.dylib
otool -L $PREFIX/lib/libgeos.3.0.1.dylib
otool -L $PREFIX/lib/libgeos_c.1.4.2.dylib
otool -L $PREFIX/lib/libproj.0.5.5.dylib
otool -L $PREFIX/lib/libsqlite3.0.dylib
otool -L $PREFIX/lib/libxerces-c.28.0.dylib
@@ -52,7 +52,7 @@ otool -L $PREFIX/lib/libtiff.3.dylib
otool -L $PREFIX/lib/libgeotiff.1.2.4.dylib
otool -L $PREFIX/lib/libjasper.1.0.0.dylib
otool -L $PREFIX/lib/libexpat.1.5.2.dylib
otool -L $PREFIX/lib/libfftw3.3.1.2.dylib
otool -L $PREFIX/lib/libfftw3.3.1.3.dylib
otool -L $PREFIX/lib/libgsl.0.dylib
otool -L $PREFIX/lib/libgslcblas.0.dylib
otool -L $PREFIX/lib/libpq.5.1.dylib
@@ -82,7 +82,7 @@ if test -f $PREFIX/lib/libqgispython.dylib; then
do
otool -L $PREFIX/lib/$FRAMEWORK.framework/Versions/4/$FRAMEWORK
done
otool -L $PREFIX/lib/libQtCLucene.4.4.2.dylib
otool -L $PREFIX/lib/libQtCLucene.4.4.3.dylib

otool -L $PREFIX/share/qgis/python/sip.so
for LIBPYQT4 in Qt QtCore QtGui QtNetwork QtSql QtSvg QtXml QtAssistant QtHelp QtOpenGL QtScript QtTest QtWebKit QtXmlPatterns phonon
@@ -7,7 +7,7 @@ PREFIX=qgis1.0.0.app/Contents/MacOS
# Edit version when any library is upgraded
LNKGDAL=libgdal.1.dylib
LNKPROJ=libproj.0.dylib
LIBFFTW=libfftw3.3.1.2.dylib
LIBFFTW=libfftw3.3.1.3.dylib
LNKFFTW=libfftw3.3.dylib
GRASSVER=6.3.0
GRASSLIB=/usr/local/grass-$GRASSVER/lib
@@ -8,9 +8,9 @@ BUNDLE=qgis1.0.0.app/Contents/MacOS
LNKGDAL=libgdal.1.dylib
LNKGEOSC=libgeos_c.1.dylib

QTPREFIX=/usr/local/Trolltech/Qt-4.4.2
QTPREFIX=/usr/local/Trolltech/Qt-4.4.3
QTFRAMEWORKS="QtAssistant QtHelp QtOpenGL QtScript QtTest QtWebKit QtXmlPatterns phonon"
LIBQTCL=libQtCLucene.4.4.2.dylib
LIBQTCL=libQtCLucene.4.4.3.dylib
LNKQTCL=libQtCLucene.4.dylib

SITEPKG=/Library/Python/2.5/site-packages
@@ -10,7 +10,7 @@ LNKJPEG=libjpeg.62.dylib
LIBPNG=libpng12.0.dylib
LNKPNG=libpng12.0.dylib

QTPREFIX=/usr/local/Trolltech/Qt-4.4.2
QTPREFIX=/usr/local/Trolltech/Qt-4.4.3
QTFRAMEWORKS="QtCore QtGui QtNetwork QtSql QtSvg QtXml Qt3Support"

# Copy Qt frameworks to application bundle
@@ -11,9 +11,9 @@ PREFIXBACKTRACK=../../../..
# Edit version when any library is upgraded
LIBGDAL=libgdal.1.dylib
LNKGDAL=libgdal.1.dylib
LIBGEOS=libgeos.3.0.0.dylib
LIBGEOS=libgeos.3.0.1.dylib
LNKGEOS=libgeos.3.dylib
LIBGEOSC=libgeos_c.1.4.1.dylib
LIBGEOSC=libgeos_c.1.4.2.dylib
LNKGEOSC=libgeos_c.1.dylib
LIBPROJ=libproj.0.5.5.dylib
LNKPROJ=libproj.0.dylib
@@ -39,8 +39,8 @@ strip -x $PREFIX/lib/QtXml.framework/Versions/4/QtXml
strip -x $PREFIX/../plugins/imageformats/libqjpeg.dylib

strip -x $PREFIX/lib/libgdal.1.dylib
strip -x $PREFIX/lib/libgeos.3.0.0.dylib
strip -x $PREFIX/lib/libgeos_c.1.4.1.dylib
strip -x $PREFIX/lib/libgeos.3.0.1.dylib
strip -x $PREFIX/lib/libgeos_c.1.4.2.dylib
strip -x $PREFIX/lib/libproj.0.5.5.dylib
strip -x $PREFIX/lib/libsqlite3.0.dylib
strip -x $PREFIX/lib/libxerces-c.28.0.dylib
@@ -51,7 +51,7 @@ strip -x $PREFIX/lib/libtiff.3.dylib
strip -x $PREFIX/lib/libgeotiff.1.2.4.dylib
strip -x $PREFIX/lib/libjasper.1.0.0.dylib
strip -x $PREFIX/lib/libexpat.1.5.2.dylib
strip -x $PREFIX/lib/libfftw3.3.1.2.dylib
strip -x $PREFIX/lib/libfftw3.3.1.3.dylib
strip -x $PREFIX/lib/libgsl.0.dylib
strip -x $PREFIX/lib/libgslcblas.0.dylib
strip -x $PREFIX/lib/libpq.5.1.dylib
@@ -78,7 +78,7 @@ if test -f $PREFIX/lib/libqgispython.dylib; then
do
strip -x $PREFIX/lib/$FRAMEWORK.framework/Versions/4/$FRAMEWORK
done
strip -x $PREFIX/lib/libQtCLucene.4.4.2.dylib
strip -x $PREFIX/lib/libQtCLucene.4.4.3.dylib

strip -x $PREFIX/share/qgis/python/qgis/core.so
strip -x $PREFIX/share/qgis/python/qgis/gui.so
@@ -182,6 +182,7 @@
<string>ar</string>
<string>cs_CZ</string>
<string>de</string>
<string>el_GR</string>
<string>es</string>
<string>fr</string>
<string>hu</string>
@@ -191,13 +192,15 @@
<string>lo</string>
<string>lt</string>
<string>lv</string>
<string>ka</string>
<string>mn</string>
<string>nl</string>
<string>pl_PL</string>
<string>pt_BR</string>
<string>ro</string>
<string>ru</string>
<string>sk</string>
<string>sq_AL</string>
<string>sv</string>
<string>th</string>
<string>tr</string>

0 comments on commit a96b47f

Please sign in to comment.