Skip to content
Permalink
Browse files

making GSL and thus georeferences really optional but ON by default

  • Loading branch information
mbernasocchi committed Jul 25, 2011
1 parent 836bd37 commit a9ab98feb57f6c1fe8d074891db992720b21eeb7
Showing with 5 additions and 1 deletion.
  1. +5 −1 CMakeLists.txt
@@ -133,7 +133,6 @@ ENDIF(NOT WIN32 AND NOT ANDROID)
# required
FIND_PACKAGE(Proj)
FIND_PACKAGE(Expat) # GPS importer plugin
FIND_PACKAGE(GSL) # Georeferencer
FIND_PACKAGE(GEOS)
FIND_PACKAGE(GDAL)
FIND_PACKAGE(Qwt REQUIRED)
@@ -149,6 +148,11 @@ IF (NOT WITH_INTERNAL_SPATIALITE)
ENDIF (NOT WITH_INTERNAL_SPATIALITE)

# optional
SET (WITH_GSL TRUE CACHE BOOL "Determines whether to load GSL (and thus the georeferencer plugin)")
IF (WITH_GSL)
FIND_PACKAGE(GSL) # Georeferencer
ENDIF (WITH_GSL)

IF (WITH_POSTGRESQL)
FIND_PACKAGE(Postgres) # PostgreSQL provider, SPIT plugin
ENDIF (WITH_POSTGRESQL)

0 comments on commit a9ab98f

Please sign in to comment.
You can’t perform that action at this time.