Skip to content
Permalink
Browse files
Migrate to vue cli v5 to solve issue related to webpack 4 and fedora …
…rawhide which already uses openssl 3
  • Loading branch information
pathmapper committed Dec 30, 2021
1 parent 8c4cd94 commit a9ae64e5f2809701d01fc4489a158f1834faec30
@@ -4,7 +4,7 @@
"private": true,
"scripts": {
"serve": "vue-cli-service serve",
"build": "vue-cli-service build",
"build": "vue-cli-service build --no-module",
"lint": "vue-cli-service lint"
},
"dependencies": {
@@ -18,18 +18,18 @@
"vuex": "^3.5.1"
},
"devDependencies": {
"@vue/cli": "^4.4.6",
"@vue/cli-plugin-babel": "^4.4.6",
"@vue/cli-plugin-eslint": "^4.4.6",
"@vue/cli-service": "^4.4.6",
"@vue/cli": "~5.0.0-rc.1",
"@vue/cli-plugin-babel": "~5.0.0-rc.1",
"@vue/cli-plugin-eslint": "~5.0.0-rc.1",
"@vue/cli-service": "~5.0.0-rc.1",
"babel-eslint": "^10.1.0",
"eslint": "^7.6.0",
"eslint-plugin-vue": "^6.2.2",
"sass": "^1.26.10",
"sass": "~1.26.10",
"sass-loader": "^9.0.3",
"vue-cli-plugin-vuetify": "^2.0.7",
"vue-cli-plugin-vuetify": "~2.4.5",
"vue-template-compiler": "^2.6.11",
"vuetify-loader": "^1.6.0"
"vuetify-loader": "^1.7.3"
},
"eslintConfig": {
"root": true,
@@ -67,7 +67,7 @@
</template>

<script>
const uuidv4 = require("uuid/v4");
import { v4 as uuidv4 } from 'uuid';
export default {
name: "AttributeTable",
props: {
@@ -51,7 +51,7 @@

<script>
import LayerTreeNode from "@/components/LayerTreeNode.vue";
const uuidv4 = require("uuid/v4");
import { v4 as uuidv4 } from 'uuid';
export default {
name: "LayerTree",
props: {
@@ -175,4 +175,4 @@ ul.layer-group {
.v-navigation-drawer {
z-index: 5000;
}
</style>
</style>
@@ -174,7 +174,7 @@
</template>

<script>
const uuidv4 = require("uuid/v4");
import { v4 as uuidv4 } from 'uuid';
export default {
name: "LayerTreeNode",
props: {
@@ -126,7 +126,7 @@


<script>
const uuidv4 = require("uuid/v4");
import { v4 as uuidv4 } from 'uuid';
export default {
props: {

0 comments on commit a9ae64e

Please sign in to comment.