Skip to content
Permalink
Browse files
Update Mac release scripts for 0.8.1.
git-svn-id: http://svn.osgeo.org/qgis/branches/Release-0_8_0@7034 c8812cc2-4d05-0410-92ff-de0c093fc19c
  • Loading branch information
telwertowski committed Jun 15, 2007
1 parent 548bac3 commit ab3f37e4996df6aa9bcb3bd2b7c3a3f7597109a2
Showing with 68 additions and 76 deletions.
  1. +11 −50 mac/Read Me (Mac).rtf
  2. +1 −0 mac/install-extra.sh
  3. +4 −2 mac/release-check.sh
  4. +28 −20 mac/release-extra-qt.sh
  5. +20 −2 mac/release-extra.sh
  6. +4 −2 mac/release-strip.sh
@@ -1,11 +1,11 @@
{\rtf1\mac\ansicpg10000\cocoartf824\cocoasubrtf410
\readonlydoc1{\fonttbl\f0\fswiss\fcharset77 Helvetica-Bold;\f1\fswiss\fcharset77 Helvetica;\f2\fmodern\fcharset77 Courier;
\f3\fswiss\fcharset77 Helvetica-Oblique;}
}
{\colortbl;\red255\green255\blue255;}
\margl1440\margr1440\vieww11100\viewh8700\viewkind0
\pard\tx720\tx1440\tx2160\tx2880\tx3600\tx4320\tx5040\tx5760\tx6480\tx7200\tx7920\tx8640\qc

\f0\b\fs24 \cf0 QGIS 0.8.0 Release Notes for Macintosh
\f0\b\fs24 \cf0 QGIS 0.8.1 Release Notes for Macintosh
\f1\b0 \
\pard\tx720\tx1440\tx2160\tx2880\tx3600\tx4320\tx5040\tx5760\tx6480\tx7200\tx7920\tx8640\ql\qnatural
\cf0 \
@@ -41,12 +41,12 @@ This release of QGIS requires Mac OS X 10.3.9 or 10.4. A PostgreSQL version 7 or
\f1\b0 \cf0 \
The following libraries are included with this distribution of QGIS. If you have other versions of these libraries installed, QGIS will ignore your versions and use these.\
\
GDAL 1.3.2 (libgdal.1.10.0.dylib)\
GDAL 1.4.1 (libgdal.1.11.0.dylib)\
GEOS 2.2.3 (libgeos.2.2.3.dylib)\
PROJ 4.4.9 (libproj.0.5.0.dylib)\
SQLITE3 3.3.6 (libsqlite3.0.8.6.dylib)\
SQLITE3 3.3.15 (libsqlite3.0.8.6.dylib)\
Xerces-C++ 2.7.0 (libxerces-c.27.0.dylib)\
Qt/Mac 4.2.2 (various Qt frameworks)\
Qt/Mac 4.3.0 (various Qt frameworks)\
GIF 4.1.4 (libgif.4.1.4.dylib)\
JPEG 6b (libjpeg.62.0.0.dylib)\
PNG 1.2.8 (libpng.3.1.2.8.dylib)\
@@ -55,7 +55,7 @@ GeoTIFF 1.2.3 (libgeotiff.1.2.3.dylib)\
JasPer 1.701.0.GEO (libjasper-1.701.1.0.0.dylib)\
Expat 2.0.0 (libexpat.1.5.0.dylib)\
GSL 1.8 (libgsl.0.9.0.dylib, libgslcblas.0.0.0.dylib)\
PostgreSQL 8.2.0 (libpq.5.0.dylib) This client can also access a version 7 server.\
PostgreSQL 8.2.4 (libpq.5.0.dylib) This client can also access a version 7 server.\
GRASS 6.2.1 (libgrass_*.6.2.1.dylib)\
\
\
@@ -70,14 +70,8 @@ GRASS 6.2.1 (libgrass_*.6.2.1.dylib)\
\cf0 Some dialogs have cosmetic issues with buttons.\
\pard\tx720\tx1440\tx2160\tx2880\tx3600\tx4320\tx5040\tx5760\tx6480\tx7200\tx7920\tx8640\ql\qnatural
\cf0 \
If the International System Preferences Language is changed, it will not affect QGIS until the next login. To use a different language without relogging in, start QGIS from a Terminal session. For example:\
To use QGIS with a language other than English, you must change both the Language and Format settings in the International System Preferences. The QGIS application menu uses the Language preference while all other QGIS menus use the Format preference to select the language.\
\
\pard\tx720\tx1440\tx2160\tx2880\tx3600\tx4320\tx5040\tx5760\tx6480\tx7200\tx7920\tx8640\ql\qnatural

\f2 \cf0 qgis.app/Contents/MacOS/qgis --lang it\
\pard\tx720\tx1440\tx2160\tx2880\tx3600\tx4320\tx5040\tx5760\tx6480\tx7200\tx7920\tx8640\ql\qnatural

\f1 \cf0 \
\
\
\pard\tx720\tx1440\tx2160\tx2880\tx3600\tx4320\tx5040\tx5760\tx6480\tx7200\tx7920\tx8640\ql\qnatural
@@ -91,15 +85,15 @@ If the International System Preferences Language is changed, it will not affect
\
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural

\f2 \cf0 ln -s /Applications/GPSBabel+\\ 1.3.0/gpsbabel /usr/local/bin/gpsbabel\
\f2 \cf0 ln -s /Applications/GPSBabel+\\ 1.3.3/gpsbabel /usr/local/bin/gpsbabel\
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural

\f1 \cf0 \
or add the folder containing GPSBabel to your search path:\
\
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural

\f2 \cf0 export PATH=$PATH:/Applications/GPSBabel+\\ 1.3.0\
\f2 \cf0 export PATH=$PATH:/Applications/GPSBabel+\\ 1.3.3\
\pard\tx720\tx1440\tx2160\tx2880\tx3600\tx4320\tx5040\tx5760\tx6480\tx7200\tx7920\tx8640\ql\qnatural

\f1 \cf0 \
@@ -112,46 +106,13 @@ or add the folder containing GPSBabel to your search path:\
\f1\b0 \cf0 \
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural
\cf0 To use all the functions of the GRASS plugin, QGIS should be launched from inside GRASS. This can be done in two ways.\
\
One method is to launch QGIS from the GRASS command-line prompt:\
\
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural

\f2 \cf0 /Applications/qgis-0.8.0/qgis.app/Contents/MacOS/qgis\
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural

\f1 \cf0 \
Another method is to add a menu item for QGIS to the GRASS menu bar.\
\
To do this for GRASS 6.0.x, open the file\
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural

\f2 \cf0 /Applications/Grass/grass60.app/Contents/Resources/grass-6.0.0/etc/dm/menu.tcl\
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural

\f1 \cf0 using a text editor and add the following three lines just before the line beginning with "&Help" which should be line 500. (The second line is very long and is probably displayed here on more than one line. It begins with "\{command" and ends with "\} \}".)\
\cf0 To use all the functions of the GRASS plugin, QGIS should be launched from inside GRASS. Some GRASS distributions provide a GRASS menu item to launch QGIS. If GRASS does not contain a QGIS menu item, launch QGIS from the GRASS command-line prompt:\
\
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural

\f2 \cf0 "&Ext" all options $tmenu \{\
\{command "Open QGIS" \{\} "Open QGIS (Quantum GIS) with Grass support enabled" \{\} -command \{ exec $env(GRASS_HTML_BROWSER) "/Applications/qgis-0.8.0/qgis.app" & \} \}\
\}\
\f2 \cf0 /Applications/qgis-0.8.1/qgis.app/Contents/MacOS/qgis\
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural

\f1 \cf0 \
For GRASS 6.1.x, the
\f2 menu.tcl
\f1 file has changed considerably. Although it is still possible to add an Open QGIS command, the above text must be modified and cannot be inserted as is.\
\
After making this edit and launching GRASS, you can select "Open QGIS" from the new Ext (external application) menu.\
\
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural

\f3\i \cf0 Thanks to Lorenzo Moretti for providing the GRASS 6.0.x menu information.\
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural
\f1\i0 \cf0 \
\
If you try to use the GRASS plugin while not running GRASS, you will be able to open GRASS files but not use GRASS tools. If you have not previously run QGIS with GRASS, you may be prompted for the location of the GRASS directory GISBASE. Because this directory is inside the GRASS application bundle and cannot be directly selected, you should choose Cancel and then run QGIS from inside GRASS. QGIS will remember the GISBASE directory for subsequent launches.\
}
@@ -57,6 +57,7 @@ for PLUGIN in \
qgis/grassplugin.so \
qgis/grassprovider.so \
qgis/gridmakerplugin.so \
qgis/launcherplugin.so \
qgis/libwfsprovider.so \
qgis/northarrowplugin.so \
qgis/ogrprovider.so \
@@ -28,6 +28,7 @@ otool -L $PREFIX/lib/qgis/gpxprovider.so
otool -L $PREFIX/lib/qgis/grassplugin.so
otool -L $PREFIX/lib/qgis/grassprovider.so
otool -L $PREFIX/lib/qgis/gridmakerplugin.so
otool -L $PREFIX/lib/qgis/launcherplugin.so
otool -L $PREFIX/lib/qgis/libwfsprovider.so
otool -L $PREFIX/lib/qgis/northarrowplugin.so
otool -L $PREFIX/lib/qgis/ogrprovider.so
@@ -49,12 +50,13 @@ otool -L $PREFIX/lib/QtSvg.framework/Versions/4/QtSvg
otool -L $PREFIX/lib/QtXml.framework/Versions/4/QtXml
otool -L $PREFIX/lib/QtDesigner.framework/Versions/4/QtDesigner
otool -L $PREFIX/lib/QtTest.framework/Versions/4/QtTest
otool -L $PREFIX/imageformats/libqjpeg.dylib
otool -L $PREFIX/../plugins/imageformats/libqjpeg.dylib

otool -L $PREFIX/lib/libgdal.1.10.0.dylib
otool -L $PREFIX/lib/libgdal.1.11.0.dylib
otool -L $PREFIX/lib/gdalplugins/gdal_GRASS.so
otool -L $PREFIX/lib/gdalplugins/ogr_GRASS.so
otool -L $PREFIX/lib/libgeos.2.2.3.dylib
otool -L $PREFIX/lib/libgeos_c.1.1.1.dylib
otool -L $PREFIX/lib/libproj.0.5.0.dylib
otool -L $PREFIX/lib/libsqlite3.0.8.6.dylib
otool -L $PREFIX/lib/libxerces-c.27.0.dylib
@@ -10,9 +10,8 @@ LNKJPEG=libjpeg.62.dylib
LIBPNG=libpng.3.1.2.8.dylib
LNKPNG=libpng.3.dylib

QTVER=4.2.2
QTPREFIX=/usr/local/Trolltech/Qt-$QTVER
QTFRAMEWORKS="QtCore QtGui QtNetwork QtSql QtSvg QtXml Qt3Support QtDesigner QtTest"
QTPREFIX=/usr/local/Qt4.3
QTFRAMEWORKS="QtCore QtGui QtNetwork QtSql QtSvg QtXml Qt3Support QtDesigner QtScript QtTest"

# Copy supporting frameworks to application bundle
cd $PREFIX/lib
@@ -25,56 +24,64 @@ do
mkdir $FRAMEWORK.framework/Versions
mkdir $FRAMEWORK.framework/Versions/4
cp $QTPREFIX/lib/$LIBFRAMEWORK $LIBFRAMEWORK
install_name_tool -id @executable_path/libs/$LIBFRAMEWORK $LIBFRAMEWORK
install_name_tool -id @executable_path/lib/$LIBFRAMEWORK $LIBFRAMEWORK
fi
done

# Update path to supporting frameworks
for FRAMEWORK in QtGui QtNetwork QtSql QtSvg QtXml Qt3Support QtDesigner QtTest
for FRAMEWORK in QtGui QtNetwork QtSql QtSvg QtXml Qt3Support QtDesigner QtScript QtTest
do
install_name_tool -change $QTPREFIX/lib/QtCore.framework/Versions/4/QtCore \
install_name_tool -change QtCore.framework/Versions/4/QtCore \
@executable_path/lib/QtCore.framework/Versions/4/QtCore \
$FRAMEWORK.framework/Versions/4/$FRAMEWORK
done
for FRAMEWORK in QtSvg Qt3Support QtDesigner
do
install_name_tool -change $QTPREFIX/lib/QtGui.framework/Versions/4/QtGui \
install_name_tool -change QtGui.framework/Versions/4/QtGui \
@executable_path/lib/QtGui.framework/Versions/4/QtGui \
$FRAMEWORK.framework/Versions/4/$FRAMEWORK
install_name_tool -change $QTPREFIX/lib/QtXml.framework/Versions/4/QtXml \
install_name_tool -change QtXml.framework/Versions/4/QtXml \
@executable_path/lib/QtXml.framework/Versions/4/QtXml \
$FRAMEWORK.framework/Versions/4/$FRAMEWORK
done
for FRAMEWORK in Qt3Support
do
install_name_tool -change $QTPREFIX/lib/QtNetwork.framework/Versions/4/QtNetwork \
install_name_tool -change QtNetwork.framework/Versions/4/QtNetwork \
@executable_path/lib/QtNetwork.framework/Versions/4/QtNetwork \
$FRAMEWORK.framework/Versions/4/$FRAMEWORK
install_name_tool -change $QTPREFIX/lib/QtSql.framework/Versions/4/QtSql \
install_name_tool -change QtSql.framework/Versions/4/QtSql \
@executable_path/lib/QtSql.framework/Versions/4/QtSql \
$FRAMEWORK.framework/Versions/4/$FRAMEWORK
done
for FRAMEWORK in QtDesigner
do
install_name_tool -change QtScript.framework/Versions/4/QtScript \
@executable_path/lib/QtScript.framework/Versions/4/QtScript \
$FRAMEWORK.framework/Versions/4/$FRAMEWORK
done
for FRAMEWORK in QtGui QtSvg Qt3Support QtDesigner
do
install_name_tool -change /usr/local/lib/$LNKPNG @executable_path/lib/$LNKPNG \
$FRAMEWORK.framework/Versions/4/$FRAMEWORK
done
cd ../
LIBQJPEG=imageformats/libqjpeg.dylib
cd ../../
LIBQJPEG=plugins/imageformats/libqjpeg.dylib
if test ! -f $LIBQJPEG; then
mkdir imageformats
cp $QTPREFIX/plugins/$LIBQJPEG $LIBQJPEG
mkdir plugins
mkdir plugins/imageformats
cp $QTPREFIX/$LIBQJPEG $LIBQJPEG
install_name_tool -id @executable_path/../$LIBQJPEG $LIBQJPEG
# Update path to supporting libraries
install_name_tool -change $QTPREFIX/lib/QtCore.framework/Versions/4/QtCore \
install_name_tool -change QtCore.framework/Versions/4/QtCore \
@executable_path/lib/QtCore.framework/Versions/4/QtCore \
$LIBQJPEG
install_name_tool -change $QTPREFIX/lib/QtGui.framework/Versions/4/QtGui \
install_name_tool -change QtGui.framework/Versions/4/QtGui \
@executable_path/lib/QtGui.framework/Versions/4/QtGui \
$LIBQJPEG
install_name_tool -change /usr/local/lib/$LNKJPEG @executable_path/lib/$LNKJPEG $LIBQJPEG
install_name_tool -change /usr/local/lib/$LNKPNG @executable_path/lib/$LNKPNG $LIBQJPEG
# Empty qt.conf indicates plugins are in default location within this bundle
cp /dev/null Resources/qt.conf
fi
cd ../../../
cd ../../

for FILE in \
qgis \
@@ -96,6 +103,7 @@ for FILE in \
lib/qgis/grassplugin.so \
lib/qgis/grassprovider.so \
lib/qgis/gridmakerplugin.so \
lib/qgis/launcherplugin.so \
lib/qgis/libwfsprovider.so \
lib/qgis/northarrowplugin.so \
lib/qgis/ogrprovider.so \
@@ -111,7 +119,7 @@ for FILE in \
do
for FRAMEWORK in QtCore QtGui QtNetwork QtSql QtSvg QtXml Qt3Support QtDesigner QtTest
do
install_name_tool -change $QTPREFIX/lib/$FRAMEWORK.framework/Versions/4/$FRAMEWORK \
install_name_tool -change $FRAMEWORK.framework/Versions/4/$FRAMEWORK \
@executable_path/lib/$FRAMEWORK.framework/Versions/4/$FRAMEWORK \
$PREFIX/$FILE
done
@@ -9,10 +9,12 @@ MSEXPORTPREFIX=$PREFIX/bin/msexport.app/Contents/MacOS
PREFIXBACKTRACK=../../../..

# Edit version when any library is upgraded
LIBGDAL=libgdal.1.10.0.dylib
LIBGDAL=libgdal.1.11.0.dylib
LNKGDAL=libgdal.1.dylib
LIBGEOS=libgeos.2.2.3.dylib
LNKGEOS=libgeos.2.dylib
LIBGEOSC=libgeos_c.1.1.1.dylib
LNKGEOSC=libgeos_c.1.dylib
LIBPROJ=libproj.0.5.0.dylib
LNKPROJ=libproj.0.dylib
LIBSQLITE3=libsqlite3.0.8.6.dylib
@@ -50,12 +52,20 @@ if test ! -f $LIBGEOS; then
ln -s $LIBGEOS $LNKGEOS
install_name_tool -id @executable_path/lib/$LNKGEOS $LIBGEOS
fi
if test ! -f $LIBGEOSC; then
cp /usr/local/lib/$LIBGEOSC $LIBGEOSC
ln -s $LIBGEOSC $LNKGEOSC
install_name_tool -id @executable_path/lib/$LNKGEOSC $LIBGEOSC
# Update path to supporting libraries
install_name_tool -change /usr/local/lib/$LNKGEOS @executable_path/lib/$LNKGEOS $LIBGEOSC
fi
if test ! -f $LIBGDAL; then
cp /usr/local/lib/$LIBGDAL $LIBGDAL
ln -s $LIBGDAL $LNKGDAL
install_name_tool -id @executable_path/lib/$LNKGDAL $LIBGDAL
# Update path to supporting libraries
install_name_tool -change /usr/local/lib/$LNKGEOS @executable_path/lib/$LNKGEOS $LIBGDAL
install_name_tool -change /usr/local/lib/$LNKGEOSC @executable_path/lib/$LNKGEOSC $LIBGDAL
install_name_tool -change /usr/local/lib/$LNKSQLITE3 @executable_path/lib/$LNKSQLITE3 $LIBGDAL
install_name_tool -change /usr/local/lib/$LNKXERCESC @executable_path/lib/$LNKXERCESC $LIBGDAL
install_name_tool -change /usr/local/lib/$LNKGIF @executable_path/lib/$LNKGIF $LIBGDAL
@@ -190,6 +200,7 @@ cd ../../../../
# Update application paths to supporting libraries
install_name_tool -change /usr/local/lib/$LNKGDAL @executable_path/lib/$LNKGDAL $PREFIX/qgis
install_name_tool -change /usr/local/lib/$LNKGEOS @executable_path/lib/$LNKGEOS $PREFIX/qgis
install_name_tool -change /usr/local/lib/$LNKGEOSC @executable_path/lib/$LNKGEOSC $PREFIX/qgis
install_name_tool -change /usr/local/lib/$LNKPROJ @executable_path/lib/$LNKPROJ $PREFIX/qgis
install_name_tool -change /usr/local/lib/$LNKSQLITE3 @executable_path/lib/$LNKSQLITE3 $PREFIX/qgis
install_name_tool -change /usr/local/lib/$LNKXERCESC @executable_path/lib/$LNKXERCESC $PREFIX/qgis
@@ -208,6 +219,7 @@ for LIB in _core.1.0.0 _gui.1.0.0 _raster.1.0.0 grass.1.0.0
do
install_name_tool -change /usr/local/lib/$LNKGDAL @executable_path/lib/$LNKGDAL $PREFIX/lib/libqgis$LIB.dylib
install_name_tool -change /usr/local/lib/$LNKGEOS @executable_path/lib/$LNKGEOS $PREFIX/lib/libqgis$LIB.dylib
install_name_tool -change /usr/local/lib/$LNKGEOSC @executable_path/lib/$LNKGEOSC $PREFIX/lib/libqgis$LIB.dylib
install_name_tool -change /usr/local/lib/$LNKSQLITE3 @executable_path/lib/$LNKSQLITE3 $PREFIX/lib/libqgis$LIB.dylib
install_name_tool -change /usr/local/lib/$LNKXERCESC @executable_path/lib/$LNKXERCESC $PREFIX/lib/libqgis$LIB.dylib
install_name_tool -change /usr/local/lib/$LNKGIF @executable_path/lib/$LNKGIF $PREFIX/lib/libqgis$LIB.dylib
@@ -229,6 +241,7 @@ for PLUGIN in \
grassplugin.so \
grassprovider.so \
gridmakerplugin.so \
launcherplugin.so \
libwfsprovider.so \
northarrowplugin.so \
ogrprovider.so \
@@ -243,6 +256,7 @@ for PLUGIN in \
do
install_name_tool -change /usr/local/lib/$LNKGDAL @executable_path/lib/$LNKGDAL $PREFIX/lib/qgis/$PLUGIN
install_name_tool -change /usr/local/lib/$LNKGEOS @executable_path/lib/$LNKGEOS $PREFIX/lib/qgis/$PLUGIN
install_name_tool -change /usr/local/lib/$LNKGEOSC @executable_path/lib/$LNKGEOSC $PREFIX/lib/qgis/$PLUGIN
install_name_tool -change /usr/local/lib/$LNKSQLITE3 @executable_path/lib/$LNKSQLITE3 $PREFIX/lib/qgis/$PLUGIN
install_name_tool -change /usr/local/lib/$LNKXERCESC @executable_path/lib/$LNKXERCESC $PREFIX/lib/qgis/$PLUGIN
install_name_tool -change /usr/local/lib/$LNKGIF @executable_path/lib/$LNKGIF $PREFIX/lib/qgis/$PLUGIN
@@ -286,7 +300,7 @@ for PLUGIN in \
gdalplugins/gdal_GRASS.so \
gdalplugins/ogr_GRASS.so
do
for LIB in datetime dbmibase dbmiclient gis gmath gproj I vask vect
for LIB in datetime dbmibase dbmiclient dgl dig2 gis gmath gproj I linkm rtree vask vect
do
install_name_tool -change $GRASSLIB/libgrass_$LIB.dylib \
@executable_path/lib/grass/libgrass_$LIB.dylib \
@@ -302,6 +316,7 @@ ln -sf $PREFIXBACKTRACK/lib $HELPPREFIX/lib
# Update msexport application paths to supporting libraries
install_name_tool -change /usr/local/lib/$LNKGDAL @executable_path/lib/$LNKGDAL $MSEXPORTPREFIX/msexport
install_name_tool -change /usr/local/lib/$LNKGEOS @executable_path/lib/$LNKGEOS $MSEXPORTPREFIX/msexport
install_name_tool -change /usr/local/lib/$LNKGEOSC @executable_path/lib/$LNKGEOSC $MSEXPORTPREFIX/msexport
install_name_tool -change /usr/local/lib/$LNKPROJ @executable_path/lib/$LNKPROJ $MSEXPORTPREFIX/msexport
install_name_tool -change /usr/local/lib/$LNKSQLITE3 @executable_path/lib/$LNKSQLITE3 $MSEXPORTPREFIX/msexport
install_name_tool -change /usr/local/lib/$LNKXERCESC @executable_path/lib/$LNKXERCESC $MSEXPORTPREFIX/msexport
@@ -312,11 +327,13 @@ install_name_tool -change /usr/local/lib/$LNKTIFF @executable_path/lib/$LNKTIFF
install_name_tool -change /usr/local/lib/$LNKGEOTIFF @executable_path/lib/$LNKGEOTIFF $MSEXPORTPREFIX/msexport
install_name_tool -change /usr/local/lib/$LNKJASPER @executable_path/lib/$LNKJASPER $MSEXPORTPREFIX/msexport
install_name_tool -change /usr/local/pgsql/lib/$LNKPQ @executable_path/lib/$LNKPQ $MSEXPORTPREFIX/msexport
ln -sf $PREFIXBACKTRACK/bin $MSEXPORTPREFIX/bin
ln -sf $PREFIXBACKTRACK/lib $MSEXPORTPREFIX/lib

# Update spit application paths to supporting libraries
#install_name_tool -change /usr/local/lib/$LNKGDAL @executable_path/lib/$LNKGDAL $PREFIX/bin/spit
#install_name_tool -change /usr/local/lib/$LNKGEOS @executable_path/lib/$LNKGEOS $PREFIX/bin/spit
#install_name_tool -change /usr/local/lib/$LNKGEOSC @executable_path/lib/$LNKGEOSC $PREFIX/bin/spit
#install_name_tool -change /usr/local/lib/$LNKSQLITE3 @executable_path/lib/$LNKSQLITE3 $PREFIX/bin/spit
#install_name_tool -change /usr/local/lib/$LNKXERCESC @executable_path/lib/$LNKXERCESC $PREFIX/bin/spit
#install_name_tool -change /usr/local/lib/$LNKGIF @executable_path/lib/$LNKGIF $PREFIX/bin/spit
@@ -329,6 +346,7 @@ ln -sf $PREFIXBACKTRACK/lib $MSEXPORTPREFIX/lib
# Update omgui application paths to supporting libraries
#install_name_tool -change /usr/local/lib/$LNKGDAL @executable_path/lib/$LNKGDAL $PREFIX/bin/omgui
#install_name_tool -change /usr/local/lib/$LNKGEOS @executable_path/lib/$LNKGEOS $PREFIX/bin/omgui
#install_name_tool -change /usr/local/lib/$LNKGEOSC @executable_path/lib/$LNKGEOSC $PREFIX/bin/omgui
#install_name_tool -change /usr/local/lib/$LNKSQLITE3 @executable_path/lib/$LNKSQLITE3 $PREFIX/bin/omgui
#install_name_tool -change /usr/local/lib/$LNKXERCESC @executable_path/lib/$LNKXERCESC $PREFIX/bin/omgui
#install_name_tool -change /usr/local/lib/$LNKEXPAT @executable_path/lib/$LNKEXPAT $PREFIX/bin/omgui
Loading

0 comments on commit ab3f37e

Please sign in to comment.