Skip to content
Permalink
Browse files

debian packaging: depend on grass abi

(cherry picked from commit a7d1a66)
  • Loading branch information
jef-n committed Sep 27, 2017
1 parent d3d8f4d commit ac890ba2a3f3b59d754b1fcd818d053f8189c96d
Showing with 4 additions and 1 deletion.
  1. +2 −1 debian/control.in
  2. +2 −0 debian/rules
@@ -304,7 +304,8 @@ Depends:
qgis-provider-grass (= ${binary:Version}),
${shlibs:Depends},
${misc:Depends},
grass-core
grass-core,
grass{GRASSABI}
Replaces: qgis-provider-grass (<< 1:2.11.0+git20151002)
Conflicts: qgis-provider-grass (<< 1:2.11.0+git20151002)
Description: GRASS plugin for QGIS
@@ -52,6 +52,7 @@ QGIS_PATCH=$(shell sed -ne 's/SET(CPACK_PACKAGE_VERSION_PATCH "\([0-9]*\)")/\1/p
QGIS_ABI=$(QGIS_MAJOR).$(QGIS_MINOR).$(QGIS_PATCH)
GRASS=grass$(subst .,,$(shell pkg-config --modversion grass|cut -d. -f1,2))
GRASSVER=$(subst .,,$(shell pkg-config --modversion grass|cut -d. -f1))
GRASSABI=$(subst .,,$(shell pkg-config --modversion grass))

WITH_GLOBE=$(shell dpkg --compare-versions "$$(dpkg-query -W --showformat='$${Version}' libosgearth-dev)" ge 2.7 && dpkg --compare-versions "$$(dpkg-query -W --showformat='$${Version}' libosgearth-dev)" lt 2.8 && echo 1)

@@ -239,6 +240,7 @@ $(2): $(1)
-e "s/\{QGIS_ABI\}/$(QGIS_ABI)/g" \
-e "s/\{GRASS\}/$(GRASS)/g" \
-e "s/\{GRASSVER\}/$(GRASSVER)/g" \
-e "s/\{GRASSABI\}/$(GRASSABI)/g" \
-e "s/\{GRASSVER_QGISABI\}/$(GRASSVER)-$(QGIS_ABI)/g" \
$$^ >$$@

0 comments on commit ac890ba

Please sign in to comment.
You can’t perform that action at this time.