Skip to content
Permalink
Browse files

debian packaging: add support for yakkety

  • Loading branch information
jef-n committed Oct 14, 2016
1 parent dd85796 commit b8a2bc443b63e6d43b495a74e9035eb31dd6a892
Showing with 23 additions and 23 deletions.
  1. +1 −1 debian/compat.in
  2. +17 −17 debian/control.in
  3. +2 −2 debian/qgis-providers.install.in
  4. +3 −3 debian/rules
@@ -1,3 +1,3 @@
#stretch sid jessie trusty xenial#9
#stretch sid jessie trusty xenial yakkety#9
#jessie#8
#precise#7
@@ -6,20 +6,20 @@ Priority: optional
Build-Depends:
bison,
cmake (>= 2.8),
#sid stretch jessie trusty xenial# debhelper (>= 9),
#sid stretch jessie trusty xenial# dh-python,
#sid stretch jessie trusty xenial yakkety# debhelper (>= 9),
#sid stretch jessie trusty xenial yakkety# dh-python,
#precise# debhelper (>= 7),
flex,
grass-dev,
libexpat1-dev,
libfcgi-dev,
#sid stretch jessie trusty xenial# libgdal-dev (>= 1.10.1-0~),
#sid stretch jessie trusty xenial yakkety# libgdal-dev (>= 1.10.1-0~),
#precise# libgdal-dev (>= 1.9.0) | libgdal1-dev (<< 1.9.0),
gdal-bin,
python-gdal,
libgeos-dev (>= 3.0.0),
#jessie precise trusty# libgsl0-dev,
#sid stretch xenial# libgsl-dev,
#sid stretch xenial yakkety# libgsl-dev,
libpq-dev,
libproj-dev,
libqt4-dev (>= 4.7.0),
@@ -28,8 +28,8 @@ Build-Depends:
libqca2-plugin-ossl,
libqtwebkit-dev,
#stretch jessie# libqwt-dev,
#precise trusty xenial sid# libqwt5-qt4-dev,
#sid stretch jessie trusty xenial# libqjson-dev,
#precise trusty xenial yakkety sid# libqwt5-qt4-dev,
#sid stretch jessie trusty xenial yakkety# libqjson-dev,
libspatialite-dev,
libsqlite3-dev,
libspatialindex-dev,
@@ -40,13 +40,13 @@ Build-Depends:
python-qt4-dev,
python-qt4-sql,
python-yaml, python-mock,
#stretch sid xenial# python-future,
#stretch sid xenial yakkety# python-future,
#precise# python,
#precise# python-central (>= 0.5),
#sid stretch jessie trusty xenial# python-all (>= 2.6.6-3~), python-all-dev (>= 2.6.6-3~),
#sid stretch jessie xenial# pyqt4.qsci-dev,
#sid stretch jessie trusty xenial# python-pyspatialite,
#sid jessie stretch trusty xenial# python-nose2,
#sid stretch jessie trusty xenial yakkety# python-all (>= 2.6.6-3~), python-all-dev (>= 2.6.6-3~),
#sid stretch jessie xenial yakkety# pyqt4.qsci-dev,
#sid stretch jessie trusty xenial yakkety# python-pyspatialite,
#sid jessie stretch trusty xenial yakkety# python-nose2,
python-sip (>= 4.5.0),
python-sip-dev (>= 4.5.0),
libosgearth-dev,
@@ -63,11 +63,11 @@ Build-Depends:
qt4-dev-tools,
libqt4-sql-sqlite, python-psycopg2, ca-certificates
Build-Conflicts: libqgis-dev, qgis-dev
#sid stretch xenial#Standards-Version: 3.9.7
#sid stretch xenial yakkety#Standards-Version: 3.9.7
#jessie#Standards-Version: 3.9.6
#precise trusty#Standards-Version: 3.8.4
#sid stretch jessie#X-Python-Version: >= 2.7, << 2.8
#precise trusty xenial#XS-Python-Version: current
#precise trusty xenial yakkety#XS-Python-Version: current
Vcs-Browser: https://github.com/qgis/QGIS/
Vcs-Git: https://github.com/qgis/QGIS.git
Homepage: http://qgis.org/
@@ -240,11 +240,11 @@ Section: libdevel
Depends:
grass-dev,
libexpat1-dev,
#sid stretch jessie trusty xenial# libgdal-dev (>= 1.10.1-0~),
#sid stretch jessie trusty xenial yakkety# libgdal-dev (>= 1.10.1-0~),
#precise# libgdal-dev (>= 1.9.0) | libgdal1-dev (<< 1.9.0),
libgeos-dev (>= 3.0.0),
#jessie precise trusty# libgsl0-dev,
#sid stretch xenial# libgsl-dev,
#sid stretch xenial yakkety# libgsl-dev,
libpq-dev,
libproj-dev,
libqgis-app{QGIS_ABI} (= ${binary:Version}),
@@ -382,8 +382,8 @@ Depends:
python-tz,
python-six,
python-yaml,
#stretch sid xenial# python-future,
#sid stretch jessie trusty xenial# python-pyspatialite,
#stretch sid xenial yakkety# python-future,
#sid stretch jessie trusty xenial yakkety# python-pyspatialite,
libqgispython{QGIS_ABI},
${shlibs:Depends},
${python:Depends},
@@ -17,6 +17,6 @@ usr/lib/qgis/plugins/libvirtuallayerprovider.so
usr/lib/qgis/plugins/libwcsprovider.so
usr/lib/qgis/plugins/libwfsprovider.so
usr/lib/qgis/plugins/libwmsprovider.so
#sid stretch jessie trusty xenial#usr/lib/qgis/plugins/libarcgismapserverprovider.so
#sid stretch jessie trusty xenial#usr/lib/qgis/plugins/libarcgisfeatureserverprovider.so
#sid stretch jessie trusty xenial yakkety#usr/lib/qgis/plugins/libarcgismapserverprovider.so
#sid stretch jessie trusty xenial yakkety#usr/lib/qgis/plugins/libarcgisfeatureserverprovider.so
{QT_PLUGIN_DIR}/sqldrivers/libqsqlspatialite.so
@@ -34,7 +34,7 @@ ifneq (,$(findstring -oracle,$(DISTRIBUTION)))
WITH_ORACLE=1
endif

ifneq ($(DISTRIBUTION),$(findstring $(DISTRIBUTION),"jessie stretch precise trusty xenial"))
ifneq ($(DISTRIBUTION),$(findstring $(DISTRIBUTION),"jessie stretch precise trusty xenial yakkety"))
DISTRIBUTION := sid
endif

@@ -107,7 +107,7 @@ else
CMAKE_OPTS += -DWITH_INTERNAL_NOSE2=FALSE -DWITH_INTERNAL_SIX=FALSE
endif

ifeq (,$(findstring $(DISTRIBUTION),"stretch sid xenial"))
ifeq (,$(findstring $(DISTRIBUTION),"stretch sid xenial yakkety"))
CMAKE_OPTS += -DWITH_INTERNAL_FUTURE=TRUE
else
CMAKE_OPTS += -DWITH_INTERNAL_FUTURE=FALSE
@@ -133,7 +133,7 @@ ifneq (,$(findstring $(DISTRIBUTION),"sid"))
CMAKE_OPTS += -DGEOS_LIBRARY=/usr/lib/$(DEB_BUILD_MULTIARCH)/libgeos_c.so
endif

ifneq (,$(findstring $(DISTRIBUTION),"jessie stretch trusty xenial sid"))
ifneq (,$(findstring $(DISTRIBUTION),"jessie stretch trusty xenial yakkety sid"))
CMAKE_OPTS += -DPYTHON_LIBRARY=/usr/lib/$(DEB_BUILD_MULTIARCH)/libpython2.7.so
endif

0 comments on commit b8a2bc4

Please sign in to comment.
You can’t perform that action at this time.