Skip to content
Permalink
Browse files

run t2t

  • Loading branch information
jef-n committed Jun 14, 2015
1 parent ac8d4df commit bbe2e2a5364429d05239b3f964d17742f5464db2
Showing with 30 additions and 24 deletions.
  1. +1 −1 .travis.yml
  2. +8 −8 INSTALL
  3. +9 −6 doc/INSTALL.html
  4. +8 −8 doc/msys.t2t
  5. +4 −1 doc/overview.t2t
@@ -16,7 +16,7 @@ notifications:
urls:
- https://webhooks.gitter.im/e/5d0244ab020a75bf7d17
on_success: change # options: [always|never|change] default: always
on_failure: always # options: [always|never|change] default: always
on_failure: change # options: [always|never|change] default: always
on_start: never # default: never

addons:
16 INSTALL
@@ -1,10 +1,10 @@
QGIS
Building QGIS from source - step by step
Thursday March 19, 2015
Monday June 15, 2015


Last Updated: Thursday March 19, 2015
Last Change : Thursday March 19, 2015
Last Updated: Monday June 15, 2015
Last Change : Monday June 15, 2015


1. Introduction
@@ -109,9 +109,9 @@ Required build dependencies:
Optional dependencies:

- for GRASS providers and plugin - GRASS >= 6.0.0. QGIS may be compiled with GRASS 6 or GRASS 7.
It can also be compiled with both GRASS versions in a single build but only if QGIS
is not installed with rpath. The desired GRASS version is choosen on runtime by setting
LD_LIBRARY_PATH or PATH.
It can also be compiled with both GRASS versions in a single build but only if QGIS
is not installed with rpath. The desired GRASS version is choosen on runtime by setting
LD_LIBRARY_PATH or PATH.
- for georeferencer - GSL >= 1.8
- for postgis support and SPIT plugin - PostgreSQL >= 8.0.x
- for gps plugin - gpsbabel
@@ -566,7 +566,7 @@ the windows system preferences.
If you plan to do some debugging, you'll need to compile debug version of Qt:
C:\Qt\4.8.0\bin\qtvars.bat compile_debug

Note: there is a problem when compiling debug version of Qt 4.8, the script ends with
Note: there is a problem when compiling debug version of Qt 4.7, the script ends with
this message "mingw32-make: *** No rule to make target `debug'. Stop.". To
compile the debug version you have to go out of src directory and execute the
following command:
@@ -1036,7 +1036,7 @@ Snow Leopard+ note: If you are building on Snow Leopard+, you will need to
decide between 32-bit support in the older Qt Carbon branch, or 64-bit
support in the Qt Cocoa branch. Appropriate installers are available for both
as of Qt-4.5.2, though they stopped making Carbon packages at Qt 4.7.4.

Qt 4.6+ is recommended for Cocoa.
Starting with Lion, Carbon may not work properly, if at all.
Starting with Qt 4.8, only 64bit Cocoa installers are available.

@@ -77,13 +77,13 @@
<DIV CLASS="header" ID="header">
<H1>QGIS</H1>
<H2>Building QGIS from source - step by step</H2>
<H3>Thursday March 19, 2015</H3>
<H3>Monday June 15, 2015</H3>
</DIV>

<DIV CLASS="body" ID="body">
<P>
Last Updated: Thursday March 19, 2015
Last Change : Thursday March 19, 2015
Last Updated: Monday June 15, 2015
Last Change : Monday June 15, 2015
</P>
<DIV CLASS="toc">

@@ -219,7 +219,10 @@ <H1>2. Overview</H1>
</P>

<UL>
<LI>for GRASS plugin - GRASS &gt;= 6.0.0 (libraries compiled with exceptions support on Linux 32bit)
<LI>for GRASS providers and plugin - GRASS &gt;= 6.0.0. QGIS may be compiled with GRASS 6 or GRASS 7.
It can also be compiled with both GRASS versions in a single build but only if QGIS
is not installed with rpath. The desired GRASS version is choosen on runtime by setting
LD_LIBRARY_PATH or PATH.
<LI>for georeferencer - GSL &gt;= 1.8
<LI>for postgis support and SPIT plugin - PostgreSQL &gt;= 8.0.x
<LI>for gps plugin - gpsbabel
@@ -853,7 +856,7 @@ <H3>4.2.2. Qt</H3>
C:\Qt\4.8.0\bin\qtvars.bat compile_debug
</P>
<P>
Note: there is a problem when compiling debug version of Qt 4.8, the script ends with
Note: there is a problem when compiling debug version of Qt 4.7, the script ends with
this message "mingw32-make: *** No rule to make target `debug'. Stop.". To
compile the debug version you have to go out of src directory and execute the
following command:
@@ -1443,7 +1446,7 @@ <H2>5.2. Install Qt4 from disk image</H2>
decide between 32-bit support in the older Qt Carbon branch, or 64-bit
support in the Qt Cocoa branch. Appropriate installers are available for both
as of Qt-4.5.2, though they stopped making Carbon packages at Qt 4.7.4.

Qt 4.6+ is recommended for Cocoa.
Starting with Lion, Carbon may not work properly, if at all.
Starting with Qt 4.8, only 64bit Cocoa installers are available.
</P>
@@ -39,26 +39,26 @@ it, just point the installer to c:\msys\mingw

When Qt installation is complete:

Edit C:\Qt\4.7.0\bin\qtvars.bat and add the following lines:
Edit C:\Qt\4.8.0\bin\qtvars.bat and add the following lines:

```
set PATH=%PATH%;C:\msys\local\bin;c:\msys\local\lib
set PATH=%PATH%;"C:\Program Files\Subversion\bin"
```

I suggest you also add C:\Qt\4.7.0\bin\ to your Environment Variables Path in
I suggest you also add C:\Qt\4.8.0\bin\ to your Environment Variables Path in
the windows system preferences.

If you plan to do some debugging, you'll need to compile debug version of Qt:
C:\Qt\4.7.0\bin\qtvars.bat compile_debug
C:\Qt\4.8.0\bin\qtvars.bat compile_debug

Note: there is a problem when compiling debug version of Qt 4.7, the script ends with
this message "mingw32-make: *** No rule to make target `debug'. Stop.". To
compile the debug version you have to go out of src directory and execute the
following command:

```
c:\Qt\4.7.0 make
c:\Qt\4.8.0 make
```

=== Flex and Bison ===
@@ -90,7 +90,7 @@ to get versions that match your current Qt installed version.
==== Compile SIP ====

```
c:\Qt\4.7.0\bin\qtvars.bat
c:\Qt\4.8.0\bin\qtvars.bat
python configure.py -p win32-g++
make
make install
@@ -99,7 +99,7 @@ make install
==== Compile PyQt ====

```
c:\Qt\4.7.0\bin\qtvars.bat
c:\Qt\4.8.0\bin\qtvars.bat
python configure.py
make
make install
@@ -148,10 +148,10 @@ Start a cmd.exe window ( Start -> Run -> cmd.exe ) if you don't have one
already. Add paths to compiler and our MSYS environment:

```
c:\Qt\4.7.0\bin\qtvars.bat
c:\Qt\4.8.0\bin\qtvars.bat
```

For ease of use add c:\Qt\4.7.0\bin\ to your system path in system
For ease of use add c:\Qt\4.8.0\bin\ to your system path in system
properties so you can just type qtvars.bat when you open the cmd console.
Create build directory and set it as current directory:

@@ -27,7 +27,10 @@ Required build dependencies:

Optional dependencies:

- for GRASS plugin - GRASS >= 6.0.0 (libraries compiled with exceptions support on Linux 32bit)
- for GRASS providers and plugin - GRASS >= 6.0.0. QGIS may be compiled with GRASS 6 or GRASS 7.
It can also be compiled with both GRASS versions in a single build but only if QGIS
is not installed with rpath. The desired GRASS version is choosen on runtime by setting
LD_LIBRARY_PATH or PATH.
- for georeferencer - GSL >= 1.8
- for postgis support and SPIT plugin - PostgreSQL >= 8.0.x
- for gps plugin - gpsbabel

0 comments on commit bbe2e2a

Please sign in to comment.
You can’t perform that action at this time.