Skip to content
Permalink
Browse files

update version number to 1.3.0 in trunk

git-svn-id: http://svn.osgeo.org/qgis/trunk@11484 c8812cc2-4d05-0410-92ff-de0c093fc19c
  • Loading branch information
jef
jef committed Aug 22, 2009
1 parent 08f5f14 commit c080e311cb1b98f196c3f8e98d9b716512ed1461
@@ -1,12 +1,12 @@
SET(CPACK_PACKAGE_VERSION_MAJOR "1")
SET(CPACK_PACKAGE_VERSION_MINOR "2")
SET(CPACK_PACKAGE_VERSION_MINOR "3")
SET(CPACK_PACKAGE_VERSION_PATCH "0")
SET(COMPLETE_VERSION ${CPACK_PACKAGE_VERSION_MAJOR}.${CPACK_PACKAGE_VERSION_MINOR}.${CPACK_PACKAGE_VERSION_PATCH})
SET(RELEASE_NAME "Daphnis")
SET(RELEASE_NAME "Unstable")
SET(PROJECT_VERSION ${COMPLETE_VERSION})
PROJECT(qgis${PROJECT_VERSION})
# Note the version no is Mmmpp for Major/minor/patch, 0-padded, thus '10100' for 1.1.0
SET(QGIS_VERSION_INT 10200)
SET(QGIS_VERSION_INT 10300)

# TODO:
# - install includes for libs
@@ -1,3 +1,9 @@
qgis (1.3.0) UNRELEASED; urgency=low

* new development version after 1.2 branch

-- Jürgen E. Fischer <jef@norbit.de> Sat, 22 Aug 2009 17:28:29 +0200

qgis (1.2.0) UNRELEASED; urgency=low

* new development version after 1.1 branch
@@ -9,7 +9,7 @@ Build-Depends: debhelper (>= 5.0.51~), libgdal1-dev, libpq-dev,
libqt4-qt3support (>=4.2.0), libqt4-sql (>=4.2.0), python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0),
python-sip4-dev (>= 4.5.0), libfontconfig1-dev, libxi-dev, libxrandr-dev, libxrender-dev, libice-dev,
libsm-dev, pyqt4-dev-tools
Build-Conflicts: libqgis1.2.0-dev, qgis-dev
Build-Conflicts: libqgis1.3.0-dev, qgis-dev
Standards-Version: 3.8.0
XS-Python-Version: current
Homepage: http://qgis.org/
@@ -39,7 +39,7 @@ Description: Quantum GIS - architecture-independent data
This package contains architecture-independent supporting data files for use
with Quantum GIS.

Package: libqgis1.2.0
Package: libqgis1.3.0
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
Replaces: qgis (<=0.9.2rc1), libqgis-core1, libqgis-gui1, libqgis0, libqgis1
@@ -50,10 +50,10 @@ Description: Quantum GIS - shared libraries
This package contains the shared core and gui library that provide an
interface for plugins and stand-alone applications.

Package: libqgis1.2.0-dev
Package: libqgis1.3.0-dev
Architecture: any
Section: libdevel
Depends: libqgis1.2.0 (= ${binary:Version}), libgdal1-dev | libgdal1-1.3.2-dev,
Depends: libqgis1.3.0 (= ${binary:Version}), libgdal1-dev | libgdal1-1.3.2-dev,
libpq-dev | postgresql-dev, libgeos-dev (>= 2.0.1), grass-dev,
libsqlite3-dev, libgsl0-dev, proj, libexpat1-dev, libqt4-core (>=4.2.0),
libqt4-dev (>=4.2.0), libqt4-gui (>=4.2.0), libqt4-qt3support (>=4.2.0),
File renamed without changes.
File renamed without changes.
File renamed without changes.
@@ -1,3 +1,3 @@
libqgis1: shlib-calls-exit
libqgis1: no-symbols-control-file usr/lib/libqgis_gui.so.1.2.0
libqgis1: no-symbols-control-file usr/lib/libqgis_core.so.1.2.0
libqgis1: no-symbols-control-file usr/lib/libqgis_gui.so.1.3.0
libqgis1: no-symbols-control-file usr/lib/libqgis_core.so.1.3.0
@@ -1,6 +1,7 @@
@echo off
set GRASS_VERSION=6.4.0svn
set SVNVERSION=c:/cygwin/bin/svnversion
set PACKAGENAME=qgis-dev

set BUILDDIR=%CD%\build
REM set BUILDDIR=%TEMP%\qgis_unstable
@@ -99,7 +100,7 @@ cmake -G "Visual Studio 9 2008" ^
-D QT_HEADERS_DIR=%O4W_ROOT%/include/qt4 ^
-D QT_ZLIB_LIBRARY=%O4W_ROOT%/lib/zlib.lib ^
-D QT_PNG_LIBRARY=%O4W_ROOT%/lib/libpng13.lib ^
-D CMAKE_INSTALL_PREFIX=%O4W_ROOT%/apps/qgis-dev ^
-D CMAKE_INSTALL_PREFIX=%O4W_ROOT%/apps/%PACKAGENAME% ^
-D CMAKE_CXX_FLAGS_RELWITHDEBINFO="/MD /ZI /Od /D NDEBUG" ^
-D SVNVERSION="%SVNVERSION%" ^
%SRCDIR%>>%LOG% 2>&1
@@ -126,31 +127,31 @@ if errorlevel 1 goto error
echo PACKAGE: %DATE% %TIME%>>%LOG% 2>&1

cd ..
copy postinstall.bat %OSGEO4W_ROOT%\etc\postinstall\qgis-dev.bat
copy preremove.bat %OSGEO4W_ROOT%\etc\preremove\qgis-dev.bat
copy qgis-dev.bat.tmpl %OSGEO4W_ROOT%\bin\qgis-dev.bat.tmpl
copy postinstall.bat %OSGEO4W_ROOT%\etc\postinstall\%PACKAGENAME%.bat
copy preremove.bat %OSGEO4W_ROOT%\etc\preremove\%PACKAGENAME%.bat
copy %PACKAGENAME%.bat.tmpl %OSGEO4W_ROOT%\bin\%PACKAGENAME%.bat.tmpl

sed -e 's/%OSGEO4W_ROOT:\=\\\\\\\\%/@osgeo4w@/' %OSGEO4W_ROOT%\apps\qgis-dev\python\qgis\qgisconfig.py >%OSGEO4W_ROOT%\apps\qgis-dev\python\qgis\qgisconfig.py.tmpl
sed -e 's/%OSGEO4W_ROOT:\=\\\\\\\\%/@osgeo4w@/' %OSGEO4W_ROOT%\apps\%PACKAGENAME%\python\qgis\qgisconfig.py >%OSGEO4W_ROOT%\apps\%PACKAGENAME%\python\qgis\qgisconfig.py.tmpl
if errorlevel 1 goto error

del %OSGEO4W_ROOT%\apps\qgis-dev\python\qgis\qgisconfig.py
del %OSGEO4W_ROOT%\apps\%PACKAGENAME%\python\qgis\qgisconfig.py

touch exclude

tar -C %OSGEO4W_ROOT% -cjf qgis-dev-%VERSION%-%PACKAGE%.tar.bz2 ^
tar -C %OSGEO4W_ROOT% -cjf %PACKAGENAME%-%VERSION%-%PACKAGE%.tar.bz2 ^
--exclude-from exclude ^
apps/qgis-dev ^
bin/qgis-dev.bat.tmpl ^
etc/postinstall/qgis-dev.bat ^
etc/preremove/qgis-dev.bat>>%LOG% 2>&1
apps/%PACKAGENAME% ^
bin/%PACKAGENAME%.bat.tmpl ^
etc/postinstall/%PACKAGENAME%.bat ^
etc/preremove/%PACKAGENAME%.bat>>%LOG% 2>&1
if errorlevel 1 goto error

goto end

:error
echo BUILD ERROR %ERRORLEVEL%: %DATE% %TIME%
echo BUILD ERROR %ERRORLEVEL%: %DATE% %TIME%>>%LOG% 2>&1
if exist qgis-dev-%VERSION%-%PACKAGE%.tar.bz2 del qgis-dev-%VERSION%-%PACKAGE%.tar.bz2
if exist %PACKAGENAME%-%VERSION%-%PACKAGE%.tar.bz2 del %PACKAGENAME%-%VERSION%-%PACKAGE%.tar.bz2

:end
echo FINISHED: %DATE% %TIME% >>%LOG% 2>&1
@@ -43,7 +43,7 @@ class CORE_EXPORT QgsUniqueValueRenderer: public QgsRenderer
*/
int readXML( const QDomNode& rnode, QgsVectorLayer& vl );
/**Writes the contents of the renderer to a configuration file
@ return true in case of success*/
@return true in case of success*/
virtual bool writeXML( QDomNode & layer_node, QDomDocument & document, const QgsVectorLayer& vl ) const;
/** Returns true, if attribute values are used by the renderer and false otherwise*/
bool needsAttributes() const;

0 comments on commit c080e31

Please sign in to comment.
You can’t perform that action at this time.