Skip to content
Permalink
Browse files

Some updates for qt designer plugin support - still in progress...

git-svn-id: http://svn.osgeo.org/qgis/trunk/qgis@5133 c8812cc2-4d05-0410-92ff-de0c093fc19c
  • Loading branch information
timlinux
timlinux committed Apr 2, 2006
1 parent 090344d commit c1bd8cdbbb5dce3b1c29bf86c67bad9d43befb4e
Binary file not shown.
Binary file not shown.
@@ -15,5 +15,5 @@ endif
# depend on the existence of libqgis_gui.
# gui *must* be specified immediately before the providers
# subdirectory.
SUBDIRS = core ui legend raster composer widgets gui providers plugins $(MAC) helpviewer
SUBDIRS = core ui legend raster composer widgets gui providers plugins $(MAC) helpviewer designer

@@ -10,22 +10,49 @@
#
# $Id: Makefile.am 4490 2006-01-07 01:09:27Z timlinux $

##
## ----------------------------------------------------------------------
## Define Targets
## ----------------------------------------------------------------------
##
lib_LTLIBRARIES= libqgis_designerwidgets.la
## TODO change this so it installs into ${QTDIR}/plugins/designer
libqgis_designerwidgetsdir = ${pkglibdir}/designer

plugindir = ${pkglibdir}/designer
##
## ----------------------------------------------------------------------
## get Qt4 to run moc and rcc where required...
## ----------------------------------------------------------------------
##

#run moc on files
%.moc.cpp: %.h
$(MOC) -o $@ $<

# name of the designer plugin
plugin_LTLIBRARIES = qgisdesignerwidgets.la
#qt resources
%.qrc.cpp: %.qrc
$(RCC) -o $@ $<

qgisdesignerwidgets_la_SOURCES = qgsdesignerwidgets.cpp \
qgsdesignerwidgets.h \
$(projectionselector_la_MOC)
libqgis_designerwidgets_la_MOC = qgsprojectionselectorwidget.moc.cpp

qgisdesignerwidgets_la_MOC = qgsprojectionselectorplugin.moc.cpp
libqgis_designerwidgets_RES = qgisdesignerwidgets.qrc.cpp

#projectionselector_la_LIBADD = ../src/gui/libqgis_gui.la $(QT_LDADD)
#qgisdesignerwidgets_la_LIBADD = $(QT_LDADD) ../widgets/projectionselector/libqgsprojectionselector.la
qgisdesignerwidgets_la_LDFLAGS = -avoid-version -module
qgisdesignerwidgets_la_CXXFLAGS = $(CXXFLAGS) $(EXTRA_CXXFLAGS) $(QT_CXXFLAGS) $(DEBUG_QGIS) -I../gui/ -I../legend
libqgis_designerwidgets_QRC = qgisdesignerwidgets.qrc


## $(libqgis_designerwidgets_la_MOC) \
libqgis_designerwidgets_la_SOURCES = qgsprojectionselectorwidget.cpp \
$(libqgis_designerwidgets_QRC) \
$(libqgis_designerwidgets_RES)


libqgis_designerwidgets_la_LIBADD = $(QT_LDADD) ../widgets/projectionselector/libqgsprojectionselector.la
libqgis_designerwidgets_la_LDFLAGS = -avoid-version -module
libqgis_designerwidgets_la_CXXFLAGS = $(CXXFLAGS) $(EXTRA_CXXFLAGS) $(QT_CXXFLAGS) $(DEBUG_QGIS) -I../gui/ -I../legend -I../core -I../widgets/projectionselector/

##
## ----------------------------------------------------------------------
## additional files that need to be installed go here
## ----------------------------------------------------------------------
##
libqgis_designerwidgets_HEADERS = qgsprojectionselectorwidget.h
@@ -0,0 +1,5 @@
<RCC>
<qresource prefix="/" >
<file>../../images/designer_widget_icons/projectionselector.png</file>
</qresource>
</RCC>

This file was deleted.

This file was deleted.

0 comments on commit c1bd8cd

Please sign in to comment.
You can’t perform that action at this time.