Skip to content
Permalink
Browse files

INSTALL: remove outdated 'precise' reference

  • Loading branch information
jef-n committed Jun 21, 2019
1 parent 32da351 commit c5c68775136d5f4ec6071ce1eb8046eb897beeff
Showing with 21 additions and 14 deletions.
  1. +8 −5 INSTALL
  2. +11 −7 doc/INSTALL.html
  3. +2 −2 doc/linux.t2t
13 INSTALL
@@ -1,10 +1,10 @@
QGIS
Building QGIS from source - step by step
Tuesday May 07, 2019
Friday June 21, 2019


Last Updated: Tuesday May 07, 2019
Last Change : Tuesday May 07, 2019
Last Updated: Friday June 21, 2019
Last Change : Friday June 21, 2019


1. Introduction
@@ -169,8 +169,8 @@ of Ubuntu. This is not activated by default, so you need to activate it:
1. Edit your /etc/apt/sources.list file.
2. Uncomment all the lines starting with "deb"

Also you will need to be running Ubuntu 'precise' or higher in order for
all dependencies to be met.
Also you will need a recent enough distribution in order for all dependencies
to be met. The supported distributions are listed in the following section.

Now update your local sources database:

@@ -1101,6 +1101,9 @@ is required.
5. Building on MacOS X
======================

This document is outdated and there is currently no up to date documentation for building on mac.
You might want to consider to read an approach using Homebrew although not up to date either: https://github.com/qgis/QGIS/mac/development.md

In this approach I will try to avoid as much as possible building dependencies
from source and rather use frameworks wherever possible.

@@ -5,7 +5,7 @@
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=utf-8">
<TITLE>QGIS</TITLE>

<!-- Included doc/style.css -->
<!-- Included /home/fischer/src/qgis/doc/style.css -->
<STYLE TYPE="text/css">
body{ background: white;
color: black;
@@ -77,13 +77,13 @@
<DIV CLASS="header" ID="header">
<H1>QGIS</H1>
<H2>Building QGIS from source - step by step</H2>
<H3>Tuesday May 07, 2019</H3>
<H3>Friday June 21, 2019</H3>
</DIV>

<DIV CLASS="body" ID="body">
<P>
Last Updated: Tuesday May 07, 2019
Last Change : Tuesday May 07, 2019
Last Updated: Friday June 21, 2019
Last Change : Friday June 21, 2019
</P>
<DIV CLASS="toc">

@@ -291,8 +291,8 @@ <H2>3.2. Prepare apt</H2>
</OL>

<P>
Also you will need to be running Ubuntu 'precise' or higher in order for
all dependencies to be met.
Also you will need a recent enough distribution in order for all dependencies
to be met. The supported distributions are listed in the following section.
</P>
<P>
Now update your local sources database:
@@ -1546,6 +1546,10 @@ <H3>4.4.2. Testing QGIS</H3>
<A NAME="toc18"></A>
<H1>5. Building on MacOS X</H1>

<P>
This document is outdated and there is currently no up to date documentation for building on mac.
You might want to consider to read an approach using Homebrew although not up to date either: <A HREF="https://github.com/qgis/QGIS/mac/development.md">https://github.com/qgis/QGIS/mac/development.md</A>
</P>
<P>
In this approach I will try to avoid as much as possible building dependencies
from source and rather use frameworks wherever possible.
@@ -3126,5 +3130,5 @@ <H1>9. Authors and Acknowledgments</H1>

</DIV>
<!-- html code generated by txt2tags 2.6 (http://txt2tags.org) -->
<!-- cmdline: txt2tags -\-encoding=utf-8 -o doc/INSTALL.html -t html doc/INSTALL.t2t -->
<!-- cmdline: txt2tags -\-encoding=utf-8 -o/home/fischer/src/qgis/debian/build/doc/INSTALL.html -t html /home/fischer/src/qgis/doc/INSTALL.t2t -->
</BODY></HTML>
@@ -32,8 +32,8 @@ of Ubuntu. This is not activated by default, so you need to activate it:
+ Uncomment all the lines starting with "deb"
+

Also you will need to be running Ubuntu 'precise' or higher in order for
all dependencies to be met.
Also you will need a recent enough distribution in order for all dependencies
to be met. The supported distributions are listed in the following section.

Now update your local sources database:

0 comments on commit c5c6877

Please sign in to comment.
You can’t perform that action at this time.