Skip to content
Permalink
Browse files

debian packaging: trim dependencies

git-svn-id: http://svn.osgeo.org/qgis/trunk@14388 c8812cc2-4d05-0410-92ff-de0c093fc19c
  • Loading branch information
jef
jef committed Oct 17, 2010
1 parent 2d168d9 commit d21f120b6ac30437e3fec8216647870ba1fc08c0
Showing with 243 additions and 73 deletions.
  1. +3 −2 debian/changelog
  2. +37 −11 debian/control
  3. +39 −13 debian/control.lenny
  4. +41 −11 debian/control.lucid
  5. +41 −12 debian/control.maverick
  6. +41 −12 debian/control.sid
  7. +41 −12 debian/control.squeeze
@@ -5,9 +5,10 @@ qgis (1.6.0) UNRELEASED; urgency=low
control fields.
* include displacementplugin and offline editing plugin
* add subversion as build dependency for trunk
* add qgis-mapserver
* add qgis-mapserver package
* trim dependencies

-- Jürgen E. Fischer <jef@norbit.de> Tue, 05 Oct 2010 11:22:04 +0200
-- Jürgen E. Fischer <jef@norbit.de> Sun, 17 Oct 2010 12:09:23 +0200

qgis (1.5.0) UNRELEASED; urgency=low

@@ -2,12 +2,29 @@ Source: qgis
Section: science
Priority: extra
Maintainer: Quantum GIS developers <qgis-developer@lists.osgeo.org>
Build-Depends: debhelper (>= 5.0.51~), libgdal1-dev, libpq-dev,
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, proj (<< 4.7.0) | libproj-dev (>= 4.7.0), libexpat1-dev,
flex, bison, python-dev, cmake (>= 2.6), python-sip4 (>= 4.5.0), python-central (>=0.5), python,
sip4 (>= 4.5), libqt4-core (>=4.4.0), libqt4-dev (>=4.4.0), libqt4-gui (>=4.4.0),
libqt4-sql (>=4.4.0), python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0),
python-sip4-dev (>= 4.5.0), pyqt4-dev-tools, libqwt5-qt4-dev, libfcgi-dev, subversion
Build-Depends:
bison,
cmake (>= 2.6),
debhelper (>= 5.0.51~),
flex,
grass-dev,
libexpat1-dev,
libfcgi-dev,
libgdal1-dev,
libgeos-dev (>= 3.0.0),
libgsl0-dev,
libpq-dev,
libqt4-dev (>=4.4.0),
libqwt5-qt4-dev,
libsqlite3-dev,
proj (<< 4.7.0) | libproj-dev (>= 4.7.0),
pyqt4-dev-tools,
python,
python-central (>=0.5),
python-dev,
python-qt4-dev (>=4.1.0),
python-sip4-dev (>= 4.5.0) | sip4 (>= 4.5),
subversion
Build-Conflicts: libqgis-dev, qgis-dev
Standards-Version: 3.8.4
XS-Python-Version: current
@@ -51,11 +68,20 @@ Description: Quantum GIS - shared libraries
Package: libqgis-dev
Architecture: any
Section: libdevel
Depends: libqgis1.6.0 (= ${binary:Version}), libgdal1-dev,
libpq-dev, libgeos-dev (>= 3.0.0), grass-dev,
libsqlite3-dev, libgsl0-dev, libproj-dev, libexpat1-dev, libqt4-core (>=4.4.0),
libqt4-dev (>=4.4.0), libqt4-gui (>=4.4.0), libqt4-sql (>=4.4.0),
python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0), qt4-designer (>=4.4.0)
Depends:
grass-dev,
libexpat1-dev,
libgdal1-dev,
libgeos-dev (>= 3.0.0),
libgsl0-dev,
libpq-dev,
libproj-dev,
libqgis1.6.0 (= ${binary:Version}),
libqt4-dev (>=4.4.0),
libsqlite3-dev,
python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0),
qt4-designer (>=4.4.0)
Provides: qgis-dev
Replaces: qgis-dev, libqgis1-dev, libqgis1.4.0-dev
Description: Quantum GIS - development files
@@ -2,14 +2,32 @@ Source: qgis
Section: science
Priority: extra
Maintainer: Quantum GIS developers <qgis-developer@lists.osgeo.org>
Build-Depends: debhelper (>= 5.0.51~), libgdal1-dev, libpq-dev,
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, proj,
libexpat1-dev, flex, bison, python-dev, cmake (>=2.4.3),
python-sip4 (>= 4.5.0), python-central (>=0.5), python, sip4 (>= 4.5),
libqt4-core (>=4.2.0), libqt4-dev (>=4.2.0), libqt4-gui (>=4.2.0),
libqt4-sql (>=4.2.0), python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0),
python-sip4-dev (>= 4.5.0), pyqt4-dev-tools, libqwt5-qt4-dev, pkg-config,
libfcgi-dev, subversion
Build-Depends:
bison,
cmake (>= 2.4.3),
debhelper (>= 5.0.51~),
flex,
grass-dev,
libexpat1-dev,
libfcgi-dev,
libgdal1-dev,
libgeos-dev (>= 3.0.0),
libgsl0-dev,
libpq-dev,
libqt4-dev (>=4.2.0),
libqwt5-qt4-dev,
libsqlite3-dev,
pkg-config,
proj,
pyqt4-dev-tools,
python,
python-central (>=0.5),
python-dev,
python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0),
python-sip4-dev (>= 4.5.0),
sip4 (>= 4.5),
subversion
Build-Conflicts: libqgis-dev, qgis-dev
Standards-Version: 3.8.0
XS-Python-Version: current
@@ -53,11 +71,19 @@ Description: Quantum GIS - shared libraries
Package: libqgis-dev
Architecture: any
Section: libdevel
Depends: libqgis{QGIS_ABI} (= ${binary:Version}), libgdal1-dev,
libpq-dev, libgeos-dev (>= 3.0.0), grass-dev,
libsqlite3-dev, libgsl0-dev, proj, libexpat1-dev, libqt4-core (>=4.2.0),
libqt4-dev (>=4.2.0), libqt4-gui (>=4.2.0), libqt4-qt3support (>=4.2.0),
libqt4-sql (>=4.2.0), python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0),
Depends:
grass-dev,
libexpat1-dev,
libgdal1-dev,
libgeos-dev (>= 3.0.0),
libgsl0-dev,
libpq-dev,
libqgis{QGIS_ABI} (= ${binary:Version}),
libqt4-dev (>=4.2.0),
libsqlite3-dev,
proj,
python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0),
qt4-designer (>=4.2.0)
Provides: qgis-dev
Replaces: qgis-dev, libqgis1-dev
@@ -2,12 +2,33 @@ Source: qgis
Section: science
Priority: extra
Maintainer: Quantum GIS developers <qgis-developer@lists.osgeo.org>
Build-Depends: debhelper (>= 7), libgdal1-dev, libpq-dev,
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, libproj-dev,
libexpat1-dev, flex, bison, python-dev, cmake (>= 2.6), python-sip (>= 4.5.0), python-central (>=0.5), python, libqt4-core (>=4.4.0), libqt4-dev (>=4.4.0),
libqt4-gui (>=4.4.0), libqt4-sql (>=4.4.0), python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0), python-sip-dev (>= 4.5.0), pyqt4-dev-tools,
libqwt5-qt4-dev, libspatialite-dev, libfcgi-dev, pkg-config, subversion
Build-Depends:
bison,
cmake (>= 2.6),
debhelper (>= 7),
flex,
grass-dev,
libexpat1-dev,
libfcgi-dev,
libgdal1-dev,
libgeos-dev (>= 3.0.0),
libgsl0-dev,
libpq-dev,
libproj-dev,
libqt4-dev (>=4.4.0),
libqwt5-qt4-dev,
libspatialite-dev,
libsqlite3-dev,
pkg-config,
pyqt4-dev-tools,
python,
python-central (>=0.5),
python-dev,
python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0),
python-sip (>= 4.5.0),
python-sip-dev (>= 4.5.0),
subversion
Build-Conflicts: libqgis-dev, qgis-dev
Standards-Version: 3.8.4
XS-Python-Version: current
@@ -51,11 +72,20 @@ Description: Quantum GIS - shared libraries
Package: libqgis-dev
Architecture: any
Section: libdevel
Depends: libqgis{QGIS_ABI} (= ${binary:Version}), libgdal1-dev,
libpq-dev, libgeos-dev (>= 3.0.0), grass-dev,
libsqlite3-dev, libgsl0-dev, libproj-dev, libexpat1-dev, libqt4-core (>=4.4.0),
libqt4-dev (>=4.4.0), libqt4-gui (>=4.4.0), libqt4-sql (>=4.4.0),
python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0), qt4-designer (>=4.4.0)
Depends:
grass-dev,
libexpat1-dev,
libgdal1-dev,
libgeos-dev (>= 3.0.0),
libgsl0-dev,
libpq-dev,
libproj-dev,
libqgis{QGIS_ABI} (= ${binary:Version}),
libqt4-dev (>=4.4.0),
libsqlite3-dev,
python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0),
qt4-designer (>=4.4.0)
Provides: qgis-dev
Replaces: qgis-dev, libqgis1-dev, libqgis1.4.0-dev
Description: Quantum GIS - development files
@@ -2,13 +2,33 @@ Source: qgis
Section: science
Priority: extra
Maintainer: Quantum GIS developers <qgis-developer@lists.osgeo.org>
Build-Depends: debhelper (>= 7), libgdal1-dev, libpq-dev,
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, libproj-dev,
libexpat1-dev, flex, bison, python-dev, cmake (>= 2.6), python-sip (>= 4.5.0),
python-central (>=0.5), python, libqt4-core (>=4.4.0), libqt4-dev (>=4.4.0),
libqt4-gui (>=4.4.0), libqt4-sql (>=4.4.0), libqtwebkit-dev,
python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0), python-sip-dev (>= 4.5.0),
pyqt4-dev-tools, libqwt5-qt4-dev, libspatialite-dev, libfcgi-dev, pkg-config,
Build-Depends:
bison,
cmake (>= 2.6),
debhelper (>= 7),
flex,
grass-dev,
libexpat1-dev,
libfcgi-dev,
libgdal1-dev,
libgeos-dev (>= 3.0.0),
libgsl0-dev,
libpq-dev,
libproj-dev,
libqt4-dev (>=4.4.0),
libqtwebkit-dev,
libqwt5-qt4-dev,
libspatialite-dev,
libsqlite3-dev,
pkg-config,
pyqt4-dev-tools,
python,
python-central (>=0.5),
python-dev,
python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0),
python-sip (>= 4.5.0),
python-sip-dev (>= 4.5.0),
subversion
Build-Conflicts: libqgis-dev, qgis-dev
Standards-Version: 3.8.4
@@ -53,11 +73,20 @@ Description: Quantum GIS - shared libraries
Package: libqgis-dev
Architecture: any
Section: libdevel
Depends: libqgis{QGIS_ABI} (= ${binary:Version}), libgdal1-dev,
libpq-dev, libgeos-dev (>= 3.0.0), grass-dev,
libsqlite3-dev, libgsl0-dev, libproj-dev, libexpat1-dev, libqt4-core (>=4.4.0),
libqt4-dev (>=4.4.0), libqt4-gui (>=4.4.0), libqt4-sql (>=4.4.0),
python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0), qt4-designer (>=4.4.0)
Depends:
grass-dev,
libexpat1-dev,
libgdal1-dev,
libgeos-dev (>= 3.0.0),
libgsl0-dev,
libpq-dev,
libproj-dev,
libqgis{QGIS_ABI} (= ${binary:Version}),
libqt4-dev (>=4.4.0),
libsqlite3-dev,
python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0),
qt4-designer (>=4.4.0)
Provides: qgis-dev
Replaces: qgis-dev, libqgis1-dev, libqgis1.4.0-dev
Description: Quantum GIS - development files
@@ -2,13 +2,33 @@ Source: qgis
Section: science
Priority: extra
Maintainer: Quantum GIS developers <qgis-developer@lists.osgeo.org>
Build-Depends: debhelper (>= 7), libgdal1-dev, libpq-dev,
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, libproj-dev,
libexpat1-dev, flex, bison, python-dev, cmake (>= 2.6), python-sip (>= 4.5.0),
python-central (>=0.5), python, libqt4-core (>=4.4.0), libqt4-dev (>=4.4.0),
libqt4-gui (>=4.4.0), libqt4-sql (>=4.4.0), python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0), python-sip-dev (>= 4.5.0), pyqt4-dev-tools,
libqwt5-qt4-dev, libspatialite-dev, libfcgi-dev, pkg-config, subversion
Build-Depends:
bison,
cmake (>= 2.6),
debhelper (>= 7),
flex,
grass-dev,
libexpat1-dev,
libfcgi-dev,
libgdal1-dev,
libgeos-dev (>= 3.0.0),
libgsl0-dev,
libpq-dev,
libproj-dev,
libqt4-dev (>=4.4.0),
libqwt5-qt4-dev,
libspatialite-dev,
libsqlite3-dev,
pkg-config,
pyqt4-dev-tools,
python,
python-central (>=0.5),
python-dev,
python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0),
python-sip (>= 4.5.0),
python-sip-dev (>= 4.5.0),
subversion
Build-Conflicts: libqgis-dev, qgis-dev
Standards-Version: 3.8.4
XS-Python-Version: current
@@ -52,11 +72,20 @@ Description: Quantum GIS - shared libraries
Package: libqgis-dev
Architecture: any
Section: libdevel
Depends: libqgis{QGIS_ABI} (= ${binary:Version}), libgdal1-dev,
libpq-dev, libgeos-dev (>= 3.0.0), grass-dev,
libsqlite3-dev, libgsl0-dev, libproj-dev, libexpat1-dev, libqt4-core (>=4.4.0),
libqt4-dev (>=4.4.0), libqt4-gui (>=4.4.0), libqt4-sql (>=4.4.0),
python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0), qt4-designer (>=4.4.0)
Depends:
grass-dev,
libexpat1-dev,
libgdal1-dev,
libgeos-dev (>= 3.0.0),
libgsl0-dev,
libpq-dev,
libproj-dev,
libqgis{QGIS_ABI} (= ${binary:Version}),
libqt4-dev (>=4.4.0),
libsqlite3-dev,
python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0),
qt4-designer (>=4.4.0)
Provides: qgis-dev
Replaces: qgis-dev, libqgis1-dev, libqgis1.4.0-dev
Description: Quantum GIS - development files

0 comments on commit d21f120

Please sign in to comment.
You can’t perform that action at this time.