Skip to content
Permalink
Browse files

[server] Keep default version in case of invalid VERSION parameter

  • Loading branch information
pblottiere committed Apr 30, 2018
1 parent 58e5351 commit db4a2dda9f4607235642c31eaff2965b710c96c7
Showing with 2 additions and 1 deletion.
  1. +2 −1 src/server/services/wms/qgswms.cpp
@@ -67,7 +67,8 @@ namespace QgsWms
}

// Set the default version
if ( versionString.isEmpty() )
const bool valid = versionString.compare( "1.1.1" ) == 0 || versionString.compare( "1.3.0" ) == 0;
if ( versionString.isEmpty() || !valid )
{
versionString = mVersion;
}

0 comments on commit db4a2dd

Please sign in to comment.
You can’t perform that action at this time.