Skip to content
Permalink
Browse files

Merge pull request #3689 from rduivenvoorde/getPlugins3

Temporarily hardcode plugins version in url ?qgis=3.0
  • Loading branch information
3nids committed Nov 2, 2016
2 parents 4f5337f + 54f312f commit dbd7de3940d78cd7c6c6835090f3d3416c5b6677
Showing with 4 additions and 1 deletion.
  1. +4 −1 python/pyplugin_installer/installer_data.py
@@ -236,7 +236,10 @@ def allUnavailable(self):
def urlParams(self):
""" return GET parameters to be added to every request """
v = str(Qgis.QGIS_VERSION_INT)
return "?qgis=%d.%d" % (int(v[0]), int(v[1:3]))
# TODO: make this proper again after 3.0 release, by uncommenting
# the line below and removing the other return line:
#return "?qgis=%d.%d" % (int(v[0]), int(v[1:3]))
return "?qgis=3.0"

# ----------------------------------------- #
def setRepositoryData(self, reposName, key, value):

1 comment on commit dbd7de3

@sildeag

This comment has been minimized.

Copy link

@sildeag sildeag commented on dbd7de3 Nov 5, 2016

Existing QGIS development on Ubuntu 16.04, unless ~/apps/share/qgis is removed, may require cp ~/dev/cpp/QGIS/python/pyplugin_installer/installer_data.py ~/apps/share/qgis/python/pyplugin_installer/ to update this file.

Please sign in to comment.
You can’t perform that action at this time.