Skip to content
Permalink
Browse files

backport debian packaging updates

cherry picked from aeec6df & 206cc96 & c748aac & 41e0c01
  • Loading branch information
jef-n committed Mar 11, 2019
1 parent 24ccb08 commit de8f540d3b55e674ca974b9fca551ff628f98079
Showing with 920 additions and 928 deletions.
  1. +161 −74 debian/control
  2. +160 −133 debian/control.in
  3. +467 −598 debian/copyright
  4. +1 −1 debian/libqgis-3d{QGIS_ABI}.install
  5. +1 −1 debian/libqgis-analysis{QGIS_ABI}.install
  6. +2 −2 debian/libqgis-analysis{QGIS_ABI}.lintian-overrides
  7. +1 −1 debian/libqgis-app{QGIS_ABI}.install
  8. +1 −1 debian/libqgis-app{QGIS_ABI}.lintian-overrides
  9. +1 −1 debian/libqgis-core{QGIS_ABI}.install
  10. +2 −2 debian/libqgis-core{QGIS_ABI}.lintian-overrides
  11. +1 −0 debian/libqgis-customwidgets.install
  12. +0 −1 debian/libqgis-customwidgets.install.in
  13. +1 −1 debian/libqgis-customwidgets.lintian-overrides
  14. +3 −3 debian/libqgis-dev.install.in
  15. +1 −1 debian/libqgis-gui{QGIS_ABI}.install
  16. +2 −2 debian/libqgis-gui{QGIS_ABI}.lintian-overrides
  17. +1 −1 debian/libqgis-native{QGIS_ABI}.install
  18. +1 −1 debian/libqgis-server{QGIS_ABI}.install
  19. +2 −2 debian/libqgis-server{QGIS_ABI}.lintian-overrides
  20. +1 −1 debian/libqgisgrass{GRASSVER_QGIS_ABI}.install
  21. +2 −2 debian/libqgisgrass{GRASSVER_QGIS_ABI}.lintian-overrides
  22. +1 −1 debian/libqgispython{QGIS_ABI}.lintian-overrides
  23. +0 −8 debian/python-qgis.install.in
  24. +0 −1 debian/python-qgis.lintian-overrides.in
  25. +6 −2 debian/{python-qgis-common.install → python3-qgis-common.install}
  26. +10 −0 debian/python3-qgis.install
  27. +1 −0 debian/python3-qgis.lintian-overrides
  28. +0 −1 debian/qgis-api-doc.links
  29. +4 −4 debian/qgis-common.install
  30. +2 −2 debian/qgis-common.links
  31. +2 −2 debian/qgis-common.lintian-overrides
  32. +2 −0 debian/qgis-oracle-provider.install
  33. +0 −2 debian/qgis-oracle-provider.install.in
  34. +0 −1 debian/qgis-plugin-globe-common.install
  35. +0 −1 debian/qgis-plugin-globe-common.links
  36. +0 −1 debian/qgis-plugin-globe-common.lintian-overrides
  37. +0 −1 debian/qgis-plugin-globe.install
  38. +2 −0 debian/qgis-plugin-grass.install
  39. +0 −2 debian/qgis-plugin-grass.install.in
  40. +2 −2 debian/qgis-plugin-grass.lintian-overrides
  41. +6 −0 debian/qgis-provider-grass.install
  42. +0 −6 debian/qgis-provider-grass.install.in
  43. +2 −2 debian/qgis-provider-grass.lintian-overrides
  44. +6 −6 debian/qgis-providers.install.in
  45. +1 −1 debian/qgis-providers.triggers
  46. +4 −4 debian/qgis.install
  47. +1 −1 debian/qgis.preinst
  48. +50 −45 debian/rules
  49. +1 −1 debian/upstream/metadata
  50. +5 −2 debian/watch

Large diffs are not rendered by default.

Large diffs are not rendered by default.

Large diffs are not rendered by default.

@@ -1 +1 @@
usr/lib/libqgis_3d.so.{QGIS_ABI}
usr/lib/libqgis_3d.so.*
@@ -1 +1 @@
usr/lib/libqgis_analysis.so.{QGIS_ABI}
usr/lib/libqgis_analysis.so.*
@@ -1,2 +1,2 @@
libqgis-analysis{QGIS_ABI}: no-symbols-control-file
libqgis-analysis{QGIS_ABI}: shlib-calls-exit
no-symbols-control-file *
shlib-calls-exit *
@@ -1 +1 @@
usr/lib/libqgis_app.so.{QGIS_ABI}
usr/lib/libqgis_app.so.*
@@ -1 +1 @@
libqgis-app{QGIS_ABI}: no-symbols-control-file usr/lib/libqgis_app.so.{QGIS_ABI}
no-symbols-control-file *
@@ -1 +1 @@
usr/lib/libqgis_core.so.{QGIS_ABI}
usr/lib/libqgis_core.so.*
@@ -1,2 +1,2 @@
libqgis-core{QGIS_ABI}: shlib-calls-exit usr/lib/libqgis_core.so.{QGIS_ABI}
libqgis-core{QGIS_ABI}: no-symbols-control-file usr/lib/libqgis_core.so.{QGIS_ABI}
shlib-calls-exit *
no-symbols-control-file *
@@ -0,0 +1 @@
usr/lib/*/qt?/plugins/designer/libqgis_customwidgets.so*

This file was deleted.

@@ -1 +1 @@
libqgis-customwidgets: no-symbols-control-file
no-symbols-control-file *
@@ -1,11 +1,11 @@
usr/include/qgis/*
#sid buster bionic cosmic#usr/lib/libqgis_3d.so
usr/lib/libqgis_analysis.so
usr/lib/libqgis_app.so
usr/lib/libqgis_core.so
usr/lib/libqgis_gui.so
usr/lib/libqgis_analysis.so
usr/lib/libqgis_native.so
usr/lib/libqgis_server.so
usr/lib/libqgisgrass{GRASSVER}.so
usr/lib/libqgisgrass?.so
usr/lib/libqgispython.so
usr/share/qgis/FindQGIS.cmake
#sid buster bionic cosmic#usr/lib/libqgis_3d.so
@@ -1 +1 @@
usr/lib/libqgis_gui.so.{QGIS_ABI}
usr/lib/libqgis_gui.so.*
@@ -1,2 +1,2 @@
libqgis-gui{QGIS_ABI}: shlib-calls-exit usr/lib/libqgis_gui.so.{QGIS_ABI}
libqgis-gui{QGIS_ABI}: no-symbols-control-file usr/lib/libqgis_gui.so.{QGIS_ABI}
shlib-calls-exit *
no-symbols-control-file *
@@ -1 +1 @@
usr/lib/libqgis_native.so.{QGIS_ABI}
usr/lib/libqgis_native.so.*
@@ -1 +1 @@
usr/lib/libqgis_server.so.{QGIS_ABI}
usr/lib/libqgis_server.so.*
@@ -1,2 +1,2 @@
libqgis-server{QGIS_ABI}: shlib-calls-exit usr/lib/libqgis_server.so.{QGIS_ABI}
libqgis-server{QGIS_ABI}: no-symbols-control-file usr/lib/libqgis_server.so.{QGIS_ABI}
shlib-calls-exit *
no-symbols-control-file *
@@ -1 +1 @@
usr/lib/libqgisgrass{GRASSVER}.so.{QGIS_ABI}
usr/lib/libqgisgrass?.so.*
@@ -1,2 +1,2 @@
libqgisgrass{GRASSVER}-{QGIS_ABI}: hardening-no-fortify-functions usr/lib/libqgisgrass{GRASSVER}.so.{QGIS_ABI}
libqgisgrass{GRASSVER}-{QGIS_ABI}: no-symbols-control-file usr/lib/libqgisgrass{GRASSVER}.so.{QGIS_ABI}
hardening-no-fortify-functions *
no-symbols-control-file *
@@ -1 +1 @@
libqgispython{QGIS_ABI}: no-symbols-control-file
no-symbols-control-file *

This file was deleted.

This file was deleted.

@@ -1,4 +1,8 @@
usr/share/qgis/python/*
usr/lib/python*/*-packages/PyQt?/uic/widget-plugins/qgis_customwidgets.py
usr/lib/python*/*-packages/qgis/*.py
usr/lib/python*/*-packages/qgis/PyQt/*
usr/lib/python*/*-packages/qgis/processing/*
usr/lib/python*/*-packages/qgis/testing/*
usr/lib/python*/*-packages/PyQt?/uic/widget-plugins/qgis_customwidgets.py
usr/lib/python*/*-packages/qgis/core/additions/*
usr/lib/python*/*-packages/qgis/core/contextmanagers.py
usr/share/qgis/python/*
@@ -0,0 +1,10 @@
usr/lib/python*/*-packages/qgis/3d/__init__.py
usr/lib/python*/*-packages/qgis/_3d.so
usr/lib/python*/*-packages/qgis/_analysis.so
usr/lib/python*/*-packages/qgis/_core.so
usr/lib/python*/*-packages/qgis/_gui.so
usr/lib/python*/*-packages/qgis/_server.so
usr/lib/python*/*-packages/qgis/analysis/__init__.py
usr/lib/python*/*-packages/qgis/core/__init__.py
usr/lib/python*/*-packages/qgis/gui/__init__.py
usr/lib/python*/*-packages/qgis/server/__init__.py
@@ -0,0 +1 @@
hardening-no-fortify-functions *

This file was deleted.

@@ -15,11 +15,11 @@ usr/share/qgis/doc/nohelp.html
usr/share/qgis/doc/style.css
usr/share/qgis/i18n/*
usr/share/qgis/images/*
usr/share/qgis/resources/spatialite.db
usr/share/qgis/resources/palettes/*
usr/share/qgis/resources/themes/*
usr/share/qgis/resources/2to3migration.txt
usr/share/qgis/resources/data/*
usr/share/qgis/resources/metadata-ISO/*
usr/share/qgis/resources/opencl_programs/*
usr/share/qgis/resources/2to3migration.txt
usr/share/qgis/resources/palettes/*
usr/share/qgis/resources/qgis_global_settings.ini
usr/share/qgis/resources/spatialite.db
usr/share/qgis/resources/themes/*
@@ -1,3 +1,3 @@
usr/share/common-licenses/GPL-2 usr/share/qgis/doc/LICENSE
usr/share/common-licenses/GPL-2 usr/share/qgis/doc/LICENSE
usr/share/javascript/jquery/jquery.js usr/share/qgis/doc/jquery-min.js
usr/share/javascript/leaflet usr/share/qgis/doc/leaflet
usr/share/javascript/leaflet usr/share/qgis/doc/leaflet
@@ -1,2 +1,2 @@
qgis-common: package-contains-broken-symlink usr/share/qgis/doc/LICENSE ../../common-licenses/GPL-2
qgis-common: package-contains-broken-symlink usr/share/qgis/doc/leaflet ../../javascript/leaflet
package-contains-broken-symlink usr/share/qgis/doc/LICENSE ../../common-licenses/GPL-2
package-contains-broken-symlink usr/share/qgis/doc/leaflet ../../javascript/leaflet
@@ -0,0 +1,2 @@
usr/lib/qgis/plugins/liboracleprovider.so
usr/lib/*/qt?/plugins/sqldrivers/libqsqlocispatial.so

This file was deleted.

This file was deleted.

This file was deleted.

This file was deleted.

This file was deleted.

@@ -0,0 +1,2 @@
usr/lib/qgis/grass/bin/qgis.g.browser?
usr/lib/qgis/plugins/libgrassplugin?.so

This file was deleted.

@@ -1,2 +1,2 @@
qgis-plugin-grass: package-name-doesnt-match-sonames
qgis-plugin-grass: no-symbols-control-file
package-name-doesnt-match-sonames *
no-symbols-control-file *
@@ -0,0 +1,6 @@
usr/lib/qgis/grass/modules/qgis.d.rast?
usr/lib/qgis/grass/modules/qgis.g.info?
usr/lib/qgis/grass/modules/qgis.r.in?
usr/lib/qgis/grass/modules/qgis.v.in?
usr/lib/qgis/plugins/libgrassprovider?.so
usr/lib/qgis/plugins/libgrassrasterprovider?.so

This file was deleted.

@@ -1,2 +1,2 @@
qgis-provider-grass: package-name-doesnt-match-sonames
qgis-provider-grass: no-symbols-control-file
package-name-doesnt-match-sonames *
no-symbols-control-file *
@@ -1,13 +1,16 @@
usr/lib/qgis/crssync
usr/lib/qgis/plugins/libarcgisfeatureserverprovider.so
usr/lib/qgis/plugins/libarcgismapserverprovider.so
usr/lib/qgis/plugins/libbasicauthmethod.so
usr/lib/qgis/plugins/libesritokenauthmethod.so
usr/lib/qgis/plugins/libdb2provider.so
usr/lib/qgis/plugins/libdelimitedtextprovider.so
usr/lib/qgis/plugins/libesritokenauthmethod.so
usr/lib/qgis/plugins/libgdalprovider.so
usr/lib/qgis/plugins/libgeonodeprovider.so
usr/lib/qgis/plugins/libgpxprovider.so
usr/lib/qgis/plugins/libidentcertauthmethod.so
usr/lib/qgis/plugins/libmdalprovider.so
usr/lib/qgis/plugins/libmssqlprovider.so
usr/lib/qgis/plugins/libdb2provider.so
usr/lib/qgis/plugins/libogrprovider.so
usr/lib/qgis/plugins/libowsprovider.so
usr/lib/qgis/plugins/libpkcs12authmethod.so
@@ -18,7 +21,4 @@ usr/lib/qgis/plugins/libvirtuallayerprovider.so
usr/lib/qgis/plugins/libwcsprovider.so
usr/lib/qgis/plugins/libwfsprovider.so
usr/lib/qgis/plugins/libwmsprovider.so
usr/lib/qgis/plugins/libarcgismapserverprovider.so
usr/lib/qgis/plugins/libarcgisfeatureserverprovider.so
usr/lib/qgis/plugins/libmdalprovider.so
#!xenial#{QT_PLUGINS_DIR}/sqldrivers/libqsqlspatialite.so
#!xenial#usr/lib/*/qt?/plugins/sqldrivers/libqsqlspatialite.so
@@ -1 +1 @@
interest qgis-crssync
interest-noawait qgis-crssync
@@ -1,11 +1,11 @@
usr/lib/qgis/plugins/libgeorefplugin.so
usr/lib/qgis/plugins/libgpsimporterplugin.so
usr/lib/qgis/plugins/libcoordinatecaptureplugin.so
usr/lib/qgis/plugins/libevis.so
usr/lib/qgis/plugins/libofflineeditingplugin.so
usr/lib/qgis/plugins/libtopolplugin.so
usr/lib/qgis/plugins/libgeometrycheckerplugin.so
usr/lib/qgis/plugins/libgeorefplugin.so
usr/lib/qgis/plugins/libgpsimporterplugin.so
usr/lib/qgis/plugins/liboauth2authmethod.so
usr/lib/qgis/plugins/libofflineeditingplugin.so
usr/lib/qgis/plugins/libtopolplugin.so
usr/share/applications/
usr/share/metainfo/
usr/share/mime/packages/
@@ -7,7 +7,7 @@ if [ "$1" = "install" -o "$1" = "upgrade" ]; then
for i in /usr/bin/qgis /usr/bin/qbrowser; do
pkg=$(dpkg-divert --listpackage $i)
if [ -n "$pkg" -a "$pkg" = qgis-plugin-grass -o "$pkg" = qgis-provider-grass ]; then
dpkg-divert --package $pkg --rename --remove $i
dpkg-divert --package $pkg --remove $i
fi
done
fi

0 comments on commit de8f540

Please sign in to comment.
You can’t perform that action at this time.