Skip to content
Permalink
Browse files

Merge branch 'master' into measurement_from_geometry

  • Loading branch information
mhugent committed Jul 27, 2015
2 parents 8680259 + 10d262f commit e03463cda81db3281085011940bf80c9812260f4
Showing 603 changed files with 6,721 additions and 2,608 deletions.
@@ -19,8 +19,6 @@
.pydevproject
/CMakeLists.txt.user
/CMakeLists.txt.user.*
/python/plugins/sextante/about/ui_aboutdialogbase.py
/python/plugins/sextante/resources_rc.py
api_doc
build*
debian/*.debhelper
@@ -23,14 +23,13 @@ addons:
postgresql: "9.1"

before_install:
- export DEBIAN_FRONTEND=noninteractive
- sudo add-apt-repository ppa:ubuntugis/ppa -y
- sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable -y # For postgresql-9.1-postgis-2.1
- sudo add-apt-repository ppa:smspillaz/cmake-3.0.2 -y
- sudo add-apt-repository ppa:kedazo/doxygen-updates-precise -y # For doxygen 1.8.8
- sudo rm -f /etc/apt/sources.list.d/pgdg-source.list # postgis from pgdg requires different gdal package than the grass package
- sudo apt-get update -qq
- sudo apt-get remove postgresql-9.1-postgis-2.1 # Remove postgis from pgdg, will install postgis from ubuntugis-unstable instead
- sudo apt-get install --no-install-recommends
- sudo apt-get install --force-yes --no-install-recommends --no-install-suggests
bison cmake cmake-data doxygen flex git graphviz
grass-dev libexpat1-dev libfcgi-dev libgdal1-dev
libgeos-dev libgsl0-dev libpq-dev libproj-dev
@@ -41,7 +40,8 @@ before_install:
python python-dev python-qt4 python-qt4-dev
python-sip python-sip-dev spawn-fcgi txt2tags
xauth xfonts-100dpi xfonts-75dpi xfonts-base
xfonts-scalable xvfb postgresql-9.1-postgis-2.1
xfonts-scalable xvfb
postgresql-9.1-postgis-2.1/precise # postgis one from ubuntugis-unstable, not pgdg
- cmake --version
- clang --version

@@ -30,7 +30,7 @@
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#=============================================================================

# The automoc_qt4 macro is superceded by CMAKE_AUTOMOC from CMake 2.8.6
# The automoc_qt4 macro is superceeded by CMAKE_AUTOMOC from CMake 2.8.6
# A Qt 5 version is not provided by CMake or Qt.

include(MacroAddFileDependencies)
Binary file not shown.
@@ -34,7 +34,7 @@ class QgsRasterCalculator
* @param formulaString formula for raster calculation
* @param outputFile output file path
* @param outputFormat output file format
* @param outputExtent output extent, CRS is specifed by outputCrs parameter
* @param outputExtent output extent, CRS is specified by outputCrs parameter
* @param outputCrs destination CRS for output raster
* @param nOutputColumns number of columns in output raster
* @param nOutputRows number of rows in output raster
@@ -72,7 +72,7 @@ class QgsEffectStack : QgsPaintEffect
*/
bool insertEffect( const int index, QgsPaintEffect* effect /Transfer/);

/** Replaces the effect at a speficied position within the stack.
/** Replaces the effect at a specified position within the stack.
* @param index position of effect to replace
* @param effect QgsPaintEffect to replace with. Ownership of the effect will be
* transferred to the stack object.
@@ -118,13 +118,22 @@ class QgsRelation
*/
QgsFeatureRequest getRelatedFeaturesRequest( const QgsFeature& feature ) const;

const QString name() const;
QgsFeatureRequest getReferencedFeatureRequest( const QgsFeature& feature ) const;

QgsFeature getReferencedFeature( const QgsFeature& child ) const;

/**
* The id
* @return
*/
const QString& id() const;
QString name() const;

/**
* A (project-wide) unique id for this relation
*
* @return The id
*/
QString id() const;

/**
* Access the referencing (child) layer's id
@@ -182,5 +191,4 @@ class QgsRelation

protected:
void updateRelationStatus();
void runChecks();
};
@@ -159,6 +159,9 @@ class QgisInterface : QObject
/** Return a pointer to the map canvas */
virtual QgsMapCanvas * mapCanvas() = 0;

/** Returns a pointer to the layer tree canvas bridge */
virtual QgsLayerTreeMapCanvasBridge* layerTreeCanvasBridge() = 0;

/** Return a pointer to the main window (instance of QgisApp in case of QGIS) */
virtual QWidget * mainWindow() = 0;

@@ -66,13 +66,13 @@ class QgsHistogramWidget : QWidget
*/
QBrush brush() const;

/** Sets the graduated ranges associated with the histogram. If set, the ranges will be used to colour the histogram
/** Sets the graduated ranges associated with the histogram. If set, the ranges will be used to color the histogram
* bars and for showing vertical dividers at the histogram breaks.
* @param ranges graduated range list
*/
void setGraduatedRanges( const QgsRangeList& ranges );

/** Returns the graduated ranges associated with the histogram. If set, the ranges will be used to colour the histogram
/** Returns the graduated ranges associated with the histogram. If set, the ranges will be used to color the histogram
* bars and for showing vertical dividers at the histogram breaks.
* @returns graduated range list
* @see setGraduatedRanges
@@ -6,7 +6,7 @@ It allows showing the DBs contents and run query on them.
In this moment DB Manager supports the following DBMS backends:
- PostgreSQL/PostGIS through the psycopg2 pymodule
- SQLite/SpatiaLite using the pyspatialite pymodule

- Oracle Spatial using PyQt QtSql module

For more info about the project, see at the wiki page:
http://qgis.org/wiki/DB_Manager_plugin_GSoC_2011
@@ -1,5 +1,8 @@
ADD_SUBDIRECTORY(postgis)
ADD_SUBDIRECTORY(spatialite)
IF(WITH_ORACLE)
ADD_SUBDIRECTORY(oracle)
ENDIF(WITH_ORACLE)

FILE(GLOB PY_FILES *.py)
PLUGIN_INSTALL(db_manager db_plugins ${PY_FILES})
@@ -0,0 +1,9 @@

FILE(GLOB PY_FILES *.py)
FILE(GLOB ICON_FILES icons/*.png)

PYQT4_ADD_RESOURCES(PYRC_FILES resources.qrc)

PLUGIN_INSTALL(db_manager db_plugins/oracle ${PY_FILES} ${PYRC_FILES})
PLUGIN_INSTALL(db_manager db_plugins/oracle/icons ${ICON_FILES})

0 comments on commit e03463c

Please sign in to comment.
You can’t perform that action at this time.