Skip to content
Permalink
Browse files
Update INSTALL.md
On Fedora 35 Workstation (fresh install),  it is not possible to install dependencies following the instructions provided.
2 packages have no match and some others are required but not included (python3-sip-devel protobuf-lite protobuf-lite-devel libzstd-devel qt5-qtserialport-devel).
Assuming the currently displayed command worked on previous Fedora versions (which ones?), I propose to keep it for reference, renaming the title: "Install command for dependencies (older versions)" while providing an updated "Install command for dependencies (Fedora 35 Workstation)" that correctly installs all required packages with the latest distribution, allowing to successfully compile.
I've tested the updated command multiple times with success (but of course a double check is welcome).
  • Loading branch information
GisUsers authored and nyalldawson committed Dec 19, 2021
1 parent a9d1d1b commit e764ec8a92f30eb1694fe6151e1568e4b70c7335
Showing with 7 additions and 3 deletions.
  1. +7 −3 INSTALL.md
@@ -425,11 +425,15 @@ new subdirectory called `build` or `build-qt5` in it.

### 3.11.1. Install build dependencies

|Install command for dependencies|
|--------------------------------|
|Install command for dependencies (older versions)|
|-------------------------------------------------|
|`dnf install qt5-qtbase-private-devel qt5-qtwebkit-devel qt5-qtlocation-devel qt5-qttools-static qca-qt5-devel qca-qt5-ossl qt5-qt3d-devel python3-qt5-devel python3-qscintilla-qt5-devel qscintilla-qt5-devel python3-qscintilla-devel python3-qscintilla-qt5 clang flex bison geos-devel gdal-devel sqlite-devel libspatialite-devel qt5-qtsvg-devel spatialindex-devel expat-devel proj-devel qwt-qt5-devel gsl-devel postgresql-devel cmake python3-future gdal-python3 python3-psycopg2 python3-PyYAML python3-pygments python3-jinja2 python3-OWSLib qca-qt5-ossl qwt-qt5-devel qtkeychain-qt5-devel qwt-devel sip-devel libzip-devel exiv2-devel`|


|Install command for dependencies (Fedora 35 Workstation)|
|--------------------------------------------------------|
|`dnf install qt5-qtbase-private-devel qt5-qtwebkit-devel qt5-qtlocation-devel qt5-qttools-static qca-qt5-devel qca-qt5-ossl qt5-qt3d-devel python3-qt5-devel python3-qscintilla-qt5-devel qscintilla-qt5-devel python3-qscintilla-qt5 clang flex bison geos-devel gdal-devel sqlite-devel libspatialite-devel qt5-qtsvg-devel spatialindex-devel expat-devel proj-devel qwt-qt5-devel gsl-devel postgresql-devel cmake python3-future gdal-python3 python3-psycopg2 python3-PyYAML python3-pygments python3-jinja2 python3-OWSLib qca-qt5-ossl qwt-qt5-devel qtkeychain-qt5-devel qwt-devel libzip-devel exiv2-devel python3-sip-devel protobuf-lite protobuf-lite-devel libzstd-devel qt5-qtserialport-devel`|


To build QGIS server additional dependencies are required:

```bash

0 comments on commit e764ec8

Please sign in to comment.