Skip to content
Permalink
Browse files

Fix a warning when building on >= Qt 5.13

  • Loading branch information
nyalldawson committed Feb 7, 2020
1 parent 51f4f03 commit f3c423417be50a6b3bad01bb3eb94929d5043f65
Showing with 5 additions and 0 deletions.
  1. +5 −0 src/core/auth/qgsauthcertutils.cpp
@@ -228,6 +228,11 @@ QSslKey QgsAuthCertUtils::keyFromFile( const QString &keypath,
case QSsl::KeyAlgorithm::Opaque:
*algtype = QStringLiteral( "opaque" );
break;
#if QT_VERSION >= QT_VERSION_CHECK(5, 13, 0)
case QSsl::KeyAlgorithm::Dh:
*algtype = QStringLiteral( "dh" );
break;
#endif
}
}
return clientkey;

0 comments on commit f3c4234

Please sign in to comment.
You can’t perform that action at this time.