Skip to content
Permalink
Browse files
added dependency packages for python language binding and some notes …
…about current

version requirements for sip4 and python-qt4 


git-svn-id: http://svn.osgeo.org/qgis/trunk@7113 c8812cc2-4d05-0410-92ff-de0c093fc19c
  • Loading branch information
dassau committed Jul 30, 2007
1 parent 2a827fb commit fedafb5006104ec818e2a7731fa425a0b202b940
Showing with 6 additions and 2 deletions.
  1. +6 −2 INSTALL.t2t
@@ -659,13 +659,17 @@ above commands to select the Qt4 version of the relevant applications.

```
sudo apt-get install gdal-bin libgdal1-dev libgeos-dev proj libtool \
libgdal-doc libhdf4g-dev libhdf4g-run python-dev \
swig libgsl0-dev g++ libjasper-1.701-dev libtiff4-dev subversion gsl-bin \
libgdal-doc libhdf4g-dev libhdf4g-run python-dev python-qt4-dev sip4 \
swig libgsl0-dev g++ libjasper-1.701-dev libtiff4-dev subversion gsl-bin \
libsqlite3-dev sqlite3 ccache make libpq-dev flex bison
```

/!\ Debian users should use libgdal-dev above rather

/!\ ***Note:*** For python language bindings SIP >= 4.5 and PyQt4 >= 4.1 is required! Some stable GNU/Linux
distributions (e.g. Debian or SuSE) only provide SIP < 4.5 and PyQt4 < 4.1. To include support for python
language bindings you need to build and install those packages from source.

== GRASS Specific Steps ==

/!\ ***Note:*** If you don't need to build with GRASS support, you can

0 comments on commit fedafb5

Please sign in to comment.