Skip to content


added dependency packages for python language binding and some notes …
Browse files Browse the repository at this point in the history
…about current

version requirements for sip4 and python-qt4 

git-svn-id: c8812cc2-4d05-0410-92ff-de0c093fc19c
  • Loading branch information
dassau committed Jul 30, 2007
1 parent 2a827fb commit fedafb5
Showing 1 changed file with 6 additions and 2 deletions.
8 changes: 6 additions & 2 deletions INSTALL.t2t
Original file line number Diff line number Diff line change
Expand Up @@ -659,13 +659,17 @@ above commands to select the Qt4 version of the relevant applications.

sudo apt-get install gdal-bin libgdal1-dev libgeos-dev proj libtool \
libgdal-doc libhdf4g-dev libhdf4g-run python-dev \
swig libgsl0-dev g++ libjasper-1.701-dev libtiff4-dev subversion gsl-bin \
libgdal-doc libhdf4g-dev libhdf4g-run python-dev python-qt4-dev sip4 \
swig libgsl0-dev g++ libjasper-1.701-dev libtiff4-dev subversion gsl-bin \
libsqlite3-dev sqlite3 ccache make libpq-dev flex bison

/!\ Debian users should use libgdal-dev above rather

/!\ ***Note:*** For python language bindings SIP >= 4.5 and PyQt4 >= 4.1 is required! Some stable GNU/Linux
distributions (e.g. Debian or SuSE) only provide SIP < 4.5 and PyQt4 < 4.1. To include support for python
language bindings you need to build and install those packages from source.

== GRASS Specific Steps ==

/!\ ***Note:*** If you don't need to build with GRASS support, you can
Expand Down

0 comments on commit fedafb5

Please sign in to comment.