Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

wms layer is added even if the the request fails #11575

Closed
qgib opened this issue Jan 26, 2009 · 1 comment

Comments

@qgib
Copy link
Contributor

commented Jan 26, 2009

Author Name: Giovanni Manghi (@gioman)
Original Redmine Issue: 1515

Redmine category:web_services_clients/wms
Assignee: Marco Hugentobler


When a WMS layer is added and the requests fails, the layer is added anyway in the legend. The result is that if the layer is not removed by hand from the legend, any action (zoom, pan, add/remove other layers) will produce the error shown when the initial request failed.

If the wms layer cannot be retrieved it should not be added to the legend.

I noticed this behavior when I mistakenly used the wrong URL while adding a new wms server connection:

I used

http://mapas.igeo.pt/igp/Capabilities/wms_CRIF_GetCapabilities.xml

instead of

http://mapas.igeo.pt/wms/crif2008

The first URL gives a list of layers but a error is returned when you try to add them, still they are added to the legend.

@qgib

This comment has been minimized.

Copy link
Contributor Author

commented Aug 10, 2009

Author Name: Giovanni Manghi (@gioman)


Well, the problem was then explained very bad. I will open a new ticket with a better description if and when I will encounter again the same problem.


  • resolution was changed from to wontfix
  • status_id was changed from Open to Closed
@qgib qgib added this to the Version 1.2.0 milestone May 24, 2019
@qgib qgib closed this May 24, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.