Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

paste doesn't convert geometry or give error on incompatible geometry #13663

Closed
qgib opened this issue Mar 13, 2011 · 7 comments

Comments

@qgib
Copy link
Contributor

commented Mar 13, 2011

Author Name: William Kyngesburye (@kyngchaos)
Original Redmine Issue: 3604
Affected QGIS version: master
Redmine category:vectors


For example, I'm working in a [[PostGIS]] multipolygon layer. I copy a polygon (not multi) from a shapefile and paste it into the postGIS layer. QGIS doesn't give me a warning or convert the polygon to a multipolygon, and editing works fine on the feature. But when I try to save the [[PostGIS]] layer, QGIS now gives me an error that there is an invalid geometry type and a feature wasn't saved (the one I pasted in).

I would like it to convert the polygon to multipolygon, and other simple conversions. But at least QGIS should refuse to paste and give a warning about a geometry mismatch.

@qgib

This comment has been minimized.

Copy link
Contributor Author

commented Mar 13, 2011

Author Name: William Kyngesburye (@kyngchaos)


Hmm, it looks like even copying from a multipolygon layer (both shapefile and another [[PostGIS]] layer) is not working. I still get invalid geometry.

@qgib

This comment has been minimized.

Copy link
Contributor Author

commented Mar 29, 2011

Author Name: William Kyngesburye (@kyngchaos)


Now at least copying from a similar postgis multipolygon layer seems to be working. Still can't copy from the shapefile.

@qgib

This comment has been minimized.

Copy link
Contributor Author

commented Apr 3, 2011

Author Name: William Kyngesburye (@kyngchaos)


Definitely something with copying from a shapefile to postgis. I converted the shapefile to a multipolygon postgis layer outside QGIS, added that layer to QGIS, and copy from that to my postgis layer works.

@qgib

This comment has been minimized.

Copy link
Contributor Author

commented Dec 16, 2011

Author Name: Giovanni Manghi (@gioman)


  • fixed_version_id was changed from Version 1.7.0 to Version 1.7.4
@qgib

This comment has been minimized.

Copy link
Contributor Author

commented Apr 16, 2012

Author Name: Paolo Cavallini (@pcav)


  • fixed_version_id was changed from Version 1.7.4 to Version 1.8.0
  • crashes_corrupts_data was configured as 0
  • version was configured as master
@qgib

This comment has been minimized.

Copy link
Contributor Author

commented Sep 4, 2012

Author Name: Paolo Cavallini (@pcav)


  • fixed_version_id was changed from Version 1.8.0 to Version 2.0.0
@qgib

This comment has been minimized.

Copy link
Contributor Author

commented Mar 2, 2014

Author Name: Jürgen Fischer (@jef-n)


Fixed in changeset "2f2d6ac95b052bb490c47ba53eb327c96176eed1".


  • status_id was changed from Open to Closed
@qgib qgib added Bug Vectors labels May 24, 2019
@qgib qgib added this to the Version 2.0.0 milestone May 24, 2019
@qgib qgib closed this May 24, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.