Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

iterate broken in Processing/QGIS 2.16.3 #23573

Closed
qgib opened this issue Oct 2, 2016 · 2 comments

Comments

@qgib
Copy link
Contributor

commented Oct 2, 2016

Author Name: Giovanni Manghi (@gioman)
Original Redmine Issue: 15650
Affected QGIS version: 2.16.3
Redmine category:processing/core
Assignee: Victor Olaya


Take the linked shapefiles, and try do a Intersection (QGIS tool) using the buffers with iterate against the land use layer. It works as expected on QGIS 2.14.. Fails on 2.16.

Traceback (most recent call last):
File "C:/OSGeo4W/apps/qgis/./python/plugins\processing\gui\AlgorithmDialog.py", line 238, in accept
if runalgIterating(self.alg, self.iterateParam, self):
File "C:/OSGeo4W/apps/qgis/./python/plugins\processing\gui\AlgorithmExecutor.py", line 90, in runalgIterating
if runalg(alg):
File "C:/OSGeo4W/apps/qgis/./python/plugins\processing\gui\AlgorithmExecutor.py", line 52, in runalg
progress.error(e.msg)
AttributeError: 'NoneType' object has no attribute 'error'

@qgib

This comment has been minimized.

Copy link
Contributor Author

commented Oct 2, 2016

@qgib

This comment has been minimized.

Copy link
Contributor Author

commented Oct 4, 2016

Author Name: Victor Olaya (@volaya)


Fixed in changeset "4bcdecd3cf87dd191c27bcb4d6419191f5ff8cb2".


  • status_id was changed from Open to Closed
@qgib qgib added this to the Version 2.18 milestone May 25, 2019
@qgib qgib closed this May 25, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.