Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Reactivate (some) WMS GetPrint unit tests #37179

Closed
wants to merge 4 commits into from

Conversation

pblottiere
Copy link
Member

@pblottiere pblottiere commented Jun 12, 2020

Description

After some experimentation with Travis, it seems that 3 tests are actually flaky and cause a segfault:

  • test_wms_getprint_atlas_getProjectSettings
  • test_wms_getprint_atlas
  • test_wms_getprint_two_maps

However, segfault doesn't seem to be happening when these tests are executed alone. I didn't find the origin of the segfault but I'd like to reactivate all the other tests to have a basic test coverage for the WMS GetPrint request.

@pblottiere
Copy link
Member Author

pblottiere commented Jun 12, 2020

What do you think @rldhont?

@pblottiere pblottiere added the Server label Jun 12, 2020
@github-actions github-actions bot added this to the 3.14.0 milestone Jun 12, 2020
@rldhont
Copy link
Contributor

rldhont commented Jun 13, 2020

@pblottiere great news, I was on the same way.

@pblottiere pblottiere force-pushed the reactivate_wms_getprint branch from b0158c2 to f87fc85 Compare Jun 14, 2020
@pblottiere
Copy link
Member Author

pblottiere commented Jun 15, 2020

Still segfaulting...

@pblottiere pblottiere closed this Jun 15, 2020
@mdouchin
Copy link
Contributor

mdouchin commented Jun 22, 2020

Crossed fingers...

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Needs Backporting Server
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

3 participants