New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

OSX Gui Keys Not Firing Properly? #208

Closed
braidn opened this Issue Mar 23, 2016 · 2 comments

Comments

Projects
None yet
2 participants
@braidn

braidn commented Mar 23, 2016

Just pulled the most recent version of QMK and decided to tweak my planck layout. However on reboot, the bottom row of the following keymap was acting off:

https://gist.github.com/d2b3cd4986b61178c2af

LGUI fires as if it's an LALT, LALT doesn't fire at all, RGUI doesn't fire at all, and RALT fires fine. All of these fire as 'FlagsChanged' in event viewer over the more traditional keyup/keydown I have never seen this before but it is definitely odd. Any help would be amazing. Thanks again

@braidn braidn changed the title from OSX Gui Key's Not Working to OSX Gui Keys Not Firing Properly? Mar 23, 2016

@braidn

This comment has been minimized.

braidn commented Mar 23, 2016

Ok, so apparently this is due to a Boot Magic mode that the keyboard is in? Holding space + backspace on the keyboard as you plug it in seems to fix everything. Closing but updating for history's sake and if someone is searching.

@braidn braidn closed this Mar 23, 2016

@tuananh

This comment has been minimized.

tuananh commented Nov 21, 2018

@braidn a thousand upvotes. I love you!!!!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment