Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Can't compile on Arch x86-64 #16

Closed
petRUShka opened this Issue · 10 comments

2 participants

petRUShka Alexander Vershilov
petRUShka

I catch an error when I compile kbdd

==> Making package: kbdd 0.6-1 (Thu May 3 00:12:47 MSK 2012)
...
In file included from kbdd.c:36:0:
/usr/include/glib-2.0/glib/gthread.h:28:2: error: #error "Only <glib.h> can be included directly."
make[3]: *** [kbdd.o] Error 1

My system:

% uname -a
Linux lparch 3.3.4-1-ARCH #1 SMP PREEMPT Sat Apr 28 00:21:22 CEST 2012 x86_64 Intel(R) Core(TM)2 Duo CPU T7700 @ 2.40GHz GenuineIntel GNU/Linux

% LANG=en_EN gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.0/lto-wrapper
Target: x86_64-unknown-linux-gnu
Configured with: /build/src/gcc-4.7-20120414/configure --prefix=/usr --libdir=/usr/lib --libexecdir=/usr/lib --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=https://bugs.archlinux.org/ --enable-languages=c,c++,ada,fortran,go,lto,objc,obj-c++ --enable-shared --enable-threads=posix --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-clocale=gnu --disable-libstdcxx-pch --enable-libstdcxx-time --enable-gnu-unique-object --enable-linker-build-id --with-ppl --enable-cloog-backend=isl --enable-lto --enable-gold --enable-ld=default --enable-plugin --with-plugin-ld=ld.gold --with-linker-hash-style=gnu --enable-multilib --disable-libssp --disable-build-with-cxx --disable-build-poststage1-with-cxx --enable-checking=release --with-fpmath=sse
Thread model: posix
gcc version 4.7.0 20120414 (prerelease) (GCC)

I get kbdd from AUR: https://aur.archlinux.org/packages.php?ID=43452

Alexander Vershilov qnikst was assigned
Alexander Vershilov
Owner

Strange patch, that fixes this error should be included in 0.6.1, anyway I'll try to check and fix it in nearest feature.

Alexander Vershilov
Owner

AUR package sources are: https://github.com/downloads/qnikst/kbdd/kbdd-0.6.tar.bz2
and version where problem is fixed is: https://github.com/downloads/qnikst/kbdd/kbdd-0.6.1.tar.bz2

you should request aur update or install newer version.

Alexander Vershilov qnikst closed this
petRUShka

There is no 0.6.1 in downloads. There is only kbdd-0.6.tar.bz2 that marked as version 0.6.1...

Alexander Vershilov
Owner

it was in tag list:
0.6.2: https://github.com/qnikst/kbdd/tarball/v0.6.2
0.6.1: https://github.com/qnikst/kbdd/tarball/v0.6.1

I can create downloads tar if it necessary

petRUShka

I would be great!

petRUShka

But may be I will change PKGBUILD to using tag list instead of downloads and send it to author. Thanks

petRUShka

Yes please create downloads, because tarball version haven't the same structure as downloads version...

petRUShka

New error:

  ==> Building and installing package
  ==> Сборка пакета: kbdd 0.6.2-1 (Сб. мая  5 00:53:44 MSK 2012)
  ...
  m-kbdd-service.c:19:28: фатальная ошибка: ../common-defs.h: Нет такого файла или каталога
  компиляция прервана.
  make[4]: *** [m-kbdd-service.o] Ошибка 1
Alexander Vershilov qnikst reopened this
Alexander Vershilov
Owner

fixed

Alexander Vershilov qnikst closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.