New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

travis ci failing with latest chrome unstable #9349

Closed
level420 opened this Issue Jun 14, 2017 · 21 comments

Comments

Projects
None yet
9 participants
@level420
Member

level420 commented Jun 14, 2017

We are getting the following messages when trying to start chrome:

14 06 2017 12:28:20.640:ERROR [launcher]: Cannot start Chrome
	[3750:3762:0614/122820.429774:ERROR:bus.cc(422)] Failed to connect to the bus: Failed to connect to socket /var/run/dbus/system_bus_socket: Connection refused
Xlib:  extension "RANDR" missing on display ":99.0".
[3750:3777:0614/122820.443087:FATAL:nss_util.cc(679)] NSS_VersionCheck("3.26") failed. NSS >= 3.26 is required. Please upgrade to the latest NSS, and if you still get this error, contact your distribution maintainer.

@level420 level420 added the bug label Jun 14, 2017

@level420

This comment has been minimized.

Show comment
Hide comment
@level420

level420 Jun 14, 2017

Member

@cajus could you please have a look into this if we could do something here? As chrome since version 59 supports headless mode, we could maybe run the tests without xvfb

See

Member

level420 commented Jun 14, 2017

@cajus could you please have a look into this if we could do something here? As chrome since version 59 supports headless mode, we could maybe run the tests without xvfb

See

@cajus

This comment has been minimized.

Show comment
Hide comment
@cajus

cajus Jun 14, 2017

Contributor

@level420 I've updated it to run headless locally, but it's more about the incompatible NSS version.

Contributor

cajus commented Jun 14, 2017

@level420 I've updated it to run headless locally, but it's more about the incompatible NSS version.

@cajus cajus self-assigned this Jun 14, 2017

@level420

This comment has been minimized.

Show comment
Hide comment
@level420

level420 Jun 14, 2017

Member

Ah. I see ... So it's about choosing another ubuntu version for the container based tests which hopefully have a more up to date NSS?

Member

level420 commented Jun 14, 2017

Ah. I see ... So it's about choosing another ubuntu version for the container based tests which hopefully have a more up to date NSS?

@level420

This comment has been minimized.

Show comment
Hide comment
@level420

level420 Jun 14, 2017

Member

Seems that travis ci offers ubuntu 14.04 LTS
https://docs.travis-ci.com/user/ci-environment/#Virtualization-environments
which offers nss v 3.28 which would fit:
https://launchpad.net/ubuntu/trusty/+source/nss

Member

level420 commented Jun 14, 2017

Seems that travis ci offers ubuntu 14.04 LTS
https://docs.travis-ci.com/user/ci-environment/#Virtualization-environments
which offers nss v 3.28 which would fit:
https://launchpad.net/ubuntu/trusty/+source/nss

@oetiker

This comment has been minimized.

Show comment
Hide comment
@oetiker

oetiker Jun 14, 2017

Member

oh :-) we might want to upgrade

Member

oetiker commented Jun 14, 2017

oh :-) we might want to upgrade

@oetiker

This comment has been minimized.

Show comment
Hide comment
@oetiker

oetiker Jun 14, 2017

Member

adding dist: trusty to the .travis file should do the trick

Member

oetiker commented Jun 14, 2017

adding dist: trusty to the .travis file should do the trick

@cboulanger

This comment has been minimized.

Show comment
Hide comment
@cboulanger

cboulanger Jun 17, 2017

Contributor

Any progress on this?

Contributor

cboulanger commented Jun 17, 2017

Any progress on this?

@peuter

This comment has been minimized.

Show comment
Hide comment
@peuter

peuter Jun 19, 2017

Member

I get the same error in another project using pretty much the same build environment. I already use the trusty dist, so the upgrade does not solve the problem.

Member

peuter commented Jun 19, 2017

I get the same error in another project using pretty much the same build environment. I already use the trusty dist, so the upgrade does not solve the problem.

@peuter

This comment has been minimized.

Show comment
Hide comment
@peuter

peuter Jun 19, 2017

Member

Travis trusty image is a little bit outdated, it uses libnss3 in version 3.23. When you upgrade the package (sudo apt-get --only-upgrade install libnss3) to 3.28, the error is gone.

Member

peuter commented Jun 19, 2017

Travis trusty image is a little bit outdated, it uses libnss3 in version 3.23. When you upgrade the package (sudo apt-get --only-upgrade install libnss3) to 3.28, the error is gone.

@oetiker

This comment has been minimized.

Show comment
Hide comment
@oetiker

oetiker Jun 19, 2017

Member

can you do a PR for the .travis.yml ?

Member

oetiker commented Jun 19, 2017

can you do a PR for the .travis.yml ?

peuter added a commit to peuter/qooxdoo that referenced this issue Jun 19, 2017

@peuter

This comment has been minimized.

Show comment
Hide comment
@peuter

peuter Jun 19, 2017

Member

I can try, I have to check if using the "trusty" image introduces new errors.

Member

peuter commented Jun 19, 2017

I can try, I have to check if using the "trusty" image introduces new errors.

@cajus

This comment has been minimized.

Show comment
Hide comment
@cajus

cajus Jun 19, 2017

Contributor

Well. We spent much time to have a container based build - and the ticket is currently assigned to me.

Contributor

cajus commented Jun 19, 2017

Well. We spent much time to have a container based build - and the ticket is currently assigned to me.

@cajus

This comment has been minimized.

Show comment
Hide comment
@cajus

cajus Jun 19, 2017

Contributor

As travis sucks from time to time, and I spent countless hours into various problems until now, I tend to make a docker image of our own which contains a recent distribution. Trusty is "beta" on travis side - and it's more than outdated in real life.

Contributor

cajus commented Jun 19, 2017

As travis sucks from time to time, and I spent countless hours into various problems until now, I tend to make a docker image of our own which contains a recent distribution. Trusty is "beta" on travis side - and it's more than outdated in real life.

@cajus

This comment has been minimized.

Show comment
Hide comment
@cajus

cajus Jun 19, 2017

Contributor

I've fixed the two errors (headless / travis beta container) and we're green again. I'll leave this issue open for the docker image - to get rid of the travis container dependency.

Contributor

cajus commented Jun 19, 2017

I've fixed the two errors (headless / travis beta container) and we're green again. I'll leave this issue open for the docker image - to get rid of the travis container dependency.

@oetiker

This comment has been minimized.

Show comment
Hide comment
@oetiker

oetiker Jun 20, 2017

Member

yes that seems rather odd I wonder what makes it so hard for them to offer current images

Member

oetiker commented Jun 20, 2017

yes that seems rather odd I wonder what makes it so hard for them to offer current images

@level420

This comment has been minimized.

Show comment
Hide comment
Member

level420 commented Jun 26, 2017

@level420

This comment has been minimized.

Show comment
Hide comment
@level420

level420 Jun 26, 2017

Member

thank you @cajus

Member

level420 commented Jun 26, 2017

thank you @cajus

@sfc0907

This comment has been minimized.

Show comment
Hide comment
@sfc0907

sfc0907 Aug 29, 2017

I am facing the same issue with NSS_VersionCheck.My Ubuntu's version is 14.04LTS.I try this command sudo apt-get --only-upgrade install libnss3,but it seems that the vesion is 3.15.Do you have any ideas about this?Thank you.

sfc0907 commented Aug 29, 2017

I am facing the same issue with NSS_VersionCheck.My Ubuntu's version is 14.04LTS.I try this command sudo apt-get --only-upgrade install libnss3,but it seems that the vesion is 3.15.Do you have any ideas about this?Thank you.

@leothor2015

This comment has been minimized.

Show comment
Hide comment
@leothor2015

leothor2015 Sep 14, 2017

Travis trusty image is a little bit outdated, it uses libnss3 in version 3.23. When you upgrade the package (sudo apt-get --only-upgrade install libnss3) to 3.28, the error is gone.

This one solved the issue. Thanks.

leothor2015 commented Sep 14, 2017

Travis trusty image is a little bit outdated, it uses libnss3 in version 3.23. When you upgrade the package (sudo apt-get --only-upgrade install libnss3) to 3.28, the error is gone.

This one solved the issue. Thanks.

@smartm0use

This comment has been minimized.

Show comment
Hide comment
@smartm0use

smartm0use Sep 14, 2017

@peuter 's solution works, it does the trick! Thank you!

smartm0use commented Sep 14, 2017

@peuter 's solution works, it does the trick! Thank you!

@hkollmann

This comment has been minimized.

Show comment
Hide comment
@hkollmann

hkollmann Feb 26, 2018

Member

Done.

Member

hkollmann commented Feb 26, 2018

Done.

@hkollmann hkollmann closed this Feb 26, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment