@riverfor riverfor released this Sep 6, 2018

Assets 4

v2.4.2-2 is released (2018/9/28)

  • Added tab key in terminal

v2.4.2-1 (2018/9/26)

  • Added dropbear SSH toolkit
  • Fix some bugs

v2.4.1 (2018/9/14)

  • Fixed pip block issue
  • Added notebook in terminal
  • Removed some unused files

v2.4.0

This is a big update for QPython, after installing it, you can get Py2.7.15 and Py3.3.6 all in one.

  • Brand new Python 2 (2.7.15)
  • Built-in Python 3 plug-in in QPython setting (Py3.6.6)
  • Built-in Pygame support (For Py2 only now)
  • Built-in Notebook plug-in (Support Py2 and Py3)
  • New PIP tool (Supports more libraries)
  • Many amazing improvements

New Libraries

  • Numpy for Py2 and Py3
  • Pyjnius for Py2
  • QSl4ahelper for Py2

FAQ

Q: Why should I have to upgrade ?
A: You can get the Py2.7.15 and 3.6.6 (You can switch to Python 3 from QPython's setting) after installing. Besides this, you can have newer PIP package which can install many pure python packages.

Q: Why can't I install other Python packages after installing the QPython v2.4.0 ?
A: Did you new install it ? If not, please try to clear data from QPython's setting => storage & permission => clear data.

Q: Why can't I see other packages after installing?
A: We have changed the Python core, and old packages should be tested or recompiled. After we having completed that, we will re-published them.

Q: What packages do you want to support in the future?
A: We will try to support more and more packages in the future, our recent main work is to improve the cross compile toolchain, now we have completed it, and we are able to support more packages.

Q: Why should I install QPyNotebook again when switch to Python 3 after I having installed it when I used Python 2.
A: Yes, you need to install it again for the Python 3 again, for the QPyNotebook was separated the py2 and py3 branch, every time you install it, you were installing the branch for the python interpreter your were using.

Q: Why can't I see kivy support in this version?
A: Kivy is not a built-in library by default, and we are porting it to adjust the newest python core, now you could try the QSL4A (Checkout a sample project https://github.com/qpython-android/sample-qsl4a/ ) to develop app or pygame to develop game with QPython.

中文用户

v2.4.0

这是一个大版本更新,安装后,你可以同时拥有 Py2.7.15 和 Py3.6.6 以及许多更赞的新特性

  • 全新的 Python 2 (2.7.15)
  • 加入 Python 3 插件 (Py3.6.6)
  • 内置支持安卓SDL2的 Pygame 库 (Py2 only now)
  • 内置 Notebook 插件 (Support Py2 and Py3)
  • 全新 PIP 客户端,支持安装更多的 Python 库
  • 许多让人称赞的改进

新的库

  • Numpy for Py2 and Py3
  • Scipy for Py3
  • QSl4ahelper (开发原生体验的应用)

BAIDU CLOUD DISK

链接: https://pan.baidu.com/s/1P4EkYDZp4nGe22K0D6MjAw 密码: ed6z