Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Updating gemspec and doc for 1.0.2 release

  • Loading branch information...
commit a89c9a6a1a87c3d8ff43acb3f1fe0e34e9547ba0 1 parent 5b79f30
@jscruggs jscruggs authored
Showing with 11 additions and 5 deletions.
  1. +6 −0 HISTORY
  2. +4 −4 home_page/index.html
  3. +1 −1  metric_fu.gemspec
View
6 HISTORY
@@ -1,3 +1,9 @@
+=== MetricFu 1.0.2 / 2009-5-11
+
+* Fixing problems with Reek new line character (thanks to all who pointed this out)
+* Flog now recognizes namespaces in method names thanks to Daniel Guettler
+* Saikuro now looks at multiple directories, again.
+
=== MetricFu 1.0.1 / 2009-5-3
* metrics:all task no longer requires a MetricFu::Configuration.run {} if you want to accept the defaults
View
8 home_page/index.html
@@ -46,7 +46,7 @@
<!-- end #sidebar -->
</div>
<div id="left">
- <h1>About metric_fu 1.0.1</h1>
+ <h1>About metric_fu 1.0.2</h1>
<div>
<p><br/>
Metric_fu is a set of rake tasks that make it easy to generate metrics reports. It uses
@@ -82,13 +82,13 @@
If you like to vendor gems, you can unpack metric_fu into vendor/gems and require it like so:
</p>
<br/>
-<pre>require(File.join(RAILS_ROOT, 'vendor', 'gems', 'jscruggs-metric_fu-1.0.1', 'lib', 'metric_fu'))</pre>
+<pre>require(File.join(RAILS_ROOT, 'vendor', 'gems', 'jscruggs-metric_fu-1.0.2', 'lib', 'metric_fu'))</pre>
<br/>
<p>Then you don't have to install it on every box you run it on.</p>
<br/>
<p>Later versions of Rails like to manage your gems for you, so you can put this in your test.rb file:</p>
<br/>
-<pre>config.gem 'jscruggs-metric_fu', :version => '1.0.1', :lib => 'metric_fu', :source => 'http://gems.github.com'</pre>
+<pre>config.gem 'jscruggs-metric_fu', :version => '1.0.2', :lib => 'metric_fu', :source => 'http://gems.github.com'</pre>
<br/>
<p>And then issue this command:</p>
<br/>
@@ -99,7 +99,7 @@
<p>That way Rails won't yell at you every time you run a Rake task:</p>
<br/>
<pre>
- config.gem: Unpacked gem jscruggs-metric_fu-1.0.1 in vendor/gems has no specification file. Run 'rake gems:refresh_specs' to fix this.
+ config.gem: Unpacked gem jscruggs-metric_fu-1.0.2 in vendor/gems has no specification file. Run 'rake gems:refresh_specs' to fix this.
</pre>
<br/>
<p>
View
2  metric_fu.gemspec
@@ -1,6 +1,6 @@
Gem::Specification.new do |s|
s.name = "metric_fu"
- s.version = "1.0.1"
+ s.version = "1.0.2"
s.summary = "A fistful of code metrics"
s.email = "jake.scruggs@gmail.com"
s.homepage = "http://metric-fu.rubyforge.org/"
Please sign in to comment.
Something went wrong with that request. Please try again.