Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 21 lines (17 sloc) 0.86 kB
46c8373 @qrush basic setup
authored
1 # -*- encoding: utf-8 -*-
7e9cd23 @qrush rename to motion-settings-bundle
authored
2 require File.expand_path('../lib/motion-settings-bundle/version', __FILE__)
46c8373 @qrush basic setup
authored
3
4 Gem::Specification.new do |gem|
5 gem.authors = ["Nick Quaranto"]
6 gem.email = ["nick@quaran.to"]
a941aa9 @qrush Add license, generate a very, very simple plist
authored
7 gem.summary = gem.description =
8 %{Create a Settings.bundle for your RubyMotion app. This allows your app to have a "global" settings entry in the Settings app.}
7e9cd23 @qrush rename to motion-settings-bundle
authored
9 gem.homepage = "https://github.com/qrush/motion-settings-bundle"
46c8373 @qrush basic setup
authored
10
11 gem.files = `git ls-files`.split($\)
12 gem.executables = gem.files.grep(%r{^bin/}).map{ |f| File.basename(f) }
13 gem.test_files = gem.files.grep(%r{^(test|spec|features)/})
7e9cd23 @qrush rename to motion-settings-bundle
authored
14 gem.name = "motion-settings-bundle"
46c8373 @qrush basic setup
authored
15 gem.require_paths = ["lib"]
9ba3ff7 @qrush rename Motion::Settings to Motion::SettingsBundle
authored
16 gem.version = Motion::SettingsBundle::VERSION
a941aa9 @qrush Add license, generate a very, very simple plist
authored
17
18 gem.add_dependency 'plist', '~> 3.1.0'
19 gem.add_development_dependency 'rake'
46c8373 @qrush basic setup
authored
20 end
Something went wrong with that request. Please try again.