Permalink
Browse files

rename Motion::Settings to Motion::SettingsBundle

  • Loading branch information...
qrush committed Sep 10, 2012
1 parent 7e9cd23 commit 9ba3ff7bc5f90a241c42005125de0e36fc5ddad7
View
@@ -23,21 +23,21 @@ Add a chunk of code into your project's `Rakefile` like so:
``` ruby
require 'motion-settings-bundle'
-Motion::Settings.setup do |app|
+Motion::SettingsBundle.setup do |bundle|
# A text field. Allows configuration of a string.
- app.text "Name", key: "username", default: "Paul Atreides"
+ bundle.text "Name", key: "username", default: "Paul Atreides"
# A read-only text field. Use for showing a small chunk of text, maybe a version number
- app.title "Year of Birth", key: "yearOfBirth", default: "10,175 AG"
+ bundle.title "Year of Birth", key: "yearOfBirth", default: "10,175 AG"
# An on/off switch. Turn something on or off. Default is `false` (off).
- app.toggle "Kwisatz Haderach?", key: "superpowersEnabled", default: true
+ bundle.toggle "Kwisatz Haderach?", key: "superpowersEnabled", default: true
# A slider, configure volume or something linear
- app.slider "Spice Level", key: "spiceLevel", default: 50, min: 1, max: 100
+ bundle.slider "Spice Level", key: "spiceLevel", default: 50, min: 1, max: 100
# Jump to a screen and choose from a list of options
- app.options "Occupation", key: "occupation" do |group|
+ bundle.options "Occupation", key: "occupation" do |group|
group.option "Padishah Emperor"
group.option "Mentat", default: true
group.option "Duke of House Atreides"
View
@@ -24,7 +24,7 @@ Bundler.setup
require 'motion-settings-bundle'
-Motion::Settings.setup do |app|
+Motion::SettingsBundle.setup do |app|
# A text field. Allows configuration of a string.
app.text "Name", key: "username", default: "Paul Atreides"
@@ -11,7 +11,7 @@
require "motion-settings-bundle/version"
module Motion
- module Settings
+ module SettingsBundle
class << self
attr_accessor :generator
@@ -26,7 +26,7 @@ def setup(&block)
desc "Generate a Settings.bundle"
task :settings do
- Motion::Settings.generator.generate
+ Motion::SettingsBundle.generator.generate
end
%w(build:simulator build:device).each do |build_task|
@@ -1,5 +1,5 @@
module Motion
- module Settings
+ module SettingsBundle
class Configuration
attr_reader :preferences
@@ -1,5 +1,5 @@
module Motion
- module Settings
+ module SettingsBundle
class Generator
def initialize(resources_dir)
@root_path = File.join(resources_dir, "Settings.bundle")
@@ -1,5 +1,5 @@
module Motion
- module Settings
+ module SettingsBundle
VERSION = "0.0.1"
end
end
@@ -13,7 +13,7 @@ Gem::Specification.new do |gem|
gem.test_files = gem.files.grep(%r{^(test|spec|features)/})
gem.name = "motion-settings-bundle"
gem.require_paths = ["lib"]
- gem.version = Motion::Settings::VERSION
+ gem.version = Motion::SettingsBundle::VERSION
gem.add_dependency 'plist', '~> 3.1.0'
gem.add_development_dependency 'rake'

0 comments on commit 9ba3ff7

Please sign in to comment.