Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Zipline installation failed #2532

Open
alanpang1990301 opened this issue Sep 6, 2019 · 3 comments

Comments

@alanpang1990301
Copy link

@alanpang1990301 alanpang1990301 commented Sep 6, 2019

Dear Zipline Maintainers,

Before I tell you about my issue, let me describe my environment:

Environment

  • Operating System: (macOS Mojave Version 10.14.6)
  • Python Version: 3.5.6
  • Python Bitness: 64
  • How did you install Zipline: Conda
    I run this:
    conda create -n py35 python=3.5
    then run this :
    conda activate py35
    then run this:
    conda install -c Quantopian zipline
  • Python packages:

ca-certificates 2019.5.15 1
certifi 2018.8.24 py35_1
libcxx 4.0.1 hcfea43d_1
libcxxabi 4.0.1 hcfea43d_1
libedit 3.1.20181209 hb402a30_0
libffi 3.2.1 h475c297_4
ncurses 6.1 h0a44026_1
openssl 1.0.2s h1de35cc_0
pip 10.0.1 py35_0
python 3.5.6 hc167b69_0
readline 7.0 h1de35cc_5
setuptools 40.2.0 py35_0
sqlite 3.29.0 ha441bb4_0
tk 8.6.8 ha441bb4_0
wheel 0.31.1 py35_0
xz 5.2.4 h1de35cc_4
zlib 1.2.11 h1de35cc_3

Now that you know a little about me, let me tell you about the issue I am
having:

UnsatisfiableError: The following specifications were found to be incompatible with each other:
Package numpy conflicts for:
zipline -> numpy[version='1.10.|1.8.|1.9.|>=1.11,<1.12.0a0|>=1.14,<1.15.0a0']
Package intervaltree conflicts for:
zipline -> intervaltree[version='>=2.1.0']
Package alembic conflicts for:
zipline -> alembic[version='>=0.7.7']
Package pip conflicts for:
python=3.5 -> pip
zipline -> pip[version='>=7.1.0']
Package libcxx conflicts for:
python=3.5 -> libcxx[version='>=4.0.1']
Package requests conflicts for:
zipline -> requests[version='>=2.9.1']
Package scipy conflicts for:
zipline -> scipy[version='>=0.15.1|>=0.17.1']
Package decorator conflicts for:
zipline -> decorator[version='>=4.0.0']
Package xz conflicts for:
python=3.5 -> xz[version='>=5.2.3,<6.0a0|>=5.2.4,<6.0a0']
Package trading-calendars conflicts for:
zipline -> trading-calendars[version='>=1.0.1']
Package lru-dict conflicts for:
zipline -> lru-dict[version='>=1.1.4']
Package pytz conflicts for:
zipline -> pytz[version='>=2015.4|>=2016.4']
Package pytables conflicts for:
zipline -> pytables[version='>=3.3.0']
Package matplotlib conflicts for:
zipline -> matplotlib
Package click conflicts for:
zipline -> click[version='>=4.0.0']
Package openssl conflicts for:
python=3.5 -> openssl[version='1.0.
|1.0.,>=1.0.2l,<1.0.3a|>=1.0.2m,<1.0.3a|>=1.0.2n,<1.0.3a|>=1.0.2o,<1.0.3a|>=1.0.2p,<1.0.3a']
Package networkx conflicts for:
zipline -> networkx[version='>=1.9.1|>=1.9.1,<2.0']
Package multipledispatch conflicts for:
zipline -> multipledispatch[version='>=0.4.8']
Package readline conflicts for:
python=3.5 -> readline[version='7.
|>=7.0,<8.0a0']
Package contextlib2 conflicts for:
zipline -> contextlib2[version='>=0.4.0']
Package cython conflicts for:
zipline -> cython[version='>=0.22.1|>=0.25.2']
Package markupsafe conflicts for:
zipline -> markupsafe[version='>=0.23']
Package bottleneck conflicts for:
zipline -> bottleneck[version='>=1.0.0']
Package sortedcontainers conflicts for:
zipline -> sortedcontainers[version='>=1.4.4']
Package patsy conflicts for:
zipline -> patsy[version='>=0.4.0']
Package bcolz conflicts for:
zipline -> bcolz[version='>=0.12.1|>=0.12.1,<1']
Package cyordereddict conflicts for:
zipline -> cyordereddict[version='>=0.2.2']
Package empyrical conflicts for:
zipline -> empyrical[version='>=0.1.11|>=0.2.2|>=0.4.2|>=0.5.0']
Package mako conflicts for:
zipline -> mako[version='>=1.0.1']
Package setuptools conflicts for:
zipline -> setuptools[version='>18.0']
Package requests-file conflicts for:
zipline -> requests-file[version='>=1.4.1']
Package toolz conflicts for:
zipline -> toolz[version='>=0.7.4|>=0.8.2']
Package numexpr conflicts for:
zipline -> numexpr[version='>=2.4.3|>=2.4.6|>=2.6.1']
Package logbook conflicts for:
zipline -> logbook[version='>=0.12.5']
Package ta-lib conflicts for:
zipline -> ta-lib
Package tk conflicts for:
python=3.5 -> tk[version='8.6.|>=8.6.7,<8.7.0a0']
Package cachetools conflicts for:
zipline -> cachetools[version='>=1.1.5']
Package ncurses conflicts for:
python=3.5 -> ncurses[version='>=6.0,<7.0a0|>=6.1,<7.0a0']
Package six conflicts for:
zipline -> six[version='>=1.10.0|>=1.9.0']
Package python-dateutil conflicts for:
zipline -> python-dateutil[version='>=2.4.2']
Package zlib conflicts for:
python=3.5 -> zlib[version='>=1.2.11,<1.3.0a0']
Package sqlalchemy conflicts for:
zipline -> sqlalchemy[version='>=1.0.8']
Package sqlite conflicts for:
python=3.5 -> sqlite[version='>=3.20.1,<4.0a0|>=3.22.0,<4.0a0|>=3.23.1,<4.0a0|>=3.24.0,<4.0a0']
Package statsmodels conflicts for:
zipline -> statsmodels[version='>=0.6.1']
Package libffi conflicts for:
python=3.5 -> libffi[version='3.2.
|>=3.2.1,<4.0a0']
Package pandas conflicts for:
zipline -> pandas[version='>=0.16.1|>=0.16.1,<0.18|>=0.18.1,<0.19|>=0.18.1,<=0.22']
Package pandas-datareader conflicts for:
zipline -> pandas-datareader[version='>=0.2.1|>=0.2.1,<0.6']

  • What did you expect to happen?
    No conflict
  • What happened instead?
    a lot of conflict
    Here is how you can reproduce this issue on your machine:

Reproduction Steps

Remove conda env and try again.

What steps have you taken to resolve this already?

try pip install also not working

Anything else?

no
Sincerely,
Alan

@rogerjbos

This comment has been minimized.

Copy link

@rogerjbos rogerjbos commented Sep 6, 2019

Its been fairly widely reported that conda 4.7+ is too strict and you have to downgrade conda to get zipline to install, Try running these lines:

conda config --set allow_conda_downgrades true
conda install conda=4.6.11
conda --version # Should say 4.6.11

If you succeed in downgrading conda to 4.6.11, try the install again and see what happens.

@alanpang1990301

This comment has been minimized.

Copy link
Author

@alanpang1990301 alanpang1990301 commented Sep 7, 2019

Its been fairly widely reported that conda 4.7+ is too strict and you have to downgrade conda to get zipline to install, Try running these lines:

conda config --set allow_conda_downgrades true
conda install conda=4.6.11
conda --version # Should say 4.6.11

If you succeed in downgrading conda to 4.6.11, try the install again and see what happens.

This works well. Thx

@MBpy

This comment has been minimized.

Copy link

@MBpy MBpy commented Sep 13, 2019

Hi,

I am quite new with installing packages with Conda.

When running the above lines:

conda config --set allow_conda_downgrades true
conda install conda=4.6.11

I got the following error:

WARNING conda.base.context:use_only_tar_bz2(632): Conda is constrained to only using the old .tar.bz2 file format because you have conda-build installed, and it is <3.18.3. Update or remove conda-build to get smaller downloads and faster extractions.
Collecting package metadata (repodata.json): done
Solving environment: failed

UnsatisfiableError: The following specifications were found to be incompatible with each other:

  • pip -> python[version='>=3.7,<3.8.0a0']

Can anyone help how to solve this error?

I would be grateful.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.