Skip to content
master
Switch branches/tags
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Quasar Framework logo

Quasar Framework App Extension starter kit

Starter Kit for a Quasar App Extension.

Usage

First, make sure you have Node (>= 8) and Yarn (> 1.6) or NPM (>= 5).

# remove old CLI if you have it
$ npm uninstall -g quasar-cli

# install the latest Quasar CLI version:
$ npm install -g @quasar/cli

# outside of a Quasar project folder,scaffold a new extension project
# with this CLI command
$ quasar create my-extension --kit app-extension --branch next

$ cd my-extension

Quasar Framework

Build responsive Single Page Apps, SSR Apps, PWAs, Hybrid Mobile Apps and Electron Apps, all using the same codebase!, powered with Vue.

Supporting Quasar

Quasar Framework is an MIT-licensed open source project. Its ongoing development is made possible thanks to the support by these awesome backers.

Please read our manifest on Why donations are important. If you'd like to become a donator, check out Quasar Framework's Donator campaign.

Documentation

Head on to the Quasar Framework official website: https://quasar.dev

Community Forum

Head on to the official community forum: https://forum.quasar.dev

Contributing

I'm excited if you want to contribute to Quasar under any form (report bugs, write a plugin, fix an issue, write a new feature).

Issue Reporting Guidelines

Please use the appropriate Github repo to report issues. See "Related Components" above. For example, a bug related to CLI should be reported to the CLI repo, one related to build issues to Quasar Framework Templates repo and so on.

  • The issue list of the repository is exclusively for bug reports and feature requests. For anything else please use the Community Forum.

  • Try to search for your issue, it may have already been fixed in the development branch or it may have a resolution.

  • Check if the issue is reproducible with the latest stable version of Quasar. If you are using a pre-release, please indicate the specific version you are using.

  • It is required that you clearly describe the steps necessary to reproduce the issue you are running into. Issues with no clear repro steps will not be triaged. If an issue labeled "need repro" receives no further input from the issue author for more than 5 days, it will be closed.

  • If your issue is resolved but still open, don’t hesitate to close it. In case you found a solution by yourself, it could be helpful to explain how you fixed it.

License

Copyright (c) 2016-present Razvan Stoenescu

MIT License

About

Quasar Framework starter kit for creating App Extensions

Resources

License

Releases

No releases published

Sponsor this project

 

Packages

No packages published